Get rid of spurious error message when started from a window manager

Install man page
This commit is contained in:
hauke 2018-02-08 09:43:32 +00:00
parent 3330788a52
commit 0bd4e2b42d
4 changed files with 23 additions and 5 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.45 2018/02/07 11:58:31 hauke Exp $
# $NetBSD: Makefile,v 1.46 2018/02/08 09:43:32 hauke Exp $
DISTNAME= xcircuit-3.9.72
#PKGREVISION= 1
PKGREVISION= 1
CATEGORIES= cad graphics
MASTER_SITES= http://opencircuitdesign.com/xcircuit/archive/
EXTRACT_SUFX= .tgz
@ -37,6 +37,7 @@ post-extract:
${TOUCH} ${WRKSRC}/menudep.h
post-install:
${INSTALL_DATA} ${WRKSRC}/lib/xcircuit.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
${INSTALL_DATA} ${WRKSRC}/examples/*.* ${DESTDIR}${PREFIX}/${EGDIR}
${INSTALL_DATA} ${WRKSRC}/examples/xcircuitrc ${DESTDIR}${PREFIX}/${EGDIR}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2018/02/07 11:58:31 hauke Exp $
@comment $NetBSD: PLIST,v 1.9 2018/02/08 09:43:32 hauke Exp $
bin/xcircuit
lib/xcircuit-3.9/analog.lps
lib/xcircuit-3.9/analoglib2.lps
@ -124,6 +124,7 @@ lib/xcircuit-3.9/xcircuit.so
lib/xcircuit-3.9/xcircuit.tcl
lib/xcircuit-3.9/xcstartup.tcl
lib/xcircuit-3.9/xspice.lps
man/man1/xcircuit.1
share/examples/xcircuit/FlareLED.ps
share/examples/xcircuit/USAflag.ps
share/examples/xcircuit/analog1.ps
@ -147,4 +148,3 @@ share/examples/xcircuit/vcoblock.ps
share/examples/xcircuit/xc_remote.sh
share/examples/xcircuit/xcclock.ps
share/examples/xcircuit/xcircuitrc
@pkgdir man/man1

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.19 2018/02/07 11:58:31 hauke Exp $
$NetBSD: distinfo,v 1.20 2018/02/08 09:43:32 hauke Exp $
SHA1 (xcircuit-3.9.72.tgz) = d08137afb8f990e1b06aa842f1e80c0e00d8c0d7
RMD160 (xcircuit-3.9.72.tgz) = abb7eb3ffb1bfcd2c515537d43f4ba240c6f1508
@ -6,3 +6,4 @@ SHA512 (xcircuit-3.9.72.tgz) = daaca69bdd29f5ffb345498ca15dc5a46c478a4e9cea50724
Size (xcircuit-3.9.72.tgz) = 1620798 bytes
SHA1 (patch-aa) = 40e5caea7f6e6294eebff214f47aa9dc01498133
SHA1 (patch-ab) = 8c4d87dbd67b302f530b4f09201c82fcbec22dd5
SHA1 (patch-lib_tcl_xcircuit.sh.in) = 0c9882162bdd1cbd7f43d2e4aa2f329f3f91f958

View file

@ -0,0 +1,16 @@
$NetBSD: patch-lib_tcl_xcircuit.sh.in,v 1.1 2018/02/08 09:43:32 hauke Exp $
TERM may be empty, resulting in a spurious
[: cygwin: unexpected operator
--- lib/tcl/xcircuit.sh.in.orig 2014-05-17 14:15:47.000000000 +0000
+++ lib/tcl/xcircuit.sh.in
@@ -11,7 +11,7 @@ XCIRCUIT_WISH=WISH_EXE
export XCIRCUIT_WISH
# Hacks for Cygwin
-if [ ${TERM:=""} = "cygwin" ]; then
+if [ x${TERM:=""} = x"cygwin" ]; then
export PATH=$PATH:TCLLIBDIR
export DISPLAY=${DISPLAY:=":0"}
fi