Make this package compile when using gcc 3.3.

This commit is contained in:
kristerw 2004-05-23 23:35:12 +00:00
parent 6e8f676783
commit 0bdb725356
2 changed files with 39 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2001/11/21 18:27:18 nra Exp $ $NetBSD: distinfo,v 1.2 2004/05/23 23:35:12 kristerw Exp $
SHA1 (newmail-1.0.1.tar.gz) = 031387e2ba10e5e4ba801dab25d86fce3b55e02c SHA1 (newmail-1.0.1.tar.gz) = 031387e2ba10e5e4ba801dab25d86fce3b55e02c
Size (newmail-1.0.1.tar.gz) = 3476 bytes Size (newmail-1.0.1.tar.gz) = 3476 bytes
SHA1 (patch-aa) = a0937e803e029fa53351a18cad47a0f05a85e4a0

View file

@ -0,0 +1,37 @@
$NetBSD: patch-aa,v 1.1 2004/05/23 23:35:12 kristerw Exp $
--- newmail.c.orig 2004-05-24 01:29:15.000000000 +0200
+++ newmail.c 2004-05-24 01:32:01.000000000 +0200
@@ -148,19 +148,19 @@
static void usage() {
- fprintf(stderr,"usage: newmail [-deirv] directory|file directory|file ...
-
-where:
- d: Prints messages when you do not have new mail
- e: Exits with 0 on no new mail, 1 on new mail, > 1 on error
- (normally exits with a value from sysexits(3)). May not be used
- with -d or -i.
- i: Prints a message for each mailbox that has new mail (and those
- that don't if -d is also used)
- r: Warns if it finds a non regular file
- v: Print version number and exit
-
-directory|file are, respectively, directories to look in for mailboxes
+ fprintf(stderr,"usage: newmail [-deirv] directory|file directory|file ...\n\
+\n\
+where:\n\
+ d: Prints messages when you do not have new mail\n\
+ e: Exits with 0 on no new mail, 1 on new mail, > 1 on error\n\
+ (normally exits with a value from sysexits(3)). May not be used\n\
+ with -d or -i.\n\
+ i: Prints a message for each mailbox that has new mail (and those\n\
+ that don't if -d is also used)\n\
+ r: Warns if it finds a non regular file\n\
+ v: Print version number and exit\n\
+ \n\
+directory|file are, respectively, directories to look in for mailboxes\n\
and mailboxes.\n");
exit(EX_USAGE);