Add missing includes from libstdc++'s namespace pollution. Let the

compiler figure out which types std::advance is used with.
This commit is contained in:
joerg 2013-04-29 21:27:15 +00:00
parent b2a8fad234
commit 0bf668714e
8 changed files with 123 additions and 15 deletions

View file

@ -1,16 +1,21 @@
$NetBSD: distinfo,v 1.5 2012/06/28 05:24:22 dholland Exp $
$NetBSD: distinfo,v 1.6 2013/04/29 21:27:15 joerg Exp $
SHA1 (blackbox-0.70.1.tar.gz) = f0ab7e4b44ae6ee4c2a2136651afc567c47fe2cd
RMD160 (blackbox-0.70.1.tar.gz) = ab80c43d42dbfac23c9f981885f25a42c66f51a6
Size (blackbox-0.70.1.tar.gz) = 650400 bytes
SHA1 (patch-aa) = 36e90d9a54329009c1d1fd9788ebe349858578b3
SHA1 (patch-ab) = 30633230592a0b81002bdddbb1128694acde9d10
SHA1 (patch-ab) = 1e568872f238e05be11d2a4f25cc38c9fa461b71
SHA1 (patch-ac) = 5f7132230ab4c53bf5042a274592bae45c6a15ed
SHA1 (patch-lib-Resource.cc) = 8ac7fee379aa940f85c7800572be5ee3bb4202c5
SHA1 (patch-lib-Util.hh) = b0bbf923ee06d200666ce96b6bf5ad648b361fd8
SHA1 (patch-lib-XDG.cc) = 55422803fd20b8f100816a204de7af22f00ba51c
SHA1 (patch-lib_Display.cc) = 3b9c3dd6f9a309d4dc77409f3523608214e52926
SHA1 (patch-lib_Pen.cc) = 41da4c0b2aad21d875be6521257e791926b31143
SHA1 (patch-lib_Texture.cc) = 9c076e2f47d7ca99f422098323f19b60bbf389b4
SHA1 (patch-src-BlackboxResource.cc) = 66d022f7a91f2054c45c3f38a0fe98da4ddce3de
SHA1 (patch-src-ScreenResource.cc) = ec09befadf9e92bd9e9543f7e9b472639bf6e8d5
SHA1 (patch-src-Toolbar.cc) = 6f301302c3370b67feb22dc066ed4aac0624d23d
SHA1 (patch-src-main.cc) = 1b004b5860473300afc02fa50d6fc89523ab1b59
SHA1 (patch-src-main.cc) = c5469f129f13b77c403ae54beba134ab26631652
SHA1 (patch-src_Window.cc) = fbf093e74c4d1779e65830ad6c32c0733bfc5ee3
SHA1 (patch-src_blackbox.cc) = a17c3eec5f6375feb8e68c4d53811bae5ab94d5b
SHA1 (patch-util-bsetroot.cc) = 87b3e5aab03facfce88286f25df14580c39582c6

View file

@ -1,10 +1,49 @@
$NetBSD: patch-ab,v 1.1 2008/01/14 02:04:41 rillig Exp $
$NetBSD: patch-ab,v 1.2 2013/04/29 21:27:15 joerg Exp $
Sunpro has problems with a non-const const_reverse_iterator.
--- lib/Menu.cc.orig 2005-01-27 18:08:22.000000000 +0100
+++ lib/Menu.cc 2007-12-05 16:08:11.094236000 +0100
@@ -1052,10 +1052,10 @@ void bt::Menu::keyPressEvent(const XKeyE
--- lib/Menu.cc.orig 2005-01-27 17:08:22.000000000 +0000
+++ lib/Menu.cc
@@ -33,9 +33,9 @@
#include <X11/Xlib.h>
#include <X11/keysym.h>
-#include <stdio.h>
#include <assert.h>
-
+#include <stdio.h>
+#include <stdlib.h>
bt::MenuStyle **bt::MenuStyle::styles = 0;
@@ -363,7 +363,7 @@ unsigned int bt::Menu::insertItem(const
} else {
index = std::min(static_cast<size_t>(index), _items.size());
it = _items.begin();
- std::advance<ItemList::iterator, signed>(it, index);
+ std::advance(it, index);
}
it = _items.insert(it, item);
@@ -514,7 +514,7 @@ void bt::Menu::removeItem(unsigned int i
void bt::Menu::removeIndex(unsigned int index) {
ItemList::iterator it = _items.begin();
- std::advance<ItemList::iterator, signed>(it, index);
+ std::advance(it, index);
if (it == _items.end())
return; // item not found
removeItemByIterator(it);
@@ -1035,7 +1035,7 @@ void bt::Menu::keyPressEvent(const XKeyE
const ItemList::const_iterator &end = _items.end();
ItemList::const_iterator anchor = _items.begin();
if (_active_index != ~0u) {
- std::advance<ItemList::const_iterator, signed>(anchor, _active_index);
+ std::advance(anchor, _active_index);
// go one paste the current active index
if (anchor != end && !anchor->separator)
@@ -1052,11 +1052,10 @@ void bt::Menu::keyPressEvent(const XKeyE
}
case XK_Up: {
@ -14,11 +53,12 @@ Sunpro has problems with a non-const const_reverse_iterator.
+ const ItemList::reverse_iterator &end = _items.rend();
if (_active_index != ~0u) {
- std::advance<ItemList::const_reverse_iterator, signed>
+ std::advance<ItemList::reverse_iterator, signed>
(anchor, _items.size() - _active_index - 1);
- (anchor, _items.size() - _active_index - 1);
+ std::advance(anchor, _items.size() - _active_index - 1);
// go one item past the current active index
@@ -1065,7 +1065,7 @@ void bt::Menu::keyPressEvent(const XKeyE
if (anchor != end && !anchor->separator)
@@ -1065,7 +1064,7 @@ void bt::Menu::keyPressEvent(const XKeyE
if (anchor == end) anchor = _items.rbegin();
@ -27,7 +67,7 @@ Sunpro has problems with a non-const const_reverse_iterator.
std::find_if(anchor, end, InteractMatch());
if (it != end)
activateIndex(it->indx);
@@ -1073,8 +1073,8 @@ void bt::Menu::keyPressEvent(const XKeyE
@@ -1073,8 +1072,8 @@ void bt::Menu::keyPressEvent(const XKeyE
}
case XK_Home: {
@ -38,7 +78,7 @@ Sunpro has problems with a non-const const_reverse_iterator.
it = std::find_if(it, end, InteractMatch());
if (it != end)
activateIndex(it->indx);
@@ -1082,8 +1082,8 @@ void bt::Menu::keyPressEvent(const XKeyE
@@ -1082,8 +1081,8 @@ void bt::Menu::keyPressEvent(const XKeyE
}
case XK_End: {

View file

@ -0,0 +1,13 @@
$NetBSD: patch-lib_Display.cc,v 1.1 2013/04/29 21:27:15 joerg Exp $
--- lib/Display.cc.orig 2013-04-28 12:56:05.000000000 +0000
+++ lib/Display.cc
@@ -31,7 +31,7 @@
#include <assert.h>
#include <fcntl.h>
#include <stdio.h>
-
+#include <stdlib.h>
namespace bt {

View file

@ -0,0 +1,12 @@
$NetBSD: patch-lib_Pen.cc,v 1.1 2013/04/29 21:27:15 joerg Exp $
--- lib/Pen.cc.orig 2013-04-28 12:57:35.000000000 +0000
+++ lib/Pen.cc
@@ -36,6 +36,7 @@
#include <assert.h>
#include <stdio.h>
+#include <stdlib.h>
// #define PENCACHE_DEBUG

View file

@ -0,0 +1,13 @@
$NetBSD: patch-lib_Texture.cc,v 1.1 2013/04/29 21:27:15 joerg Exp $
--- lib/Texture.cc.orig 2013-04-28 12:59:39.000000000 +0000
+++ lib/Texture.cc
@@ -31,7 +31,7 @@
#include <X11/Xlib.h>
#include <ctype.h>
-
+#include <stdlib.h>
void bt::Texture::setColor1(const bt::Color &new_color) {
c1 = new_color;

View file

@ -1,12 +1,13 @@
$NetBSD: patch-src-main.cc,v 1.1 2011/11/22 20:02:48 joerg Exp $
$NetBSD: patch-src-main.cc,v 1.2 2013/04/29 21:27:15 joerg Exp $
--- src/main.cc.orig 2011-11-22 18:56:19.000000000 +0000
--- src/main.cc.orig 2005-01-03 09:42:57.000000000 +0000
+++ src/main.cc
@@ -35,7 +35,7 @@
@@ -35,7 +35,8 @@
#include "../version.h"
#include <stdio.h>
-
+#include <stdlib.h>
+#include <string.h>
static void showHelp(int exitval) {

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_Window.cc,v 1.1 2013/04/29 21:27:15 joerg Exp $
--- src/Window.cc.orig 2013-04-28 13:03:26.000000000 +0000
+++ src/Window.cc
@@ -43,6 +43,7 @@
#endif
#include <assert.h>
+#include <stdlib.h>
/*
sometimes C++ is a pain in the ass... it gives us stuff like the

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_blackbox.cc,v 1.1 2013/04/29 21:27:15 joerg Exp $
--- src/blackbox.cc.orig 2013-04-28 13:04:23.000000000 +0000
+++ src/blackbox.cc
@@ -35,6 +35,7 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <assert.h>
+#include <stdlib.h>
#include <signal.h>
#include <unistd.h>