Engine_pkcs11 is a PKCS#11 engine for OpenSSL. It can be loaded using code,
config file or command line and will pass any function call by openssl to a PKCS#11 module. Engine_pkcs11 is meant to be used with smart cards and software for using smart cards in PKCS#11 format, such as OpenSC. Originaly this engine was a part of OpenSC, until OpenSC was split into several small projects for improved flexibility.
This commit is contained in:
parent
01e775f711
commit
0bfe3d7430
5 changed files with 57 additions and 0 deletions
8
security/engine-pkcs11/DESCR
Normal file
8
security/engine-pkcs11/DESCR
Normal file
|
@ -0,0 +1,8 @@
|
|||
Engine_pkcs11 is a PKCS#11 engine for OpenSSL. It can be loaded using code,
|
||||
config file or command line and will pass any function call by openssl to a
|
||||
PKCS#11 module.
|
||||
|
||||
Engine_pkcs11 is meant to be used with smart cards and software for using
|
||||
smart cards in PKCS#11 format, such as OpenSC. Originaly this engine was a
|
||||
part of OpenSC, until OpenSC was split into several small projects for
|
||||
improved flexibility.
|
25
security/engine-pkcs11/Makefile
Normal file
25
security/engine-pkcs11/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/03/05 20:30:52 hasso Exp $
|
||||
#
|
||||
|
||||
DISTNAME= engine_pkcs11-0.1.5
|
||||
PKGNAME= ${DISTNAME:S/_/-/}
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.opensc-project.org/files/engine_pkcs11/
|
||||
|
||||
MAINTAINER= hasso@NetBSD.org
|
||||
HOMEPAGE= http://www.opensc-project.org/engine_pkcs11/
|
||||
COMMENT= PKCS\#11 engine for OpenSSL
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.7
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
CONFIGURE_ARGS+= --with-openssl=${SSLBASE:Q}
|
||||
|
||||
.include "../../security/libp11/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
security/engine-pkcs11/PLIST
Normal file
2
security/engine-pkcs11/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/03/05 20:30:52 hasso Exp $
|
||||
lib/engines/engine_pkcs11.so
|
6
security/engine-pkcs11/distinfo
Normal file
6
security/engine-pkcs11/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/03/05 20:30:52 hasso Exp $
|
||||
|
||||
SHA1 (engine_pkcs11-0.1.5.tar.gz) = 189da9a9156c86df99d16567acbf141869f87729
|
||||
RMD160 (engine_pkcs11-0.1.5.tar.gz) = e1edcab5008cc0d524c904808de3344b9520700e
|
||||
Size (engine_pkcs11-0.1.5.tar.gz) = 355324 bytes
|
||||
SHA1 (patch-aa) = 996cdb0f077c923a2c2552ad03443e449b7c70fe
|
16
security/engine-pkcs11/patches/patch-aa
Normal file
16
security/engine-pkcs11/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/03/05 20:30:52 hasso Exp $
|
||||
|
||||
--- Makefile.in.orig 2009-03-05 16:05:48 +0200
|
||||
+++ Makefile.in 2009-03-05 16:24:01 +0200
|
||||
@@ -227,9 +227,9 @@ MAINTAINERCLEANFILES = \
|
||||
$(srcdir)/packaged
|
||||
|
||||
EXTRA_DIST = svnignore
|
||||
-SUBDIRS = src doc
|
||||
+SUBDIRS = src
|
||||
dist_noinst_SCRIPTS = bootstrap
|
||||
-dist_doc_DATA = NEWS
|
||||
+dist_doc_DATA =
|
||||
all: config.h
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|
||||
|
Loading…
Reference in a new issue