Remove the non-applicable warning about CADIR. Bump PKGREVISION.

This commit is contained in:
schmonz 2021-01-13 09:21:22 +00:00
parent 052a3442d4
commit 0c06d639db
3 changed files with 18 additions and 2 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.4 2021/01/11 18:31:10 schmonz Exp $
# $NetBSD: Makefile,v 1.5 2021/01/13 09:21:22 schmonz Exp $
DISTNAME= s6-networking-2.4.0.0
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= ${HOMEPAGE}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2021/01/11 18:31:10 schmonz Exp $
$NetBSD: distinfo,v 1.3 2021/01/13 09:21:22 schmonz Exp $
SHA1 (s6-networking-2.4.0.0.tar.gz) = 7b013b0181d5873555bbaead902533429db207ae
RMD160 (s6-networking-2.4.0.0.tar.gz) = 21fd26cff9868096d297b415f74e799da3db10ab
SHA512 (s6-networking-2.4.0.0.tar.gz) = e8646bbfe965db0a736b1624e3533151182fd0d0337c08ab6af52f6872af1e8c82e3afa85fd146fec3f0640360173aa57182065982e1f3d60ec16862f449115b
Size (s6-networking-2.4.0.0.tar.gz) = 102302 bytes
SHA1 (patch-src_stls_stls__client__init__and__handshake.c) = 5ba7652cca7fc864cfff31939fa196086d4336f6

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_stls_stls__client__init__and__handshake.c,v 1.1 2021/01/13 09:21:22 schmonz Exp $
LibreSSL has this problem; OpenSSL + LibreTLS do not.
--- src/stls/stls_client_init_and_handshake.c.orig 2020-11-23 15:28:30.000000000 +0000
+++ src/stls/stls_client_init_and_handshake.c
@@ -50,7 +50,6 @@ struct tls *stls_client_init_and_handsha
{
if (tls_config_set_ca_path(cfg, x) < 0)
diecfg(cfg, "tls_config_set_ca_path") ;
- strerr_warnw1x("some versions of libtls do not work with CADIR, try using CAFILE instead") ;
}
else strerr_diefu1x(100, "get trust anchor list: neither CADIR nor CAFILE is set") ;
}