* Update rplay to 3.3.2.

* Libtoolize build.
* Teach rplay to look for libedit readline emulation if it exists.
* Add dependency on rx-1.5.

Changes since rplay 3.3.1:

* Added devrplay.so which can be used with LD_PRELOAD to add rplay support
  to audio applications use /dev/dsp.  devrplay is known to work with rvplayer,
  xmp, mpg123, freeamp, s3mod, esd (Enlightenment Sound Daemon) and even
  rplayd itself.  devrplay.so should be installed in your LD_LIBRARY_PATH.
  Example usage:

  bash$ LD_PRELOAD=devrplay.so rvplayer
  bash$ LD_PRELOAD=devrplay.so /usr/X11R6/lib/X11/rvplayer/rvplayer
  bash$ LD_PRELOAD=devrplay.so dd if=/foo/bar/sound.wav of=/dev/dsp
  bash$ LD_PRELOAD=devrplay.so xxmp sound.mod
  bash$ LD_PRELOAD=devrplay.so mpg123 sound.mp3

  tcsh users will probably need to `setenv LD_PRELOAD devrplay.so; command'
  instead of using the `LD_PRELOAD=devrplay.so command' syntax.

  devrplay has only been tested on Linux, but it should be possible to
  get it working on other systems.

* Added rptp "set" command.  This can be used to set rplayd
  variables.  One important use of this is to set the audio-close
  variable.  Examples:

  Tell rplayd to close the audio device:
  $ rptp set audio-close 1

  Tell rplayd *not* to close the audio device:
  $ rptp set audio-close 0

* Added rplayd monitor support which allows rptp clients to monitor
  audio data that is written to the audio device.  rptp clients can
  now issue the "monitor" command to start receiving audio data.
  One use of this feature is to pipe the audio data to a program
  for visual display.

* rptp includes support for GNU readline and also displays progress
  information when doing get, put, and monitor.

* Fixed several potential rplayd buffer overflows.

Changes since rplay 3.2:

* Improved Linux support, including playing sounds directly
  from ATAPI CDROM.  Tested with the following:

      Linux 2.0.34
      Debian 2.0
      ESS ES1688 AudioDrive (rev 6) (3.1)
      TOSHIBA CD-ROM XM-1502B, ATAPI CDROM drive

  This also includes a new --audio-fragsize rplayd option.  See
  README.linux for more information.

* Support for external helper applications used to convert
  unsupported audio formats.  Helpers can be configured to
  support formats such as MPEG (using mpg123), modules
  (using xmp), and any other format that can be converted
  using a stdin -> stdout filter.

* --fork and --no-fork rplayd options.  When not in debug or inetd
  mode, rplayd will fork to put itself in the background.

* rplayd is now installed in $prefix/sbin/rplayd instead of
  $prefix/bin/rplayd.

* Running rplayd from inetd now requires the --inetd option.

* --enable-rplayd-user=USER and --enable-rplayd-group=GROUP
  configure options.

* --user=USER and --group=GROUP rplayd options.

* Lots of bug fixes.
This commit is contained in:
jlam 2000-01-26 22:11:28 +00:00
parent 1944e9c4ea
commit 0c171b3485
24 changed files with 519 additions and 200 deletions

View file

@ -1,40 +1,43 @@
# $NetBSD: Makefile,v 1.15 2000/01/02 03:07:31 wiz Exp $
# $NetBSD: Makefile,v 1.16 2000/01/26 22:11:28 jlam Exp $
# FreeBSD Id: Makefile,v 1.8 1997/06/13 16:17:01 ache Exp
#
DISTNAME= rplay-3.2.0b6
DISTNAME= rplay-3.3.2
CATEGORIES= audio
MASTER_SITES= ftp://ftp.sdsu.edu/pub/rplay/
MASTER_SITES= ftp://rplay.doit.org/pub/rplay/ \
http://rplay.doit.org/dist/
MAINTAINER= rmallory@csusb.edu
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://rplay.doit.org/
BUILD_DEPENDS+= ${LOCALBASE}/bin/autoreconf:../../devel/autoconf
DEPENDS+= gsm-1.0.10:../../audio/gsm
DEPENDS+= rx-1.5:../../devel/rx
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=${PREFIX}"
CONFIGURE_ENV+= RPLAY_TARGET=generic # XXX
CONFIGURE_ENV+= CFLAGS=-I${PREFIX}/include # XXX
CONFIGURE_ENV+= LDFLAGS=-L${PREFIX}/lib # XXX
INFO_FILES= RPTP.info RPLAY.info rplay.info librplay.info
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= RPLAY_TARGET=generic # XXX generic, or oss, or sun?
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include # for gsm.h and rxposix.h
.if !exists(/usr/include/readline.h)
DEPENDS+= readline-4.0:../../devel/readline
.endif
INFO_FILES= RPLAY.info RPLAY.info librplay.info rplay.info
pre-configure:
for f in `${FIND} ${WRKDIR}/. -type f -print|xargs ${GREP} -l '/usr/local'`; do \
${SED} -e 's:/usr/local:'${PREFIX}':g' < $$f > $$f.pdone && ${MV} $$f.pdone $$f; \
cd ${WRKSRC}; ${LOCALBASE}/bin/autoreconf
cd ${WRKSRC}/doc; for f in *.[0-9]; do \
${SED} -e "s,/usr/local,${PREFIX},g" < $$f > $$f.pdone; \
${MV} -f $$f.pdone $$f; \
done
${CHMOD} +x ${WRKSRC}/configure
post-build:
cd ${WRKSRC}/doc ; ${MAKE} info
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/rplayd.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/rplayd.sh startup file."; \
${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/rplayd.sh; \
${ECHO} "[ -x ${PREFIX}/sbin/rplayd ] && ( ${PREFIX}/sbin/rplayd & ) && ${ECHO} -n ' rplayd'" >> ${PREFIX}/etc/rc.d/rplayd.sh; \
${CHMOD} 751 ${PREFIX}/etc/rc.d/rplayd.sh; \
fi
@if [ ! -f ${PREFIX}/etc/rplay.hosts ]; then \
${ECHO} localhost > ${PREFIX}/etc/rplay.hosts; \
fi
${SED} -e "s,@PREFIX@,${PREFIX},g" \
< ${FILESDIR}/rplayd.sh > ${WRKDIR}/rplayd.sh
${INSTALL_SCRIPT} ${WRKDIR}/rplayd.sh ${PREFIX}/etc/rc.d/rplayd.sh
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} POST-INSTALL
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 1998/08/07 13:16:55 agc Exp $
$NetBSD: md5,v 1.3 2000/01/26 22:11:36 jlam Exp $
MD5 (rplay-3.2.0b6.tar.gz) = d8346e6f132193d076341de0d9fa35ca
MD5 (rplay-3.3.2.tar.gz) = e39888f6bea32e1c8cf4a8880b416e56

View file

@ -1,10 +1,19 @@
$NetBSD: patch-sum,v 1.3 1999/07/23 13:38:27 tron Exp $
$NetBSD: patch-sum,v 1.4 2000/01/26 22:11:36 jlam Exp $
MD5 (patch-aa) = 2de25c74db0d2fb5350c3cb9015c417a
MD5 (patch-ab) = 3d9cb679a5b603461b7a35b9d32f8f9e
MD5 (patch-ac) = adb570bc992db7a1c2bcade30d5edb10
MD5 (patch-ad) = b79b042ca97ac9bb83b97d2c1e5c3bcc
MD5 (patch-af) = ec41972ce9630a213d43ec1f538e1121
MD5 (patch-ag) = c85d42af17145c1f0ad3d456921ab3a1
MD5 (patch-ah) = f5f0ca854711d3f616c8968a4e520e2d
MD5 (patch-ai) = eec3eb6317516d0e59e50ccd5aca40ae
MD5 (patch-aa) = b7c2fb4dd8312722e3f7e0fb563762b7
MD5 (patch-ab) = 773fc224f922bc118cc2bd8588433111
MD5 (patch-ac) = c9b0c883d724624ec9b906a74e1cb1d1
MD5 (patch-ad) = b483c02f96b1d84c9b9f1d7c25ea5497
MD5 (patch-ae) = 381cd32626ed6cd2295cfa1ddde59d99
MD5 (patch-af) = ab9948e27a022ab35018c43455f40e6a
MD5 (patch-ag) = 581eef0032f72afd2235340eb4060a8d
MD5 (patch-ah) = bfdfd957c0650252581dedd1285ec8df
MD5 (patch-ai) = a10e0d05d678449689099b8bbaed7dd5
MD5 (patch-aj) = a457b54365015d8724ae0d0b26fb2d2e
MD5 (patch-ak) = f2b7cdbf17cd8816078e428e461e69f4
MD5 (patch-al) = 27287f4b6b816a9c879186fcf379dacc
MD5 (patch-am) = 77eeee99efce2a034dcf8fc4bd8ba288
MD5 (patch-an) = 97950cd83a400c5b6c8d56433c773eba
MD5 (patch-ao) = 01ae3b252bb43545e73b10922a972efe
MD5 (patch-ap) = f2612eebed1114e3008b029e53a761bc
MD5 (patch-aq) = c494a36ae18757468fded9536c58b042

View file

@ -0,0 +1,7 @@
#!/bin/sh
#
# $NetBSD: rplayd.sh,v 1.1 2000/01/26 22:11:36 jlam Exp $
if [ -x @PREFIX@/sbin/rplayd ]; then
echo -n ' rplayd'; @PREFIX@/sbin/rplayd
fi

View file

@ -1,25 +1,21 @@
$NetBSD: patch-aa,v 1.2 1998/08/07 10:36:07 agc Exp $
$NetBSD: patch-aa,v 1.3 2000/01/26 22:11:36 jlam Exp $
*** configure.bak Fri Feb 2 03:30:38 1996
--- configure Fri Jun 13 19:14:52 1997
***************
*** 2589,2597 ****
if test "$no_x" = "yes" -o "$HAVE_FORMS" = "no"; then
! BUILD_TARGETS="include lib adpcm gsm librplay rplayd rplay rptp doc"
else
! BUILD_TARGETS="include lib adpcm gsm librplay rplayd rplay rptp xrplay doc"
fi
--- 2589,2597 ----
if test "$no_x" = "yes" -o "$HAVE_FORMS" = "no"; then
! BUILD_TARGETS="include lib adpcm librplay rplayd rplay rptp doc"
else
! BUILD_TARGETS="include lib adpcm librplay rplayd rplay rptp xrplay doc"
fi
--- Makefile.config.in.orig Thu Aug 13 02:12:59 1998
+++ Makefile.config.in Tue Jan 18 16:15:32 2000
@@ -43,6 +43,7 @@
#CC_OPTIONS= -O -cckr # SGI
#CC_OPTIONS= -O # generic
#CC_OPTIONS= -g # debug
+CC_OPTIONS= @CPPFLAGS@ # hack to add CPPFLAGS
##
## Extra linker options.
@@ -53,7 +54,7 @@
##
## Name of the rplay library to build.
##
-LIBRPLAY_NAME= librplay.a
+LIBRPLAY_NAME= librplay.la
#LIBRPLAY_NAME= librplay.sl # HP-UX
##

View file

@ -1,41 +1,34 @@
$NetBSD: patch-ab,v 1.2 1998/08/07 10:36:07 agc Exp $
$NetBSD: patch-ab,v 1.3 2000/01/26 22:11:36 jlam Exp $
*** rplayd/Makefile.in.orig Fri Feb 2 03:13:57 1996
--- rplayd/Makefile.in Fri Jun 13 19:31:38 1997
***************
*** 1,4 ****
--- 1,5 ----
include @RPLAY_TOP@/Makefile.config
+ bindir= $(exec_prefix)/sbin
srcdir = @srcdir@
VPATH = @srcdir@
***************
*** 9,21 ****
MKINSTALLDIRS= @srcdir@/../mkinstalldirs
CPPFLAGS= $(CC_OPTIONS) -I. -I../include -I@srcdir@ -I@srcdir@/../include -I@srcdir@/../lib \
! -I@srcdir@/../adpcm -I@srcdir@/../gsm @DEFS@
.c.o:
$(CC) -c $(CPPFLAGS) $(CFLAGS) $<
LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp \
! -L../adpcm -ladpcm -L../gsm -lgsm @LDFLAGS@ @LIBS@ -lm
TARGET= rplayd
--- 10,22 ----
MKINSTALLDIRS= @srcdir@/../mkinstalldirs
CPPFLAGS= $(CC_OPTIONS) -I. -I../include -I@srcdir@ -I@srcdir@/../include -I@srcdir@/../lib \
! -I@srcdir@/../adpcm -I/usr/local/include @DEFS@
.c.o:
$(CC) -c $(CPPFLAGS) $(CFLAGS) $<
LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp \
! -L../adpcm -ladpcm -L/usr/local/lib -lgsm @LDFLAGS@ @LIBS@ -lm
TARGET= rplayd
--- configure.in.orig Wed Jun 9 02:26:28 1999
+++ configure.in Tue Jan 18 16:20:01 2000
@@ -59,6 +59,7 @@
AC_HEADER_TIME
dnl AC_PATH_XTRA
AC_CHECK_HEADERS(fcntl.h sys/file.h sys/ioctl.h sys/time.h stdlib.h unistd.h memory.h string.h strings.h utime.h limits.h gsm.h gsm/gsm.h rxposix.h rx/rxposix.h)
+AC_CHECK_HEADERS(readline.h history.h readline/readline.h readline/history.h)
AC_HEADER_SYS_WAIT
dnl Check for typedefs, structures, and compiler characteristics.
@@ -74,7 +75,20 @@
AC_CHECK_LIB(socket, socket, [LIBS="$LIBS -lsocket"])
AC_CHECK_LIB(nsl, t_accept, [LIBS="$LIBS -lnsl"])
-AC_CHECK_LIB(readline, readline, [RL_LIBS="-lreadline"])
+if test "$ac_cv_header_readline_h" = "yes" ||
+ test "$ac_cv_header_readline_readline_h" = "yes"; then
+ AC_CHECK_LIB(termcap, tputs,
+ [AC_CHECK_LIB(edit, readline,
+ [AC_DEFINE(HAVE_LIBEDIT)
+ AC_DEFINE(HAVE_READLINE)
+ RL_LIBS="-ledit -ltermcap"],
+ [AC_CHECK_LIB(readline, readline,
+ [AC_DEFINE(HAVE_LIBREADLINE)
+ AC_DEFINE(HAVE_READLINE)
+ RL_LIBS="-ledit -ltermcap"], -ltermcap)
+ ], -ltermcap)
+ ])
+fi
AC_SUBST(RL_LIBS)
AC_CHECK_LIB(gsm, gsm_decode, [HAVE_GSM="yes"])

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ac,v 1.2 1998/08/07 10:36:07 agc Exp $
$NetBSD: patch-ac,v 1.3 2000/01/26 22:11:36 jlam Exp $
--- lib/regex.h.orig Sun Jan 18 20:42:26 1998
+++ lib/regex.h Sun Jan 18 20:42:56 1998
@@ -473,7 +473,7 @@
unsigned num_regs, regoff_t *starts, regoff_t *ends));
--- doc/Makefile.in.orig Tue Jul 14 18:35:23 1998
+++ doc/Makefile.in Tue Jan 18 16:15:32 2000
@@ -23,7 +23,7 @@
.texi.html:
$(TEXI2HTML) $(TEXI2HTML_FLAGS) $<
-all:
+all: info
info: RPLAY.info RPTP.info librplay.info rplay.info
/* 4.2 bsd compatibility. */
-#ifndef __FreeBSD__
+#if !defined(__FreeBSD__) && !defined(__NetBSD__)
extern char *re_comp _RE_ARGS ((_CONST_ char *));
extern int re_exec _RE_ARGS ((_CONST_ char *));
#endif

View file

@ -1,14 +1,14 @@
$NetBSD: patch-ad,v 1.2 1998/08/07 10:36:07 agc Exp $
$NetBSD: patch-ad,v 1.3 2000/01/26 22:11:36 jlam Exp $
--- doc/RPLAY.texi.orig Sun Jan 18 20:59:52 1998
+++ doc/RPLAY.texi Sun Jan 18 21:04:54 1998
--- doc/RPLAY.texi.orig Tue Jul 14 18:35:23 1998
+++ doc/RPLAY.texi Tue Jan 18 16:15:32 2000
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename RPLAY.info
@settitle The RPLAY Protocol
+@dircategory Network Audio Systems
+@direntry
+* RPLAY-Protocol: (RPLAY). The RPLAY Protocol
+* RPLAY Protocol: (RPLAY) The RPLAY Protocol
+@end direntry
@iftex
@finalout

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ae,v 1.1 2000/01/26 22:11:36 jlam Exp $
--- doc/RPTP.texi.orig Tue Jul 14 18:35:23 1998
+++ doc/RPTP.texi Tue Jan 18 16:15:32 2000
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename RPTP.info
@settitle The RPTP Protocol
+@dircategory Network Audio Systems
+@direntry
+* RPTP: (RPTP) RPTP Protocol
+@end direntry
@defindex ev
@iftex
@finalout

View file

@ -1,14 +1,14 @@
$NetBSD: patch-af,v 1.2 1998/08/07 10:36:07 agc Exp $
$NetBSD: patch-af,v 1.3 2000/01/26 22:11:36 jlam Exp $
--- doc/RPTP.texi.orig Sun Jan 18 20:59:52 1998
+++ doc/RPTP.texi Sun Jan 18 21:04:57 1998
@@ -3,6 +3,10 @@
@setfilename RPTP.info
@settitle The RPTP Protocol
@defindex ev
--- doc/librplay.texi.orig Tue Jul 14 18:35:23 1998
+++ doc/librplay.texi Tue Jan 18 16:15:33 2000
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename librplay.info
@settitle The rplay Programmer's Manual
+@dircategory Network Audio Systems
+@direntry
+* RPTP: (RPTP). The RPTP Protocol
+* librplay: (librplay) The rplay Programmer's Manual
+@end direntry
@iftex
@finalout

View file

@ -1,14 +1,14 @@
$NetBSD: patch-ag,v 1.2 1998/08/07 10:36:08 agc Exp $
$NetBSD: patch-ag,v 1.3 2000/01/26 22:11:36 jlam Exp $
--- doc/librplay.texi.orig Sun Jan 18 20:59:52 1998
+++ doc/librplay.texi Sun Jan 18 21:04:59 1998
--- doc/rplay.texi.orig Tue Jul 14 18:35:23 1998
+++ doc/rplay.texi Tue Jan 18 16:15:33 2000
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename librplay.info
@settitle The RPlay Programmer's Manual
@setfilename rplay.info
@settitle rplay
+@dircategory Network Audio Systems
+@direntry
+* librplay: (librplay). The RPlay Programmer's Manual
+* rplay: (rplay) RPlay
+@end direntry
@iftex
@finalout

View file

@ -1,15 +1,50 @@
$NetBSD: patch-ah,v 1.2 1998/08/07 10:36:08 agc Exp $
$NetBSD: patch-ah,v 1.3 2000/01/26 22:11:36 jlam Exp $
--- doc/rplay.texi.orig Sun Jan 18 20:59:52 1998
+++ doc/rplay.texi Sun Jan 18 21:05:01 1998
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename rplay.info
@settitle RPlay
+@dircategory Network Audio Systems
+@direntry
+* rplay: (rplay). RPlay
+@end direntry
@iftex
@finalout
@end iftex
--- doc/rplayd.8.orig Tue Jul 14 18:35:23 1998
+++ doc/rplayd.8 Tue Jan 18 16:15:39 2000
@@ -125,7 +125,7 @@
Linux uses cdrom[0-3] -> /dev/cdrom[0-3].
.TP
.I "\-C FILE, \-\-conf=FILE"
-Use FILE for rplay.conf (/etc/rplay/rplay.conf).
+Use FILE for rplay.conf.
.TP
.I "\-T N, \-\-connection\-timeout=N"
Close idle RPTP connections after N seconds, disabled with 0 (300).
@@ -146,10 +146,10 @@
Display helpful information.
.TP
.I "\-\-helpers=FILE"
-Use FILE for rplay.helpers (/etc/rplay/rplay.helpers).
+Use FILE for rplay.helpers.
.TP
.I "\-H FILE, \-\-hosts=FILE"
-Use FILE for rplay.hosts (/etc/rplay/rplay.hosts).
+Use FILE for rplay.hosts.
.TP
.I "\-\-inetd"
Enable inetd mode. (disabled)
@@ -191,7 +191,7 @@
(--other-rptp-port may also be available)
.TP
.I "\-S FILE, \-\-servers=FILE"
-Use FILE for rplay.servers (/etc/rplay/rplay.servers).
+Use FILE for rplay.servers.
.TP
.I "\-t N, \-\-timeout=N"
Exit after N idle seconds, disabled with 0 (0).
@@ -205,10 +205,10 @@
.nf
~/.rplaydrc
/tmp/.rplay-cache
-/usr/local/etc/rplay.conf
-/usr/local/etc/rplay.helpers
-/usr/local/etc/rplay.hosts
-/usr/local/etc/rplay.servers
+/usr/pkg/etc/rplay.conf
+/usr/pkg/etc/rplay.helpers
+/usr/pkg/etc/rplay.hosts
+/usr/pkg/etc/rplay.servers
.fi
.SH SEE ALSO
.IR rplay.conf (5),

View file

@ -1,12 +1,13 @@
$NetBSD: patch-ai,v 1.1 1999/07/19 23:46:20 hubertf Exp $
$NetBSD: patch-ai,v 1.2 2000/01/26 22:11:36 jlam Exp $
--- rplayd/timer.h.orig Tue Jul 20 01:33:57 1999
+++ rplayd/timer.h Tue Jul 20 01:34:12 1999
@@ -27,6 +27,7 @@
#include "config.h"
#endif
+#include <signal.h>
#include <sys/types.h>
extern double timer_rate;
--- include/config.h.in.orig Wed Jun 9 02:25:20 1999
+++ include/config.h.in Tue Jan 18 16:15:33 2000
@@ -189,6 +189,8 @@
#undef HAVE_WAITPID
#undef HAVE_SNPRINTF
#undef HAVE_VSNPRINTF
+#undef HAVE_READLINE
+#undef HAVE_LIBEDIT
#undef HAVE_LIBREADLINE
#undef HAVE_RANDOM
#undef HAVE_SRANDOM

View file

@ -0,0 +1,58 @@
$NetBSD: patch-aj,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- librplay/Makefile.in.orig Mon Mar 22 21:38:38 1999
+++ librplay/Makefile.in Tue Jan 18 16:15:33 2000
@@ -9,28 +9,25 @@
MKINSTALLDIRS= @srcdir@/../mkinstalldirs
CPPFLAGS= $(CC_OPTIONS) -I. -I../include -I@srcdir@/../include @DEFS@
-LDFLAGS= $(LD_OPTIONS) -shared @LDFLAGS@
-
-.c.o:
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
+LDFLAGS= $(LD_OPTIONS) @LDFLAGS@
.SUFFIXES: .lo
.c.lo:
- $(CC) -c -fPIC $(CPPFLAGS) $(CFLAGS) -o $@ $<
+ $(LIBTOOL) $(CC) $(CPPFLAGS) $(CFLAGS) -c $<
TARGET= $(LIBRPLAY_NAME)
SRCS= rplay.c rptp.c async.c
OBJS= rplay.o rptp.o async.o
SHAREDOBJS= rplay.lo rptp.lo async.lo
-all: $(TARGET) librplay.so
+all: $(TARGET)
#
# Use the following for SunOS 4.1.x, Solaris 2.x, Linux, NetBSD
#
-$(TARGET): $(OBJS)
- $(AR) rcv $@ $?
- $(RANLIB) $@
+$(TARGET): $(SHAREDOBJS)
+ $(LIBTOOL) $(CC) $(LDFLAGS) -o $@ $? \
+ -rpath $(libdir) -version-info 0:0
librplay.so: $(SHAREDOBJS)
$(CC) -o $@ $(SHAREDOBJS) $(LDFLAGS)
@@ -49,15 +46,13 @@
install: all
$(MKINSTALLDIRS) $(libdir)
- $(INSTALL_DATA) $(TARGET) $(libdir)
- $(INSTALL_DATA) librplay.so $(libdir)
+ $(LIBTOOL) $(INSTALL_DATA) $(TARGET) $(libdir)
uninstall:
- $(RM) $(libdir)/$(TARGET)
- $(RM) $(libdir)/librplay.so
+ $(LIBTOOL) $(RM) $(libdir)/$(TARGET)
clean:
- $(RM) $(OBJS) $(SHAREDOBJS) $(TARGET) librplay.so a.out core *~ *.bak *.orig TAGS
+ $(LIBTOOL) $(RM) $(OBJS) $(SHAREDOBJS) $(TARGET) librplay.so a.out core *~ *.bak *.orig TAGS
distclean: clean
$(RM) Makefile

View file

@ -0,0 +1,39 @@
$NetBSD: patch-ak,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rplay/Makefile.in.orig Sat Mar 20 19:44:57 1999
+++ rplay/Makefile.in Tue Jan 18 16:15:33 2000
@@ -13,7 +13,7 @@
.c.o:
$(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp @LDFLAGS@ @LIBS@
+LDFLAGS= $(LD_OPTIONS) ../librplay/$(LIBRPLAY_NAME) ../lib/librp.a @LDFLAGS@ @LIBS@
TARGET= rplay
SRCS= rplay.c
@@ -22,7 +22,7 @@
all: $(TARGET)
$(TARGET): $(OBJS) ../librplay/$(LIBRPLAY_NAME) ../lib/librp.a
- $(CC) -o $@ $(OBJS) $(LDFLAGS)
+ $(LIBTOOL) $(CC) -o $@ $(OBJS) $(LDFLAGS)
../librplay/$(LIBRPLAY_NAME):
(cd ../librplay; $(MAKE) $(MFLAGS))
@@ -32,13 +32,13 @@
install: all
$(MKINSTALLDIRS) $(bindir)
- $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
+ $(LIBTOOL) $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
uninstall:
- $(RM) $(bindir)/$(TARGET)
+ $(LIBTOOL) $(RM) $(bindir)/$(TARGET)
clean:
- $(RM) $(OBJS) $(TARGET) a.out core *~ *.bak *.orig TAGS
+ $(LIBTOOL) $(RM) $(OBJS) $(TARGET) a.out core *~ *.bak *.orig TAGS
distclean: clean
$(RM) Makefile

View file

@ -0,0 +1,42 @@
$NetBSD: patch-al,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rplayd/Makefile.in.orig Wed Jun 9 02:27:43 1999
+++ rplayd/Makefile.in Wed Jan 26 17:03:44 2000
@@ -24,8 +24,8 @@
.c.o:
$(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp \
- -L../adpcm -ladpcm @GSM_LIBS@ -L../rx -lrx @LDFLAGS@ @LIBS@ -lm
+LDFLAGS= $(LD_OPTIONS) ../librplay/$(LIBRPLAY_NAME) ../lib/librp.a \
+ ../adpcm/libadpcm.a @GSM_LIBS@ @RX_LIBS@ @LDFLAGS@ @LIBS@ -lm
TARGET= rplayd
@@ -40,7 +40,7 @@
all: $(TARGET)
$(TARGET): $(OBJS) ../librplay/$(LIBRPLAY_NAME) ../lib/librp.a ../adpcm/libadpcm.a
- $(CC) -o $@ $(OBJS) $(LDFLAGS)
+ $(LIBTOOL) $(CC) -o $@ $(OBJS) $(LDFLAGS)
../librplay/$(LIBRPLAY_NAME):
(cd ../librplay; $(MAKE) $(MFLAGS))
@@ -53,14 +53,13 @@
install: all
$(MKINSTALLDIRS) $(sbindir)
- $(INSTALL_PROGRAM) $(TARGET) $(sbindir)/$(TARGET)
- @test -x $(bindir)/$(TARGET) && echo "" && echo " Note: Consider removing $(bindir)/$(TARGET)" && echo ""
+ $(LIBTOOL) $(INSTALL_PROGRAM) $(TARGET) $(sbindir)/$(TARGET)
uninstall:
- $(RM) $(bindir)/$(TARGET)
+ $(LIBTOOL) $(RM) $(bindir)/$(TARGET)
clean:
- $(RM) $(OBJS) $(TARGET) a.out core *~ *.bak *.orig TAGS
+ $(LIBTOOL) $(RM) $(OBJS) $(TARGET) a.out core *~ *.bak *.orig TAGS
cd audio; $(RM) *~ *.bak *.orig
distclean: clean

View file

@ -0,0 +1,16 @@
$NetBSD: patch-am,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rplayd/sound.h.orig Wed Jun 9 02:27:44 1999
+++ rplayd/sound.h Tue Jan 18 16:15:33 2000
@@ -170,9 +170,9 @@
int gsm_bit_frame_bytes; /* Number of bytes in gsm_bit_frame */
int gsm_fixed_buffer_size;
#endif /* HAVE_GSM */
-#ifdef HAVE_CDROM
+#if defined(HAVE_CDROM) || defined(HAVE_HELPERS)
int pid;
-#endif /* HAVE_CDROM */
+#endif /* HAVE_CDROM || HAVE_HELPERS */
}
SINDEX;

View file

@ -0,0 +1,14 @@
$NetBSD: patch-an,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rplayd/spool.c.orig Wed Mar 10 16:14:38 1999
+++ rplayd/spool.c Tue Jan 18 16:15:33 2000
@@ -1127,8 +1127,8 @@
spool_flow_pause(sp);
}
}
-#endif /* HAVE_CDROM */
}
+#endif /* HAVE_CDROM */
}
else
{

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ao,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rplayd/timer.h.orig Wed Mar 10 02:58:04 1999
+++ rplayd/timer.h Tue Jan 18 16:15:34 2000
@@ -30,6 +30,7 @@
#include "config.h"
#endif
+#include <signal.h>
#include <sys/types.h>
extern double timer_rate;

View file

@ -0,0 +1,39 @@
$NetBSD: patch-ap,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rptp/Makefile.in.orig Wed Jun 9 02:27:48 1999
+++ rptp/Makefile.in Tue Jan 18 16:15:34 2000
@@ -13,7 +13,7 @@
.c.o:
$(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp @LDFLAGS@ @RL_LIBS@ @LIBS@
+LDFLAGS= $(LD_OPTIONS) ../librplay/$(LIBRPLAY_NAME) ../lib/librp.a @LDFLAGS@ @RL_LIBS@ @LIBS@
TARGET= rptp
@@ -24,7 +24,7 @@
all: $(TARGET)
$(TARGET): $(OBJS) ../librplay/$(LIBRPLAY_NAME) ../lib/librp.a
- $(CC) -o $@ $(OBJS) $(LDFLAGS)
+ $(LIBTOOL) $(CC) -o $@ $(OBJS) $(LDFLAGS)
../librplay/$(LIBRPLAY_NAME):
(cd ../librplay; $(MAKE) $(MFLAGS))
@@ -34,13 +34,13 @@
install: all
$(MKINSTALLDIRS) $(bindir)
- $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
+ $(LIBTOOL) $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
uninstall:
- $(RM) $(bindir)/$(TARGET)
+ $(LIBTOOL) $(RM) $(bindir)/$(TARGET)
clean:
- $(RM) $(OBJS) $(TARGET) a.out core *~ *.bak *.orig TAGS
+ $(LIBTOOL) $(RM) $(OBJS) $(TARGET) a.out core *~ *.bak *.orig TAGS
distclean: clean
$(RM) Makefile

View file

@ -0,0 +1,50 @@
$NetBSD: patch-aq,v 1.1 2000/01/26 22:11:37 jlam Exp $
--- rptp/rptp.c.orig Sat Mar 20 19:45:08 1999
+++ rptp/rptp.c Tue Jan 18 16:15:34 2000
@@ -31,10 +31,23 @@
#ifdef HAVE_STRING_H
#include <string.h>
#endif
-#ifdef HAVE_LIBREADLINE
-#include <readline/readline.h>
-#include <readline/history.h>
-#endif /* HAVE_LIBREADLINE */
+
+#ifdef HAVE_READLINE
+# ifdef HAVE_READLINE_H
+# include <readline.h>
+# ifdef HAVE_HISTORY_H
+# include <history.h>
+# endif
+# elif defined(HAVE_READLINE_READLINE_H)
+# include <readline/readline.h>
+# ifdef HAVE_READLINE_HISTORY_H
+# include <readline/history.h>
+# endif
+# else
+# undef HAVE_READLINE
+# endif
+#endif /* HAVE_READLINE */
+
#include "rplay.h"
#include "getopt.h"
@@ -249,7 +262,7 @@
{
if (!raw)
{
-#ifdef HAVE_LIBREADLINE
+#ifdef HAVE_READLINE
p = readline(prompt);
if (!p)
{
@@ -263,7 +276,7 @@
#endif
}
-#ifndef HAVE_LIBREADLINE
+#ifndef HAVE_READLINE
if (fgets(buf, sizeof(buf), stdin) == NULL)
{
done(0);

View file

@ -1,32 +1,11 @@
rplay is a flexible network audio system that allows sounds to be played to
and from local and remote systems. The rplay audio server currently
supports SunOS 4.1.X, Solaris 2.X, Linux, SGI IRIX 4 & 5, HP9000/705,
HP9000/710 and now FreeBSD. The rplay clients and client library should
work on any system that supports Berkeley sockets. X Windows is not required.
Version 3.2.0beta
-------------------
* Supported systems include SunOS 4.1.X, Solaris 2.x, FreeBSD, Linux,
SGI IRIX 4 and IRIX 5, and HP9000/710.
and from local and remote systems.
* 8-bit & 16-bit audio input and output.
* All audio sample rates.
* .au, .snd, .aiff, .wav, .voc, .ub, .ul, G.721 4-bit, G.723 3-bit, and
G.723 5-bit audio files.
* Stereo input and output. (2 channels)
* Sounds can be played at any sample rate.
* Compile rplayd with -DTEST_FLANGE for some fun.
* Flexible audio configuration using the following long-named options:
--audio-device, --audio-bufsize, --audio-bits, --audio-channels,
--audio-close, --audio-flush, --audio-format, --audio-match, --audio-port,
--audio-rate, --audio-sample-rate, and no-audio.
(See `rplayd --help' for more details)
* HTML documentation.

14
audio/rplay/pkg/INSTALL Normal file
View file

@ -0,0 +1,14 @@
#!/bin/sh
#
# $NetBSD: INSTALL,v 1.1 2000/01/26 22:11:37 jlam Exp $
case $2 in
PRE-INSTALL)
;;
POST-INSTALL)
if [ ! -f ${PKG_PREFIX}/etc/rplay.conf ]; then
echo "localhost" >> ${PKG_PREFIX}/etc/rplay.conf
fi
;;
esac

View file

@ -1,30 +1,27 @@
@comment $NetBSD: PLIST,v 1.7 1999/04/20 16:39:11 tron Exp $
@comment $NetBSD: PLIST,v 1.8 2000/01/26 22:11:38 jlam Exp $
etc/rc.d/rplayd.sh
etc/rplay.hosts
@unexec rm -f %D/etc/rplay.conf
bin/rplay
bin/rptp
@comment requires XForms
@comment bin/xrplay
sbin/rplayd
include/rplay.h
lib/librplay.a
@unexec install-info --delete %D/info/librplay.info %D/info/dir
@unexec install-info --delete %D/info/rplay.info %D/info/dir
@unexec install-info --delete %D/info/RPLAY.info %D/info/dir
@unexec install-info --delete %D/info/RPTP.info %D/info/dir
info/librplay.info
info/rplay.info
@unexec install-info --delete %D/info/RPLAY.info %D/info/dir
@unexec install-info --delete %D/info/RPTP.info %D/info/dir
@unexec install-info --delete %D/info/librplay.info %D/info/dir
@unexec install-info --delete %D/info/rplay.info %D/info/dir
info/RPLAY.info
info/RPTP.info
@exec install-info %D/info/RPTP.info %D/info/dir
@exec install-info %D/info/RPLAY.info %D/info/dir
@exec install-info %D/info/rplay.info %D/info/dir
@exec install-info %D/info/librplay.info %D/info/dir
man/man1/rplay.1.gz
man/man1/rplayd.1.gz
man/man1/xrplay.1.gz
man/man1/rptp.1.gz
man/man5/rplay.conf.5.gz
man/man5/rplay.hosts.5.gz
man/man5/rplay.servers.5.gz
info/librplay.info
info/rplay.info
@exec install-info %D/info/RPLAY.info %D/info/dir
@exec install-info %D/info/RPTP.info %D/info/dir
@exec install-info %D/info/librplay.info %D/info/dir
@exec install-info %D/info/rplay.info %D/info/dir
lib/librplay.a
lib/librplay.so.0.0
man/man1/rplay.1
man/man1/rptp.1
man/man5/rplay.conf.5
man/man5/rplay.helpers.5
man/man5/rplay.hosts.5
man/man5/rplay.servers.5
man/man8/rplayd.8
sbin/rplayd