libogg: updated to 1.3.5

Version 1.3.5 (2020 June 3)
* Fix unsigned typedef problem on macOS.
* Fix overflow check in ogg_sync_buffer.
* Clean up cmake and autotools build files.
* Remove Symbian and Apple XCode build files.
* Fix documentation cross-reference links.
This commit is contained in:
adam 2021-06-07 09:12:32 +00:00
parent 8c6b571c06
commit 0c1d1ef5ae
4 changed files with 22 additions and 23 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.27 2019/09/08 19:11:30 dbj Exp $
# $NetBSD: Makefile,v 1.28 2021/06/07 09:12:32 adam Exp $
DISTNAME= libogg-1.3.4
PKGREVISION= 1
DISTNAME= libogg-1.3.5
CATEGORIES= multimedia devel
MASTER_SITES= http://downloads.xiph.org/releases/ogg/
EXTRACT_SUFX= .tar.xz

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.16 2019/09/08 19:11:30 dbj Exp $
$NetBSD: distinfo,v 1.17 2021/06/07 09:12:32 adam Exp $
SHA1 (libogg-1.3.4.tar.xz) = f07499a35566aa62affb5ca989f62eed5b8092c3
RMD160 (libogg-1.3.4.tar.xz) = ee76a42b00bc11d483de53d9e84a487be3900d06
SHA512 (libogg-1.3.4.tar.xz) = 09ffb72c3cbde5c05140f5879bd457106ed4070bd7aa5ea7720cf8910167f1d0fa6312f1f71625d51f21e3033219da858e1a8a2701bfd768b35061f7586f976c
Size (libogg-1.3.4.tar.xz) = 428696 bytes
SHA1 (patch-configure) = d33ee766a1fb7f81b9fc38930a26279aa506244a
SHA1 (patch-include_ogg_os__types.h) = b491e3c530e285bd901618245890d4a1504ad147
SHA1 (libogg-1.3.5.tar.xz) = 5a368421a636f7faa4c2f662857cb507dffd7c99
RMD160 (libogg-1.3.5.tar.xz) = cb84ce28673cd2fe398b8a70826674a6e6e49365
SHA512 (libogg-1.3.5.tar.xz) = 5d1cbc2a3a1fcf5543f5729bd5eb560cfc740c5d17a2492ead137970c45e6203ec1f5de536d77c4b73ece9e3b0046eaa9181c02a09de72ac7ae51b1fca1e1ee7
Size (libogg-1.3.5.tar.xz) = 429076 bytes
SHA1 (patch-configure) = 0fd4901eac9d5325185ab42935fa92a80eef34c5
SHA1 (patch-include_ogg_os__types.h) = 001ac30d920b02cd5dbb51883fdacf237e2613bf

View file

@ -1,10 +1,10 @@
$NetBSD: patch-configure,v 1.1 2019/09/02 08:58:57 adam Exp $
$NetBSD: patch-configure,v 1.2 2021/06/07 09:12:32 adam Exp $
Do not force compiler optimization flags.
--- configure.orig 2019-09-02 08:48:15.000000000 +0000
--- configure.orig 2021-06-04 03:21:11.000000000 +0000
+++ configure
@@ -12781,17 +12781,17 @@ if test -z "$GCC"; then
@@ -12804,17 +12804,17 @@ if test -z "$GCC"; then
case $host in
*-*-irix*)
DEBUG="-g -signed"
@ -25,19 +25,19 @@ Do not force compiler optimization flags.
PROFILE="-g -p"
;;
esac
@@ -12799,22 +12799,22 @@ else
@@ -12822,22 +12822,22 @@ else
case $host in
*-*-linux*)
DEBUG="-g -Wall -fsigned-char"
- CFLAGS="-O20 -Wall -ffast-math -fsigned-char"
- CFLAGS="-O2 -Wall -ffast-math -fsigned-char"
+ CFLAGS="-Wall -ffast-math -fsigned-char"
PROFILE="-Wall -W -pg -g -O20 -ffast-math -fsigned-char"
PROFILE="-Wall -W -pg -g -O2 -ffast-math -fsigned-char"
;;
sparc-sun-*)
DEBUG="-g -Wall -fsigned-char"
- CFLAGS="-O20 -ffast-math -fsigned-char"
- CFLAGS="-O2 -ffast-math -fsigned-char"
+ CFLAGS="-ffast-math -fsigned-char"
PROFILE="-pg -g -O20 -fsigned-char"
PROFILE="-pg -g -O2 -fsigned-char"
;;
*-*-darwin*)
DEBUG="-fno-common -g -Wall -fsigned-char"
@ -47,8 +47,8 @@ Do not force compiler optimization flags.
;;
*)
DEBUG="-g -Wall -fsigned-char"
- CFLAGS="-O20 -fsigned-char"
- CFLAGS="-O2 -fsigned-char"
+ CFLAGS="-fsigned-char"
PROFILE="-O20 -g -pg -fsigned-char"
PROFILE="-O2 -g -pg -fsigned-char"
;;
esac

View file

@ -1,10 +1,10 @@
$NetBSD: patch-include_ogg_os__types.h,v 1.1 2019/09/08 19:11:30 dbj Exp $
$NetBSD: patch-include_ogg_os__types.h,v 1.2 2021/06/07 09:12:32 adam Exp $
use stdint.h on macos
This was broken by a recent change. See comments in:
https://gitlab.xiph.org/xiph/ogg/issues/2294
--- include/ogg/os_types.h.orig 2019-08-13 16:31:53.000000000 +0000
--- include/ogg/os_types.h.orig 2021-06-07 08:37:18.000000000 +0000
+++ include/ogg/os_types.h
@@ -70,7 +70,7 @@
@ -13,5 +13,5 @@ https://gitlab.xiph.org/xiph/ogg/issues/2294
-# include <sys/types.h>
+# include <stdint.h>
typedef int16_t ogg_int16_t;
typedef uint16_t ogg_uint16_t;
typedef u_int16_t ogg_uint16_t;
typedef int32_t ogg_int32_t;