A www to ldap gateway.

This commit is contained in:
hwr 1999-01-08 14:15:57 +00:00
parent 46cfd36f4f
commit 0c2ee3ae33
8 changed files with 131 additions and 0 deletions

12
www/web500gw/Makefile Normal file
View file

@ -0,0 +1,12 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/01/08 14:15:57 hwr Exp $
DISTNAME= web500gw-2.1b3
CATEGORIES= databases
MASTER_SITES= ftp://ftp.tu-chemnitz.de/pub/Local/urz/web500gw/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.tu-chemnitz.de/~fri/web500gw/
DEPENDS+= openldap-1.1.2:../../databases/openldap
.include "../../mk/bsd.pkg.mk"

3
www/web500gw/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/01/08 14:15:57 hwr Exp $
MD5 (web500gw-2.1b3.tar.gz) = 8e411a94f79bad75a3e8deeea3d05050

View file

@ -0,0 +1,69 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/01/08 14:15:57 hwr Exp $
--- Makefile.orig Wed Oct 28 15:21:57 1998
+++ Makefile Fri Jan 8 14:05:39 1999
@@ -3,14 +3,14 @@
#-----------------------------------------------------------------------------
# Where to install web500gw
-INSTDIR = /usr/local/etc
+INSTDIR = @PREFIX@/sbin
# Where to install the manual web500gw.8
-MANDIR = /usr/local/man/man8
+MANDIR = @PREFIX@/man/man8
# Where to install web500gw's config/filter/template/help/message files
# It's recommended to use an own directory for it.
-WEB500GWDIR = $(INSTDIR)/web500
+WEB500GWDIR = @PREFIX@/etc/web500
# What language dependent files should be installed?
# "" stands for english (default) versions
@@ -14,7 +14,7 @@
# What language dependent files should be installed?
# "" stands for english (default) versions
-SUFFIX = "" de es fr
+SUFFIX = "" de
# DEFINES - Enable/disable some features
@@ -34,8 +34,8 @@
## If you use OpenLDAP 1.0 or U-Mich LDAP 3.3 package (recommended)
# If the LDAP include files and libraries installed in standard places
# (/usr/lib, /usr/include) use this:
-LDAPINCL =
-LDAPLIBS = -lldap -llber
+LDAPINCL = -I@PREFIX@/include
+LDAPLIBS = -L@PREFIX@/lib -lldap -llber -lcompat
# set LDAPVERSION (32 for ldap-3.2, 33 for 3.3 etc)
LDAPVERSION = 33
VERSION = 3.3
@@ -51,7 +51,7 @@
# T.61 <-> ISO-8859-1 translation: This is built in from LDAP 3.2.
# If you didn't define this translation there comment out the following line:
-STR_TRANSLATION = -DSTR_TRANSLATION
+# STR_TRANSLATION = -DSTR_TRANSLATION
# If you defined LDAP_DEBUG there and want to enable LDAP debugging
# uncomment the following line:
LDAP_DEBUG = -DLDAP_DEBUG
@@ -69,7 +69,7 @@
# platform specific:
# Linux
-PLATFORMCFLAGS= -Dlinux -DSYSV
+# PLATFORMCFLAGS= -Dlinux -DSYSV
# Solaris 2
# PLATFORMCFLAGS= -Dsunos5
# PLATFORMLDFLAGS= -lsocket -lnsl
@@ -97,7 +97,7 @@
$(LDAP_DEBUG) $(STR_TRANSLATION)
# when using gcc:
-CC = gcc
+CC = cc
#WARN = -Wall -Wno-implicit
#CFLAGS = -O4 $(WARN) $(ALLDEFINES) -fpcc-struct-return -fwritable-strings
CFLAGS = -g $(WARN) $(ALLDEFINES) -fpcc-struct-return -fwritable-strings

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/01/08 14:15:57 hwr Exp $
--- web500gw.h.orig Wed Oct 28 13:27:47 1998
+++ web500gw.h Fri Jan 8 14:26:55 1999
@@ -69,9 +69,9 @@
#include <unistd.h>
#endif /* USE_SYSCONF */
-/* #if defined (__NetBSD__)
+#if defined (__NetBSD__)
#include <unistd.h>
-#endif */
+#endif
#include "messages.h"
extern char *msg[];

1
www/web500gw/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
A WWW to ldap gateway.

8
www/web500gw/pkg/DESCR Normal file
View file

@ -0,0 +1,8 @@
A gateway that connects WWW browsers to LDAP based directories.
Web500gw expects HTTP requests from a WWW browser on a TCP port (usually 8888).
Depending on the requested URL web500gw performs read/search/modify/add/delete
requests to the Directory and sends HTML pages back to the browser.
Web500gw uses the LDAPv2 protocol to talk to a Directory server. It is able to
work with a Standalone LDAP server (like UMich/OpenLDAP slapd or Netscape LDAP
product) and with an LDAP Frontend to an X.500 Directory System Agent.

17
www/web500gw/pkg/PLIST Normal file
View file

@ -0,0 +1,17 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/01/08 14:15:57 hwr Exp $
man/man8/web500gw.8
etc/web500/web500gw.conf
etc/web500/ldapfilter.conf
etc/web500/ldapfilter.conf.internal
etc/web500/ldaptemplates.conf
etc/web500/ldaptemplates.conf.internal
etc/web500/web500gw.help
etc/web500/web500gw.messages
etc/web500/web500gw.attr
etc/web500/ldapfriendly
etc/web500/web500gw.help.de
etc/web500/web500gw.messages.de
etc/web500/web500gw.attr.de
etc/web500/ldapfriendly.de
@dirrm etc/web500
sbin/web500gw

View file

@ -0,0 +1,5 @@
#!/bin/sh
# $NetBSD: post-patch,v 1.1.1.1 1999/01/08 14:15:57 hwr Exp $
cd ${WRKSRC}
mv -f Makefile Makefile.pre
sed -e "s|@PREFIX@|${PREFIX}|g" < Makefile.pre > Makefile