Initial import of obexftp, version 0.10.3:

The overall goal of ObexFTP is to make mobile devices featuring the OBEX
protocol and adhering to the OBEX FTP standard accessible by an open source
implementation.

The common usage for ObexFTP is to access your mobile phones memory to
store and retrieve e.g. your phonebook, logos, ringtones, music, pictures
and alike.
This commit is contained in:
jmmv 2004-02-26 12:50:43 +00:00
parent edeebe6424
commit 0c7584ad33
11 changed files with 164 additions and 0 deletions

7
comms/obexftp/DESCR Normal file
View file

@ -0,0 +1,7 @@
The overall goal of ObexFTP is to make mobile devices featuring the OBEX
protocol and adhering to the OBEX FTP standard accessible by an open source
implementation.
The common usage for ObexFTP is to access your mobile phones memory to
store and retrieve e.g. your phonebook, logos, ringtones, music, pictures
and alike.

17
comms/obexftp/Makefile Normal file
View file

@ -0,0 +1,17 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/02/26 12:50:43 jmmv Exp $
#
DISTNAME= obexftp-0.10.3
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=openobex/}
MAINTAINER= jmmv@NetBSD.org
HOMEPAGE= http://triq.net/obex/
COMMENT= File copying over the Object Exchange (OBEX) protocol
GNU_CONFIGURE= YES
USE_BUILDLINK3= YES
USE_LIBTOOL= YES
.include "../../comms/openobex/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

37
comms/obexftp/PLIST Normal file
View file

@ -0,0 +1,37 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
bin/gsm2vmo
bin/obexftp
bin/vmo2gsm
bin/vmo2wav
include/bfb/bfb.h
include/bfb/bfb_io.h
include/cobexbfb/cobex_bfb.h
include/cobexpe/cobex_pe.h
include/obexftp/client.h
include/obexftp/obexftp.h
include/obexftp/object.h
lib/libbfb.a
lib/libbfb.la
lib/libbfb.so
lib/libbfb.so.0
lib/libbfb.so.0.4
lib/libcobexbfb.a
lib/libcobexbfb.la
lib/libcobexbfb.so
lib/libcobexbfb.so.0
lib/libcobexbfb.so.0.8
lib/libcobexpe.a
lib/libcobexpe.la
lib/libcobexpe.so
lib/libcobexpe.so.0
lib/libcobexpe.so.0.2
lib/libobexftp.a
lib/libobexftp.la
lib/libobexftp.so
lib/libobexftp.so.0
lib/libobexftp.so.0.11
man/man1/flexmem.1
@dirrm include/obexftp
@dirrm include/cobexpe
@dirrm include/cobexbfb
@dirrm include/bfb

11
comms/obexftp/distinfo Normal file
View file

@ -0,0 +1,11 @@
$NetBSD: distinfo,v 1.1.1.1 2004/02/26 12:50:43 jmmv Exp $
SHA1 (obexftp-0.10.3.tar.gz) = 7f8756597e4660f71147a60fd5a5dc79a55e6cc6
Size (obexftp-0.10.3.tar.gz) = 286083 bytes
SHA1 (patch-aa) = a00bd78a2fe83d7758b7b4b42cf8a09e4167d854
SHA1 (patch-ab) = 75005d57e2ef1ae2594b2513ab5235018dab0b4f
SHA1 (patch-ac) = e41b1d6b1ede9c27f3e238b708b17acbab953e28
SHA1 (patch-ad) = cf3ce3b10d4f35cb01f52b89c1d0636bd23ec1f6
SHA1 (patch-ae) = 8f97189137675fb6ba34ec8253f6e34bf72e111f
SHA1 (patch-af) = a18813e45590ecdc5b7402320f1e3c08daadd788
SHA1 (patch-ag) = 6183be32c1485854be6732d28b1c87cf73e48211

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- bfb/bfb_io.c.orig 2003-04-11 12:34:10.000000000 +0200
+++ bfb/bfb_io.c
@@ -272,8 +272,10 @@ void bfb_io_close(fd_t fd, int force)
/* Send a break to get out of OBEX-mode */
#ifdef _WIN32
if(SetCommBreak(fd) != TRUE) {
-#else
+#elif defined(TCSBRKP)
if(ioctl(fd, TCSBRKP, 0) < 0) {
+#else
+ if(tcsendbreak(fd, 0) == -1) {
#endif
DEBUG(1, "Unable to send break!\n");
}

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- cobexpe/cobex_pe.c.orig 2003-04-10 00:37:02.000000000 +0200
+++ cobexpe/cobex_pe.c
@@ -151,7 +151,11 @@ static void cobex_pe_cleanup(cobex_t *c,
if(force) {
/* Send a break to get out of OBEX-mode */
+#ifdef TCSBRKP
if(ioctl(c->fd, TCSBRKP, 0) < 0) {
+#else
+ if(tcsendbreak(c->fd, 0) == -1) {
+#endif
DEBUG(1, "Unable to send break!\n");
}
sleep(1);

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- obexftp/client.c.orig 2003-02-16 19:56:31.000000000 +0100
+++ obexftp/client.c
@@ -24,6 +24,7 @@
#include <unistd.h>
#include <fcntl.h>
#include <sys/stat.h>
+#include <limits.h>
/* htons */
#ifdef _WIN32

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- obexftp/dirtraverse.c.orig 2003-01-15 23:52:47.000000000 +0100
+++ obexftp/dirtraverse.c
@@ -22,6 +22,7 @@
#include <string.h>
#include <unistd.h>
#include <stdlib.h>
+#include <limits.h>
#include <sys/stat.h>
#include <sys/types.h>
#ifdef _WIN32

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- obexftp/obexftp_io.c.orig 2003-01-15 23:52:12.000000000 +0100
+++ obexftp/obexftp_io.c
@@ -24,6 +24,7 @@
#include <unistd.h>
#include <stdio.h> /* FIXME: libraries shouldn't do this */
#include <sys/stat.h>
+#include <limits.h>
#include <fcntl.h>
#include <string.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- vmo/gsm2vmo.c.orig 2003-02-17 22:55:47.000000000 +0100
+++ vmo/gsm2vmo.c
@@ -32,6 +32,7 @@
#include <stdlib.h>
#include <string.h>
#include <unistd.h>
+#include <limits.h>
#include <fcntl.h>
#include <netinet/in.h> /* ntohs */

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ag,v 1.1.1.1 2004/02/26 12:50:45 jmmv Exp $
--- vmo/vmo2gsm.c.orig 2003-02-17 22:55:40.000000000 +0100
+++ vmo/vmo2gsm.c
@@ -32,6 +32,7 @@
#include <stdlib.h>
#include <string.h>
#include <unistd.h>
+#include <limits.h>
#include <fcntl.h>
#include <netinet/in.h> /* ntohs */