need to include additional headers to build with gcc44.

This commit is contained in:
obache 2011-03-23 09:19:39 +00:00
parent b1b9ce1443
commit 0c82940039
3 changed files with 31 additions and 1 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.2 2010/09/12 02:04:21 taca Exp $
$NetBSD: distinfo,v 1.3 2011/03/23 09:19:39 obache Exp $
SHA1 (yamcha-0.33.tar.gz) = 4ee6d8150557761f86fcb8af118636b7c23920c0
RMD160 (yamcha-0.33.tar.gz) = ac21fa16a45efa40775d426cd6229f612a7aa21e
Size (yamcha-0.33.tar.gz) = 488670 bytes
SHA1 (patch-aa) = 16120e3f052a1046ee360bbe449d95dfdb6a3990
SHA1 (patch-libexec_mkdarts.cpp) = 7fb2dfae8f6b312530f0774f9e8f227b98fdfd5e
SHA1 (patch-src_param.cpp) = 4fe2da167ce0de0c88153fe545c04efba1b585c7

View file

@ -0,0 +1,14 @@
$NetBSD: patch-libexec_mkdarts.cpp,v 1.1 2011/03/23 09:19:39 obache Exp $
* require <cstdlib> header for atoi(3).
--- libexec/mkdarts.cpp.orig 2004-03-12 17:12:13.000000000 +0000
+++ libexec/mkdarts.cpp
@@ -23,6 +23,7 @@
#include <cstdio>
#include <cstring>
+#include <cstdlib>
#include <iostream>
#include <fstream>
#include <string>

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_param.cpp,v 1.1 2011/03/23 09:19:39 obache Exp $
* require <cstring> header for strlen(3) and strncmp(3).
--- src/param.cpp.orig 2005-09-05 14:50:59.000000000 +0000
+++ src/param.cpp
@@ -24,6 +24,7 @@
#include <fstream>
#include <strstream>
#include <cstdio>
+#include <cstring>
#include "param.h"
#include "common.h"