entr: Update to 4.5

Changes:
4.5
---
 - New '-z' "one-shot" option self-terminates after the utility exits
 - Termination by 'q' or 'SIGINT' results in an exit status of 0
This commit is contained in:
leot 2020-06-13 21:51:26 +00:00
parent 39c48c59de
commit 0c9d7ea70e
3 changed files with 32 additions and 7 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.13 2020/05/23 10:26:54 rillig Exp $
# $NetBSD: Makefile,v 1.14 2020/06/13 21:51:26 leot Exp $
#
DISTNAME= entr-4.4
DISTNAME= entr-4.5
CATEGORIES= sysutils
MASTER_SITES= http://eradman.com/entrproject/code/

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.11 2020/02/14 18:51:39 leot Exp $
$NetBSD: distinfo,v 1.12 2020/06/13 21:51:26 leot Exp $
SHA1 (entr-4.4.tar.gz) = 97f0041808347137d6ad669c453d25826220fb21
RMD160 (entr-4.4.tar.gz) = 1cdfcc40815a64644fdc8a9c96698dcee642e0ec
SHA512 (entr-4.4.tar.gz) = 355bc19cfee9a9b5a460b136d8db014a1d129b6e4c95d905c1c4557cf7d845a076d260798ae8b84221563c049a9bd6d81974f00eea681abaf2eac2f2f5e6d087
Size (entr-4.4.tar.gz) = 24125 bytes
SHA1 (entr-4.5.tar.gz) = a706c15f7be76e94c7504242cf488280af4bb0e2
RMD160 (entr-4.5.tar.gz) = 6e2c0f4828e2dc306185fc173658ba6ec44af468
SHA512 (entr-4.5.tar.gz) = db9499d78385df5056a30a4e3262fb436090acc5410ddfc529a7cfe4e10e304e13787abfc31dd38dbf8b9f01fa3369ef32d20c9fb903fa35763f41791bdda9c7
Size (entr-4.5.tar.gz) = 24674 bytes
SHA1 (patch-system__test.sh) = 2b13ae80c7f3a84bc2fb2da4f4fa0a4e4cabb3bd

View file

@ -0,0 +1,24 @@
$NetBSD: patch-system__test.sh,v 1.1 2020/06/13 21:51:26 leot Exp $
Do not use non-portable `==' test(1) operator.
--- system_test.sh.orig 2020-04-20 16:02:05.000000000 +0000
+++ system_test.sh
@@ -22,7 +22,7 @@ typeset -i tests=0
function try { let tests+=1; this="$1"; }
function assert {
- [[ "$1" == "$2" ]] && { printf "."; return; }
+ [[ "$1" = "$2" ]] && { printf "."; return; }
printf "\nFAIL: $this\n'$1' != '$2'\n"; exit 1
}
function skip { printf "s"; }
@@ -110,7 +110,7 @@ try "fail to exec an command using one-s
try "restart a server when a file is modified using one-shot option"
setup
- if [ $(uname) == 'Linux' ]; then
+ if [ $(uname) = 'Linux' ]; then
skip "GNU nc spins while retrying SELECT(2); busybox does not support domain sockets"
else
ls $tmp/file2 | ./entr -rz nc -l -U $tmp/nc.s >> $tmp/exec.out &