Fix "freeze on exit" issue with many GL games. Bump PKGREVISION.

This commit is contained in:
hasso 2009-06-10 10:47:22 +00:00
parent 9c11f22f79
commit 0ca190aca6
3 changed files with 28 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.76 2009/06/05 11:10:35 wiz Exp $
# $NetBSD: Makefile,v 1.77 2009/06/10 10:47:22 hasso Exp $
PKGNAME= MesaLib-${MESA_PKGVERSION}
COMMENT= Graphics library similar to SGI's OpenGL
PKGREVISION= 1
MESA_HEADERS= gl.h gl_mangle.h glext.h glx.h glxext.h \
glx_mangle.h osmesa.h xmesa.h xmesa_x.h \

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.62 2009/06/05 11:10:35 wiz Exp $
$NetBSD: distinfo,v 1.63 2009/06/10 10:47:22 hasso Exp $
SHA1 (Mesa-7.4.2/MesaDemos-7.4.2.tar.bz2) = cbba586829c76a5e7a54a906567b4b2174d6e1aa
RMD160 (Mesa-7.4.2/MesaDemos-7.4.2.tar.bz2) = c6434d325897540618130e97891f391721b543b5
@ -29,4 +29,5 @@ SHA1 (patch-ay) = 8a5eb2d874026032f9b9c15e06abb40863a21a8a
SHA1 (patch-ba) = 44e258235ac949713c4fcead25cb7ab7498cbb7f
SHA1 (patch-bb) = 4fd8a770bd0275c3467447f77f51e957996c93ac
SHA1 (patch-bc) = 6b8df3762d666c2e7720183b6d292053bda86f5a
SHA1 (patch-bd) = 61cb50ef49e64ecc0f87750d60244f1ff7b44bd4
SHA1 (patch-cb) = 83789d71de41aed2ba81a8239fb035a4cd295477

View file

@ -0,0 +1,24 @@
$NetBSD: patch-bd,v 1.1 2009/06/10 10:47:23 hasso Exp $
Fix "freeze on exit" issue with many games. The patch taken from upstream
bugzilla: http://bugs.freedesktop.org/show_bug.cgi?id=21756
--- src/mesa/main/texstate.c.orig 2009-06-10 12:59:19 +0300
+++ src/mesa/main/texstate.c 2009-06-10 13:00:26 +0300
@@ -429,7 +429,7 @@ texture_override(GLcontext *ctx,
}
if (texObj->_Complete) {
texUnit->_ReallyEnabled = textureBit;
- texUnit->_Current = texObj;
+ _mesa_reference_texobj(&texUnit->_Current, texObj);
update_texture_compare_function(ctx, texObj);
}
}
@@ -485,7 +485,6 @@ update_texture_state( GLcontext *ctx )
GLbitfield enableBits;
GLuint tex;
- texUnit->_Current = NULL;
texUnit->_ReallyEnabled = 0;
texUnit->_GenFlags = 0;