graphics/blender: use statvfs on solaris

From Gilles Dauphin in PR 35928.
This commit is contained in:
dholland 2022-05-23 05:21:25 +00:00
parent 578175f9d1
commit 0cae59ffaf
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.66 2021/11/15 17:49:09 wiz Exp $
$NetBSD: distinfo,v 1.67 2022/05/23 05:21:25 dholland Exp $
BLAKE2s (blender-2.93.5.tar.xz) = 9644846b63519b9a3b3e3bf86311df2ca6eef6566fe2ce46abc26e580fb2adf5
SHA512 (blender-2.93.5.tar.xz) = 274e94fa64af0a414815d2809870982dc1093732ddad9e91318f96ce5b72102d9afab16273724127568c0e890dad921bd8f72d7b0e74c9c501b3e86f6b7cfaa0
@ -11,6 +11,7 @@ SHA1 (patch-extern_glog_src_config.h) = e445c911d4ebb1f7e378c3c46911b55f77ba5608
SHA1 (patch-extern_glog_src_config__netbsd.h) = f96dd9d6afed38466e5765c604efebcd78537a54
SHA1 (patch-intern_cycles_kernel_svm_svm__sky.h) = bc672c23ea5f7c837d6a1f34bae87b9ef093309e
SHA1 (patch-intern_guardedalloc_intern_mallocn__intern.h) = 81fb0fd1b34d550168a4bdf63f28b4e199717921
SHA1 (patch-source_blender_blenlib_intern_storage.c) = 5f827d6e263d80e540681c5be7cad37aeae47d86
SHA1 (patch-source_blender_gpu_intern_gpu_matrix.cc) = 107866999d07a8bf74af722aa26f8b438c76ed39
SHA1 (patch-source_blender_imbuf_intern_anim_movie.c) = 1529f84515395a4764c826b90191f87131601881
SHA1 (patch-source_blender_imbuf_intern_openexr_openexr__api.cpp) = 936590a84bc5c2a25567b89fbb8f03467e41d198

View file

@ -0,0 +1,15 @@
$NetBSD: patch-source_blender_blenlib_intern_storage.c,v 1.1 2022/05/23 05:21:25 dholland Exp $
Use statvfs on Solaris. (From PR 35928)
--- source/blender/blenlib/intern/storage.c~ 2021-08-10 01:31:50.000000000 +0000
+++ source/blender/blenlib/intern/storage.c
@@ -29,7 +29,7 @@
#include <sys/stat.h>
-#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__HAIKU__)
+#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__HAIKU__) || defined(__sun)
/* Other modern unix OS's should probably use this also. */
# include <sys/statvfs.h>
# define USE_STATFS_STATVFS