Add powerpc support to sysutils/u-boot.
This commit is contained in:
parent
1f159a667c
commit
0cb0461a33
3 changed files with 26 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.30 2019/10/16 23:36:32 bad Exp $
|
||||
$NetBSD: distinfo,v 1.31 2020/03/30 16:30:54 riastradh Exp $
|
||||
|
||||
SHA1 (u-boot-2018.11.tar.bz2) = e58e86c633ad3e2613196e0c0b0a7760ae5966d6
|
||||
RMD160 (u-boot-2018.11.tar.bz2) = f63c67750951d0e2883935a5d4cc3252f51a5453
|
||||
|
@ -11,6 +11,7 @@ SHA1 (patch-arch_arm_dts_sun8i-h2-plus-bananapi-m2-zero.dts) = aaa530a5f520eea0c
|
|||
SHA1 (patch-arch_arm_dts_sun8i-h2-plus-bananapi-p2-zero.dts) = 8c78d0e0877aa9784fa209af2e16e80cb1110364
|
||||
SHA1 (patch-arch_arm_dts_sun8i-h3-nanopi-duo2.dts) = ec4927bb5f024f9aca6f71890c4bc14dc53e8ba7
|
||||
SHA1 (patch-arch_arm_dts_sun8i-h3-nanopi-r1.dts) = a192c05c31038cf11354dd4a32d94b5b62945661
|
||||
SHA1 (patch-arch_powerpc_include_asm_byteorder.h) = 8cab2805c6b21c986f7b4e2c38db11dfcea28c42
|
||||
SHA1 (patch-configs_A20-OLinuXino-Lime2-eMMC_defconfig) = 425ae3a82ce9006dbd734f41f7d49bb3587b1493
|
||||
SHA1 (patch-configs_A20-OLinuXino-Lime2_defconfig) = 9eecb0a44ec9ddda2425b042c219f59ba546a494
|
||||
SHA1 (patch-configs_bananapi_m2_zero_defconfig) = 5e4baef63f0e51cb8c94a1dc0c0e50ecb016807d
|
||||
|
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-arch_powerpc_include_asm_byteorder.h,v 1.1 2020/03/30 16:30:54 riastradh Exp $
|
||||
|
||||
Don't use inline powerpc asm when compiling a host tool on, e.g., x86.
|
||||
|
||||
--- arch/powerpc/include/asm/byteorder.h.orig 2020-03-11 21:02:16.860469825 +0000
|
||||
+++ arch/powerpc/include/asm/byteorder.h
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
#include <asm/types.h>
|
||||
|
||||
-#ifdef __GNUC__
|
||||
+#ifdef brokenforcrosscompile__GNUC__
|
||||
|
||||
static __inline__ unsigned ld_le16(const volatile unsigned short *addr)
|
||||
{
|
9
sysutils/u-boot/u-boot-powerpc.mk
Normal file
9
sysutils/u-boot/u-boot-powerpc.mk
Normal file
|
@ -0,0 +1,9 @@
|
|||
# $NetBSD: u-boot-powerpc.mk,v 1.1 2020/03/30 16:30:54 riastradh Exp $
|
||||
|
||||
MAINTAINER= port-powerpc@NetBSD.org
|
||||
TOOL_DEPENDS+= cross-powerpc-none-elf-gcc-[0-9]*:../../cross/powerpc-none-elf-gcc
|
||||
|
||||
UBOOT_ENV+= CROSS_COMPILE=${PREFIX}/cross-powerpc-none-elf/bin/powerpc-none-elf-
|
||||
|
||||
.include "u-boot.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
Loading…
Reference in a new issue