Changes 2.6:
- nvenc encoder - 10bit spp filter - colorlevels filter - RIFX format for *.wav files - RTP/mpegts muxer - non continuous cache protocol support - tblend filter - cropdetect support for non 8bpp, absolute (if limit >= 1) and relative (if limit < 1.0) threshold - Camellia symmetric block cipher - OpenH264 encoder wrapper - VOC seeking support - Closed caption Decoder - fspp, uspp, pp7 MPlayer postprocessing filters ported to native filters - showpalette filter - Twofish symmetric block cipher - Support DNx100 (960x720@8) - eq2 filter ported from libmpcodecs as eq filter - removed libmpcodecs - Changed default DNxHD colour range in QuickTime .mov derivatives to mpeg range - ported softpulldown filter from libmpcodecs as repeatfields filter - dcshift filter - RTP depacketizer for loss tolerant payload format for MP3 audio (RFC 5219) - RTP depacketizer for AC3 payload format (RFC 4184) - palettegen and paletteuse filters - VP9 RTP payload format (draft 0) experimental depacketizer - RTP depacketizer for DV (RFC 6469) - DXVA2-accelerated HEVC decoding - AAC ELD 480 decoding - Intel QSV-accelerated H.264 decoding - DSS SP decoder and DSS demuxer - Fix stsd atom corruption in DNxHD QuickTimes - Canopus HQX decoder - RTP depacketization of T.140 text (RFC 4103) - VP9 RTP payload format (draft 0) experimental depacketizer - Port MIPS optimizations to 64-bit
This commit is contained in:
parent
e7bc96af7d
commit
0cbffe573d
4 changed files with 32 additions and 12 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.29 2015/02/14 15:41:42 adam Exp $
|
||||
# $NetBSD: Makefile.common,v 1.30 2015/03/08 08:10:13 adam Exp $
|
||||
# used by multimedia/ffmpeg2/Makefile
|
||||
# used by multimedia/ffplay2/Makefile
|
||||
|
||||
DISTNAME= ffmpeg-2.5.4
|
||||
DISTNAME= ffmpeg-2.6
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://www.ffmpeg.org/releases/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2014/12/06 09:18:41 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2015/03/08 08:10:13 adam Exp $
|
||||
bin/ffmpeg2
|
||||
bin/ffprobe2
|
||||
bin/ffserver2
|
||||
|
@ -7,6 +7,7 @@ include/ffmpeg2/libavcodec/avfft.h
|
|||
include/ffmpeg2/libavcodec/dv_profile.h
|
||||
include/ffmpeg2/libavcodec/dxva2.h
|
||||
include/ffmpeg2/libavcodec/old_codec_ids.h
|
||||
include/ffmpeg2/libavcodec/qsv.h
|
||||
include/ffmpeg2/libavcodec/vaapi.h
|
||||
include/ffmpeg2/libavcodec/vda.h
|
||||
include/ffmpeg2/libavcodec/vdpau.h
|
||||
|
@ -39,6 +40,7 @@ include/ffmpeg2/libavutil/blowfish.h
|
|||
include/ffmpeg2/libavutil/bprint.h
|
||||
include/ffmpeg2/libavutil/bswap.h
|
||||
include/ffmpeg2/libavutil/buffer.h
|
||||
include/ffmpeg2/libavutil/camellia.h
|
||||
include/ffmpeg2/libavutil/cast5.h
|
||||
include/ffmpeg2/libavutil/channel_layout.h
|
||||
include/ffmpeg2/libavutil/common.h
|
||||
|
@ -86,6 +88,7 @@ include/ffmpeg2/libavutil/threadmessage.h
|
|||
include/ffmpeg2/libavutil/time.h
|
||||
include/ffmpeg2/libavutil/timecode.h
|
||||
include/ffmpeg2/libavutil/timestamp.h
|
||||
include/ffmpeg2/libavutil/twofish.h
|
||||
include/ffmpeg2/libavutil/version.h
|
||||
include/ffmpeg2/libavutil/xtea.h
|
||||
include/ffmpeg2/libpostproc/postprocess.h
|
||||
|
@ -97,23 +100,23 @@ include/ffmpeg2/libswscale/version.h
|
|||
lib/ffmpeg2/libavcodec.a
|
||||
lib/ffmpeg2/libavcodec.so
|
||||
lib/ffmpeg2/libavcodec.so.56
|
||||
lib/ffmpeg2/libavcodec.so.56.13.100
|
||||
lib/ffmpeg2/libavcodec.so.56.26.100
|
||||
lib/ffmpeg2/libavdevice.a
|
||||
lib/ffmpeg2/libavdevice.so
|
||||
lib/ffmpeg2/libavdevice.so.56
|
||||
lib/ffmpeg2/libavdevice.so.56.3.100
|
||||
lib/ffmpeg2/libavdevice.so.56.4.100
|
||||
lib/ffmpeg2/libavfilter.a
|
||||
lib/ffmpeg2/libavfilter.so
|
||||
lib/ffmpeg2/libavfilter.so.5
|
||||
lib/ffmpeg2/libavfilter.so.5.2.103
|
||||
lib/ffmpeg2/libavfilter.so.5.11.102
|
||||
lib/ffmpeg2/libavformat.a
|
||||
lib/ffmpeg2/libavformat.so
|
||||
lib/ffmpeg2/libavformat.so.56
|
||||
lib/ffmpeg2/libavformat.so.56.15.102
|
||||
lib/ffmpeg2/libavformat.so.56.25.101
|
||||
lib/ffmpeg2/libavutil.a
|
||||
lib/ffmpeg2/libavutil.so
|
||||
lib/ffmpeg2/libavutil.so.54
|
||||
lib/ffmpeg2/libavutil.so.54.15.100
|
||||
lib/ffmpeg2/libavutil.so.54.20.100
|
||||
lib/ffmpeg2/libpostproc.a
|
||||
lib/ffmpeg2/libpostproc.so
|
||||
lib/ffmpeg2/libpostproc.so.53
|
||||
|
@ -160,6 +163,7 @@ share/ffmpeg2/examples/filtering_audio.c
|
|||
share/ffmpeg2/examples/filtering_video.c
|
||||
share/ffmpeg2/examples/metadata.c
|
||||
share/ffmpeg2/examples/muxing.c
|
||||
share/ffmpeg2/examples/qsvdec.c
|
||||
share/ffmpeg2/examples/remuxing.c
|
||||
share/ffmpeg2/examples/resampling_audio.c
|
||||
share/ffmpeg2/examples/scaling_video.c
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.28 2015/02/14 15:41:42 adam Exp $
|
||||
$NetBSD: distinfo,v 1.29 2015/03/08 08:10:13 adam Exp $
|
||||
|
||||
SHA1 (ffmpeg-2.5.4.tar.bz2) = e7d0bab14e82876762531a883c6b48918631d48c
|
||||
RMD160 (ffmpeg-2.5.4.tar.bz2) = 523955845e4880c13e200846daf7787055a6db9b
|
||||
Size (ffmpeg-2.5.4.tar.bz2) = 7677320 bytes
|
||||
SHA1 (ffmpeg-2.6.tar.bz2) = 3bfc61fc3906373aecaaa523a9d13cfa9ff7e7ed
|
||||
RMD160 (ffmpeg-2.6.tar.bz2) = 86c4af5b3f43fde318a7a8557f6787449a4d28c5
|
||||
Size (ffmpeg-2.6.tar.bz2) = 7799342 bytes
|
||||
SHA1 (patch-Makefile) = ff8a7a5fdfd4987ef2835bd7360a78efd4310253
|
||||
SHA1 (patch-configure) = 580e744f44bc6b7622a21d27fcf14f934a280179
|
||||
SHA1 (patch-libavcodec_x86_ac3dsp_init.c) = 8634661d76bc3bce43437caa4244b4f52237709f
|
||||
SHA1 (patch-libavutil_common.h) = ebbd0c169f228af37ae2dd54b27d5dba11a34c5e
|
||||
SHA1 (patch-libavutil_opencl.c) = 46da890f06ab3db7fbed84aff0f6f30fa1d2adfe
|
||||
SHA1 (patch-libavutil_x86_asm.h) = 3fe732ec6da9f0920d3c6e3a5db9bed65b0a3e40
|
||||
SHA1 (patch-libavutil_x86_cpu.c) = ece66a5b22130754c11c643dae48171d04d3246f
|
||||
|
|
15
multimedia/ffmpeg2/patches/patch-libavutil_opencl.c
Normal file
15
multimedia/ffmpeg2/patches/patch-libavutil_opencl.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-libavutil_opencl.c,v 1.1 2015/03/08 08:10:13 adam Exp $
|
||||
|
||||
Fix undeclared identifier error.
|
||||
|
||||
--- libavutil/opencl.c.orig 2015-03-08 07:52:00.000000000 +0000
|
||||
+++ libavutil/opencl.c
|
||||
@@ -611,7 +611,7 @@ void av_opencl_uninit(void)
|
||||
}
|
||||
opencl_ctx.context = NULL;
|
||||
}
|
||||
- for (i = 0; i < opencl_ctx.kernel_code_count; i++) {
|
||||
+ for (int i = 0; i < opencl_ctx.kernel_code_count; i++) {
|
||||
opencl_ctx.kernel_code[i].is_compiled = 0;
|
||||
}
|
||||
free_device_list(&opencl_ctx.device_list);
|
Loading…
Reference in a new issue