nodejs: build fix for netbsd<9

netbsd's #define uint32_t still causes issues. PR pkg/55530
This commit is contained in:
maya 2020-08-07 06:26:54 +00:00
parent a348f31078
commit 0cd92ed250
2 changed files with 23 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.176 2020/08/05 21:49:18 maya Exp $
$NetBSD: distinfo,v 1.177 2020/08/07 06:26:54 maya Exp $
SHA1 (node-v14.7.0.tar.xz) = f847feec3dc00be5aa04772c5ac8bde4224429df
RMD160 (node-v14.7.0.tar.xz) = b0ddaf74aa68b36e0781d09ad31fb007016b710b
@ -7,6 +7,7 @@ Size (node-v14.7.0.tar.xz) = 33317268 bytes
SHA1 (patch-common.gypi) = f0bd2962bf7c8466db24b35a35154897ecad6316
SHA1 (patch-deps_cares_cares.gyp) = 22b44f2ac59963f694dfe4f4585e08960b3dec32
SHA1 (patch-deps_uv_common.gypi) = d38a9c8d9e3522f15812aec2f5b1e1e636d4bab3
SHA1 (patch-deps_uvwasi_include_wasi__serdes.h) = 4f418755259c9e717860a0c37b905ea1e799702a
SHA1 (patch-deps_v8_src_base_atomicops.h) = 05b1f62850c3d4a9a8e94a5263be1c4267cf566d
SHA1 (patch-deps_v8_src_base_platform_platform-freebsd.cc) = b47025f33d2991275bbcd15dbabb28900afab0e1
SHA1 (patch-deps_v8_src_base_platform_platform-openbsd.cc) = 5e593879dbab095f99e82593272a0de91043f9a8

View file

@ -0,0 +1,21 @@
$NetBSD: patch-deps_uvwasi_include_wasi__serdes.h,v 1.1 2020/08/07 06:26:54 maya Exp $
NetBSD<9 used to have #define uint8_t etc. which caused issues with complicated
defines like this one.
--- deps/uvwasi/include/wasi_serdes.h.orig 2020-07-29 16:50:21.000000000 +0000
+++ deps/uvwasi/include/wasi_serdes.h
@@ -3,6 +3,13 @@
#include "wasi_types.h"
+#ifdef __NetBSD__
+#undef uint8_t
+#undef uint16_t
+#undef uint32_t
+#undef uint64_t
+#endif
+
/* Basic uint{8,16,32,64}_t read/write functions. */
#define BASIC_TYPE_(name, type) \