Changes 4.54:

Block-triangular LU-factorization was implemented to be used
on computing an initial factorization of the basis matrix.

A new version of the Schur-complement-based factorization
module was included in the package. Now it can be used along
with plain as well as with block-triangular LU-factorization.

Currently the following flags can be used to specify the type
of the basis matrix factorization (glp_bfcp.type):

GLP_BF_LUF + GLP_BF_FT   LUF, Forrest-Tomlin update (default)
GLP_BF_LUF + GLP_BF_BG   LUF, Schur complement, Bartels-Golub
                         update
GLP_BF_LUF + GLP_BF_GR   LUF, Schur complement, Givens rotation
                         update
GLP_BF_BTF + GLP_BF_BG   BTF, Schur complement, Bartels-Golub
                         update
GLP_BF_BTF + GLP_BF_GR   BTF, Schur complement, Givens rotation
                         update

In case of GLP_BF_FT the update is applied to matrix U, while
in cases of GLP_BF_BG and GLP_BF_GR the update is applied to
the Schur complement.

Corresponding new options --luf and --btf were added to glpsol.

For more details please see a new edition of the GLPK reference
manual included in the distribution.

A minor bug (in reporting the mip solution status) was fixed.

A call to "iodbc-config --cflags" was added in configure.ac
to correctly detect iodbc flags.
This commit is contained in:
adam 2014-04-01 08:38:35 +00:00
parent 84fe4c1696
commit 0cdeed0b1d
5 changed files with 74 additions and 23 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.39 2014/02/14 09:25:49 adam Exp $
# $NetBSD: Makefile,v 1.40 2014/04/01 08:38:35 adam Exp $
DISTNAME= glpk-4.53
DISTNAME= glpk-4.54
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU:=glpk/}
@ -16,4 +16,5 @@ CONFIGURE_ARGS+= --with-gmp
TEST_TARGET= check
.include "../../devel/gmp/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.10 2010/03/24 21:54:16 asau Exp $
# $NetBSD: buildlink3.mk,v 1.11 2014/04/01 08:38:35 adam Exp $
BUILDLINK_TREE+= glpk
@ -10,6 +10,7 @@ BUILDLINK_ABI_DEPENDS.glpk+= glpk>=4.35nb1
BUILDLINK_PKGSRCDIR.glpk?= ../../math/glpk
.include "../../devel/gmp/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.endif # GLPK_BUILDLINK3_MK
BUILDLINK_TREE+= -glpk

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.32 2014/02/14 09:25:49 adam Exp $
$NetBSD: distinfo,v 1.33 2014/04/01 08:38:35 adam Exp $
SHA1 (glpk-4.53.tar.gz) = 7f61e646d4d669805ac252d62005dfd2ff818d23
RMD160 (glpk-4.53.tar.gz) = 457c0ee03c61ab395f5411311e2baf3c3583c9b5
Size (glpk-4.53.tar.gz) = 2803321 bytes
SHA1 (patch-src_glpapi06.c) = 0037423f2a4e85d2e93c659debdf6191c01ef695
SHA1 (glpk-4.54.tar.gz) = 69d9c5d83271d34de1a58d2de2f7ababab975492
RMD160 (glpk-4.54.tar.gz) = 4de0079c712dcab817a1d7b936f2ba4b1252129f
Size (glpk-4.54.tar.gz) = 3098202 bytes
SHA1 (patch-src_Makefile.in) = a28908145e2f4798679f34264dffa2780c7c4e3b

View file

@ -0,0 +1,64 @@
$NetBSD: patch-src_Makefile.in,v 1.1 2014/04/01 08:38:35 adam Exp $
Use external zlib.
--- src/Makefile.in.orig 2014-04-01 08:25:18.000000000 +0000
+++ src/Makefile.in
@@ -94,7 +94,7 @@ am__uninstall_files_from_dir = { \
}
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(includedir)"
LTLIBRARIES = $(lib_LTLIBRARIES)
-libglpk_la_LIBADD =
+libglpk_la_LIBADD = -lz
am_libglpk_la_OBJECTS = libglpk_la-avl.lo libglpk_la-bfd.lo \
libglpk_la-bfx.lo libglpk_la-glpapi01.lo \
libglpk_la-glpapi02.lo libglpk_la-glpapi03.lo \
@@ -151,13 +151,7 @@ am_libglpk_la_OBJECTS = libglpk_la-avl.l
libglpk_la-strspx.lo libglpk_la-strtrim.lo \
libglpk_la-triang.lo libglpk_la-wclique.lo \
libglpk_la-wclique1.lo libglpk_la-proxy.lo \
- libglpk_la-proxy1.lo libglpk_la-adler32.lo \
- libglpk_la-compress.lo libglpk_la-crc32.lo \
- libglpk_la-deflate.lo libglpk_la-gzclose.lo \
- libglpk_la-gzlib.lo libglpk_la-gzread.lo libglpk_la-gzwrite.lo \
- libglpk_la-inffast.lo libglpk_la-inflate.lo \
- libglpk_la-inftrees.lo libglpk_la-trees.lo \
- libglpk_la-uncompr.lo libglpk_la-zio.lo libglpk_la-zutil.lo
+ libglpk_la-proxy1.lo
libglpk_la_OBJECTS = $(am_libglpk_la_OBJECTS)
libglpk_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
@@ -310,8 +304,7 @@ libglpk_la_CPPFLAGS = \
-I$(srcdir)/env \
-I$(srcdir)/minisat \
-I$(srcdir)/misc \
--I$(srcdir)/proxy \
--I$(srcdir)/zlib
+-I$(srcdir)/proxy
libglpk_la_LDFLAGS = \
-version-info 37:1:1 \
@@ -447,22 +440,7 @@ misc/triang.c \
misc/wclique.c \
misc/wclique1.c \
proxy/proxy.c \
-proxy/proxy1.c \
-zlib/adler32.c \
-zlib/compress.c \
-zlib/crc32.c \
-zlib/deflate.c \
-zlib/gzclose.c \
-zlib/gzlib.c \
-zlib/gzread.c \
-zlib/gzwrite.c \
-zlib/inffast.c \
-zlib/inflate.c \
-zlib/inftrees.c \
-zlib/trees.c \
-zlib/uncompr.c \
-zlib/zio.c \
-zlib/zutil.c
+proxy/proxy1.c
all: all-am

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_glpapi06.c,v 1.1 2014/02/14 09:25:49 adam Exp $
Function should return a value.
--- src/glpapi06.c.orig 2014-02-14 09:20:28.000000000 +0000
+++ src/glpapi06.c
@@ -815,7 +815,7 @@ int glp_get_it_cnt(glp_prob *P)
int glp_set_it_cnt(glp_prob *P, int it_cnt)
{ /* set simplex solver iteration count */
P->it_cnt = it_cnt;
- return;
+ return P->it_cnt;
}
#endif