emulators/vice: Fix all non-NetBSD platforms

* Update configure script to force all platforms to use same installation
  path as NetBSD
* The PLIST was built with fc-cache detected.  This implicates fontconfig
  as a dependency (without it, font still install but with a diff. name)
* like NetBSD, define HAVE_STDINT_H (other platforms may need it too)

Revbump required because package would have installed before without
PKG_DEVELOPER=yes, albeit incorrectly.
This commit is contained in:
marino 2012-08-14 18:49:43 +00:00
parent df2589f37e
commit 0cf508b6d8
3 changed files with 53 additions and 10 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.95 2012/03/03 12:54:17 wiz Exp $
# $NetBSD: Makefile,v 1.96 2012/08/14 18:49:43 marino Exp $
DISTNAME= vice-2.3
PKGREVISION= 5
PKGREVISION= 6
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=vice-emu:Q}/
MASTER_SITES+= ftp://ftp.zimmers.net/pub/cbm/crossplatform/emulators/VICE/
@ -44,9 +44,14 @@ CONFIGURE_ARGS+= --without-oss
CPPFLAGS+= -DHAVE_STDINT_H
.endif
.if (${OPSYS} == DragonFly)
CPPFLAGS+= -DHAVE_STDINT_H
.endif
.include "../../devel/readline/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.38 2011/04/04 13:42:08 wiz Exp $
$NetBSD: distinfo,v 1.39 2012/08/14 18:49:43 marino Exp $
SHA1 (vice-2.3.tar.gz) = 5e7e1a375a4ca8c4895dc1552162955fdffce296
RMD160 (vice-2.3.tar.gz) = 056e48ffedfaecd470892c73b97af89c1e002ff9
Size (vice-2.3.tar.gz) = 11602378 bytes
SHA1 (patch-aa) = 7ecda5911a2dd0e7ef8676959d9dc021323d393f
SHA1 (patch-ab) = 095839b7f234f803d01296dc72c37ec9909bcbce
SHA1 (patch-ab) = dada25dfd5c40db040b1b99fd7071986db5b50cc

View file

@ -1,11 +1,13 @@
$NetBSD: patch-ab,v 1.11 2011/04/04 13:42:08 wiz Exp $
$NetBSD: patch-ab,v 1.12 2012/08/14 18:49:44 marino Exp $
1. dynamic lib support does not depend on the existence of libdl
2. patch out error message about --without-iconv-base
3. Use the NetBSD configuration for every OS since the PLIST is
hardcoded for that. Should fix every non-NetBSD platform.
--- configure.orig 2011-02-26 19:07:06.000000000 +0100
+++ configure 2011-02-27 13:56:52.000000000 +0100
@@ -3381,7 +3381,7 @@
--- configure.orig 2011-02-26 18:07:06.000000000 +0000
+++ configure
@@ -3381,7 +3381,7 @@ do
;;
esac
if test x"$argvalid" = "xno"; then
@ -14,7 +16,7 @@ $NetBSD: patch-ab,v 1.11 2011/04/04 13:42:08 wiz Exp $
fi
done
@@ -10381,13 +10381,13 @@
@@ -10381,13 +10381,13 @@ fi
if test x"$ac_cv_header_dlfcn_h" = "xyes" ; then
@ -31,7 +33,7 @@ $NetBSD: patch-ab,v 1.11 2011/04/04 13:42:08 wiz Exp $
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -10418,7 +10418,7 @@
@@ -10418,7 +10418,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_dl_dlopen" >&5
$as_echo "$ac_cv_lib_dl_dlopen" >&6; }
if test "x$ac_cv_lib_dl_dlopen" = x""yes; then :
@ -40,3 +42,39 @@ $NetBSD: patch-ab,v 1.11 2011/04/04 13:42:08 wiz Exp $
$as_echo "#define HAVE_DYNLIB_SUPPORT /**/" >>confdefs.h
@@ -19664,34 +19664,12 @@ _ACEOF
case "$host_os" in
- netbsd*)
+ *)
VICEDIR="$PREFIX/share/vice";
if true; then
ALTERNATE_DOCDIR_TRUE=
ALTERNATE_DOCDIR_FALSE='#'
else
- ALTERNATE_DOCDIR_TRUE='#'
- ALTERNATE_DOCDIR_FALSE=
-fi
-
- ;;
- freebsd*)
- VICEDIR="$PREFIX/lib/vice";
- if true; then
- ALTERNATE_DOCDIR_TRUE=
- ALTERNATE_DOCDIR_FALSE='#'
-else
- ALTERNATE_DOCDIR_TRUE='#'
- ALTERNATE_DOCDIR_FALSE=
-fi
-
- ;;
- *)
- VICEDIR="$PREFIX/lib/vice";
- if false; then
- ALTERNATE_DOCDIR_TRUE=
- ALTERNATE_DOCDIR_FALSE='#'
-else
ALTERNATE_DOCDIR_TRUE='#'
ALTERNATE_DOCDIR_FALSE=
fi