Update to 1.10:

1.10
- now use from_to instead of utf8::decode (which is experimental
  and might vanish in the future) to check for valid UTF-8
- updates and cleanups of testsuite and include "0" filename
- fix "0" filename bugs
- take into account that charset name "utf-8" resolves to "utf-8-strict"
  in recent Perl versions
This commit is contained in:
wiz 2007-01-14 16:25:25 +00:00
parent 50e475b81e
commit 0d1c6e4a58
3 changed files with 59 additions and 93 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2006/07/17 15:09:59 rillig Exp $
# $NetBSD: Makefile,v 1.6 2007/01/14 16:25:25 wiz Exp $
DISTNAME= convmv-1.09
DISTNAME= convmv-1.10
CATEGORIES= converters
MASTER_SITES= http://www.j3e.de/linux/convmv/
@ -11,6 +11,7 @@ COMMENT= Converts filenames from one encoding to another
PKG_INSTALLATION_TYPES= overwrite pkgviews
BUILD_DEPENDS+= coreutils-[0-9]*:../../sysutils/coreutils
BUILD_DEPENDS+= findutils-[0-9]*:../../sysutils/findutils
USE_LANGUAGES= # empty
USE_TOOLS+= perl:run
@ -22,7 +23,8 @@ BUILD_DEFS+= GNU_PROGRAM_PREFIX
# the test script needs the GNU versions
MAKE_ENV+= CONVMV_LS=${GNU_PROGRAM_PREFIX}ls \
CONVMV_CP=${GNU_PROGRAM_PREFIX}cp
CONVMV_CP=${GNU_PROGRAM_PREFIX}cp \
CONVMV_FIND=${GNU_PROGRAM_PREFIX}find
MAKEFLAGS+= MANDIR=${PREFIX}/man \
INSTALL_MAN_DIR=${INSTALL_MAN_DIR:Q} \

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.2 2006/02/11 17:24:17 heinz Exp $
$NetBSD: distinfo,v 1.3 2007/01/14 16:25:25 wiz Exp $
SHA1 (convmv-1.09.tar.gz) = b8d44519a1110a620afe37d367f0f31542156880
RMD160 (convmv-1.09.tar.gz) = f4164d07f2c4886003f8e6ca14334a5ab318e9e7
Size (convmv-1.09.tar.gz) = 21003 bytes
SHA1 (convmv-1.10.tar.gz) = 44cee0c861ced92c5061a0e2287bfb9ef791d22f
RMD160 (convmv-1.10.tar.gz) = e9faf9e698006b2faa24e65374819053cfa0b6a4
Size (convmv-1.10.tar.gz) = 21276 bytes
SHA1 (patch-aa) = 9f369bfffcaa4c62b2b9a96828fe25a5ce936e83
SHA1 (patch-ab) = f91b95ae447376175108df093d5d802e0d016bd8
SHA1 (patch-ab) = 94f9dd6fa7d402c0f1fe9a35b8f89e378b4da0e3

View file

@ -1,11 +1,15 @@
$NetBSD: patch-ab,v 1.2 2006/02/11 17:24:17 heinz Exp $
$NetBSD: patch-ab,v 1.3 2007/01/14 16:25:25 wiz Exp $
--- suite/dotests.sh.orig Fri Dec 9 17:11:46 2005
--- suite/dotests.sh.orig 2006-06-25 22:01:16.000000000 +0000
+++ suite/dotests.sh
@@ -1,77 +1,86 @@
@@ -1,13 +1,21 @@
#!/bin/sh
-for d in `ls -d test*` ; do cd $d ; ls -R -g -G --time-style=+ >../out-$d ; cd .. ; done
+
# this requires GNU find to be used because of -printf feature
# you might want to change this to GNU find's full path:
-FIND=find
+FIND=${CONVMV_FIND}
FINDEXP="%P -- %l\n"
-for dir in `ls -d test*` ; do $FIND $dir/ -printf "$FINDEXP" > out-$dir ; done
+# make this overridable on non-GNU systems which may have those commands
+# as gls and gcp
+CONVMV_LS=${CONVMV_LS:-ls}
@ -14,94 +18,54 @@ $NetBSD: patch-ab,v 1.2 2006/02/11 17:24:17 heinz Exp $
+# to get 0777 permissions for symlinks on non-Linux systems
+umask 0
+
+for d in `${CONVMV_LS} -d test*` ; do cd $d ; ${CONVMV_LS} -R -g -G --time-style=+ >../out-$d ; cd .. ; done
+for dir in `${CONVMV_LS} -d test*` ; do $FIND $dir/ -printf "$FINDEXP" > out-$dir ; done
#
echo smartness-test
rm -rf test2
-cp -a test test2
+${CONVMV_CP} -a test test2
../convmv -f iso8859-15 -t utf8 --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
diff out-test out2 || { echo "smartness-test failed." ; exit 1; }
#
echo double-utf8 test
../convmv -f iso8859-15 -t utf8 --notest -r --nosmart test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
pwd
diff out-test-utf8 out2 || { echo "double-utf8 test failed." ; exit 1; }
#
../convmv -f utf8 -t iso8859-15 --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
pwd
diff out-test out2 || { echo undo-double-utf8 test failed. ; exit 1; }
rm -rf test.tmp
-cp -r test test.tmp
+${CONVMV_CP} -r test test.tmp
../convmv -f iso8859-15 -t utf8 --notest -r test.tmp
false
$FIND test.tmp -printf "$FINDEXP" > out.tmp
@@ -24,21 +32,21 @@ diff out-test out.tmp > diff.tmp|| { ech
#
echo utf8-to-iso8859-15-test
rm -r test2
-cp -a test test2
+${CONVMV_CP} -a test test2
../convmv -f utf8 -t iso8859-15 --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
diff out-test-iso8859-15 out2 || { echo utf8-to-iso8859-15-test failed. ; exit 1; }
rm -r test.tmp
-cp -r test test.tmp
+${CONVMV_CP} -r test test.tmp
../convmv -f utf8 -t iso8859-15 --notest -r test.tmp
$FIND test.tmp -printf "$FINDEXP" > out.tmp
diff out-test-iso8859-15 out.tmp > diff.tmp|| { echo utf8-to-iso8859-15-test failed. ; exit 1; }
#
echo iso8859-15-to-utf8-test
rm -r test2
-cp -a test-iso8859-15 test2
+${CONVMV_CP} -a test-iso8859-15 test2
../convmv -f iso8859-15 -t utf8 --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
diff out-test out2 || { echo iso8859-15-to-utf8-test failed. ; exit 1; }
rm -r test.tmp
-cp -r test-iso8859-15 test.tmp
+${CONVMV_CP} -r test-iso8859-15 test.tmp
../convmv -f iso8859-15 -t utf8 --notest -r test.tmp
$FIND test.tmp -printf "$FINDEXP" > out.tmp
diff out-test out.tmp > diff.tmp|| { echo iso8859-15-to-utf8-test failed. ; exit 1; }
#
echo nfc-test
rm -r test2
-cp -a test test2
+${CONVMV_CP} -a test test2
../convmv -f utf8 -t utf8 --nfd --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
diff out-test-nfd out2 || { echo nfd-test failed. ; exit 1; }
#
../convmv -f utf8 -t utf8 --nfc --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
diff out-test out2 || { echo nfc-test failed. ; exit 1; }
rm -r test.tmp
-cp -r test test.tmp
+${CONVMV_CP} -r test test.tmp
../convmv -f utf-8 -t utf-8 --nfd --notest -r test.tmp
$FIND test.tmp -printf "$FINDEXP" > out.tmp
diff out-test-nfd out.tmp > diff.tmp|| { echo nfd-test failed. ; exit 1; }
@@ -49,14 +57,14 @@ diff out-test out.tmp > diff.tmp|| { ech
#
echo escaped-test
rm -r test2
-cp -a test-escaped test2
+${CONVMV_CP} -a test-escaped test2
../convmv --unescape --notest -r test2
cd test2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
diff out-test out2 || { echo escaped-test failed. ; exit 1; }
rm -r test.tmp
-cp -r test-escaped test.tmp
+${CONVMV_CP} -r test-escaped test.tmp
../convmv --unescape --notest -r test.tmp
$FIND test.tmp -printf "$FINDEXP" > out.tmp
diff out-test out.tmp > diff.tmp|| { echo escaped-test failed. ; exit 1; }
#
rm -r test2
-cp -a test test2
+${CONVMV_CP} -a test test2
../convmv --upper -f utf8 --notest -r test2
cd TEST2
-ls -R -g -G --time-style=+ >../out2
+${CONVMV_LS} -R -g -G --time-style=+ >../out2
cd ..
rm -r TEST2
diff out-test-upper out2 || { echo upper-test failed. ; exit 1; }
echo upper-test
rm -r test.tmp
-cp -r test test.tmp
+${CONVMV_CP} -r test test.tmp
../convmv --upper -f utf8 --notest -r test.tmp
$FIND TEST.TMP -printf "$FINDEXP" > out.tmp
diff out-test-upper out.tmp > diff.tmp|| { echo upper-test failed. ; exit 1; }