Needs libXcursor. Fix portability

This commit is contained in:
joerg 2020-04-20 00:38:59 +00:00
parent ea04dc99b3
commit 0d54bb4bab
3 changed files with 24 additions and 5 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2018/09/02 12:55:25 wiz Exp $
# $NetBSD: Makefile,v 1.24 2020/04/20 00:38:59 joerg Exp $
DISTNAME= tuxpaint-config-0.0.14
CATEGORIES= graphics
@ -20,4 +20,5 @@ INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../print/libpaper/buildlink3.mk"
.include "../../x11/fltk13/buildlink3.mk"
.include "../../x11/libXcursor/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.10 2019/12/19 22:17:33 joerg Exp $
$NetBSD: distinfo,v 1.11 2020/04/20 00:38:59 joerg Exp $
SHA1 (tuxpaint-config-0.0.14.tar.gz) = 9efe6e4d4ad92df1a1a4e5c4f4eff4b1dbde8b0e
RMD160 (tuxpaint-config-0.0.14.tar.gz) = d924da13b0f7221fb34f9d8fe9adeb109d8dd57b
SHA512 (tuxpaint-config-0.0.14.tar.gz) = 2e4482189fed81a7a82f41773a527c5b391ed19800279a1684634fdfd25f5c7f19c4ee42f483e0f3b8a683912c163f9846fc32f663e8fac0f7cf6d8a98c6740c
Size (tuxpaint-config-0.0.14.tar.gz) = 472856 bytes
SHA1 (patch-Makefile) = 89f50784f5bf2c1ca43203ac48d8948afa99ad6a
SHA1 (patch-Makefile) = 2756de7b3b757420eb7e2b1eca9f39e9c39692b0

View file

@ -1,9 +1,27 @@
$NetBSD: patch-Makefile,v 1.1 2019/12/19 22:17:33 joerg Exp $
$NetBSD: patch-Makefile,v 1.2 2020/04/20 00:38:59 joerg Exp $
Ensure that trans directory is made before trying to put files in it.
--- Makefile.orig 2019-12-19 18:27:04.435743784 +0000
--- Makefile.orig 2018-08-28 17:18:29.000000000 +0000
+++ Makefile
@@ -165,7 +165,7 @@ win32:
ICON_PREFIX=./ \
X11_ICON_PREFIX=./ \
CONFDIR=$(PREFIX)/etc/tuxpaint \
- ARCH_LINKS=$(shell if [ "x$$OSTYPE" == "xcygwin" ]; then echo -n "-lintl"; else echo -n "-lintl-8"; fi ) \
+ ARCH_LINKS=$(shell if [ "x$$OSTYPE" = "xcygwin" ]; then echo -n "-lintl"; else echo -n "-lintl-8"; fi ) \
ARCH_LIBS="obj/resource.o obj/win32utils.o" \
PAPER_LIB=
@@ -176,7 +176,7 @@ install-win32:
ICON_PREFIX=./ \
X11_ICON_PREFIX=./ \
CONFDIR=$(PREFIX)/etc/tuxpaint \
- ARCH_LINKS=$(shell if [ "x$$OSTYPE" == "xcygwin" ]; then echo -n "-lintl"; else echo -n "-lintl-8"; fi ) \
+ ARCH_LINKS=$(shell if [ "x$$OSTYPE" = "xcygwin" ]; then echo -n "-lintl"; else echo -n "-lintl-8"; fi ) \
ARCH_LIBS="obj/resource.o obj/win32utils.o"
# "make install" installs all of the various parts
@@ -406,7 +406,7 @@ endif
# Build the translation files for gettext