py-django-cmsplugin_gallery: updated to 2.0.3

2.0.3 / 2022-04-20
==================

  * fix: issue with the history.md file not included in MANIFEST.in file

2.0.0 / 2022-04-20
==================

  * feat: add make file for release automation and generate python3 wheels only
  * correct readme
  * fix: correct metadata
  * feat:add more metadata to the setup.py and add a setup.cfg too
  * feat: update ci setup
  * feat: set default auto field
  * feat: get package building for python 3.10 too
  * feat: python3+ only
  * fix: upgrade deps and also add more settins
  * feat: try updated package for djangocms-helper
  * fix: upgrade to a newer version of djangocms-helper
  * feat: add github actions
  * feat: make python code python3.7+
  * fix: make code django 3.2+ compatible
  * Merge pull request 50 from centralniak/fix/failing-migration-tofiler
  * wrap migration in try except
  * bump version
  * fix yet another typo
  * make it backward compatible
  * add module name in settings name
  * bump version
  * fix typo
  * add configurable module name
This commit is contained in:
adam 2023-12-07 17:43:51 +00:00
parent 22679eea7e
commit 0d766e05a6
4 changed files with 25 additions and 23 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.13 2022/01/04 20:55:18 wiz Exp $
# $NetBSD: Makefile,v 1.14 2023/12/07 17:43:51 adam Exp $
DISTNAME= cmsplugin_gallery-1.1.7
DISTNAME= cmsplugin_gallery-2.0.3
PKGNAME= ${PYPKGPREFIX}-django-${DISTNAME}
PKGREVISION= 1
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_PYPI:=c/cmsplugin_gallery/}
@ -11,14 +10,16 @@ HOMEPAGE= https://github.com/centralniak/cmsplugin_gallery
COMMENT= DjangoCMS image gallery plugin
LICENSE= modified-bsd
DEPENDS+= ${PYPKGPREFIX}-django-cms>=3.2.0:../../www/py-django-cms
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-django-cms>=3.9.0:../../www/py-django-cms
DEPENDS+= ${PYPKGPREFIX}-django-filer>=1.2.4:../../www/py-django-filer
DEPENDS+= ${PYPKGPREFIX}-django-inline-ordering>=0.1.1:../../www/py-django-inline-ordering
DEPENDS+= ${PYPKGPREFIX}-django-inline-ordering>=1.0.2:../../www/py-django-inline-ordering
DEPENDS+= ${PYPKGPREFIX}-easy-thumbnails-[0-9]*:../../www/py-easy-thumbnails
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,9 +1,10 @@
@comment $NetBSD: PLIST,v 1.5 2020/02/19 11:09:52 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.6 2023/12/07 17:43:51 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/AUTHORS
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/cmsplugin_gallery/__init__.py
${PYSITELIB}/cmsplugin_gallery/__init__.pyc
${PYSITELIB}/cmsplugin_gallery/__init__.pyo

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.9 2021/10/26 11:30:30 nia Exp $
$NetBSD: distinfo,v 1.10 2023/12/07 17:43:51 adam Exp $
BLAKE2s (cmsplugin_gallery-1.1.7.tar.gz) = 39fe29b9b2257ce9cdfd030ffc1f180808e3383012e9e65f95065d849a56093d
SHA512 (cmsplugin_gallery-1.1.7.tar.gz) = a047a9c879009c0e858629224f94bd5ee2d97671eef8f9f93a50bd5fb1d6827b78761586a72a00a8019e865f5396d45752823421b2589feaeda068ebb24ede7d
Size (cmsplugin_gallery-1.1.7.tar.gz) = 8964 bytes
SHA1 (patch-setup.py) = 9b299be124965241032c896b0ef24b2af56b6f02
BLAKE2s (cmsplugin_gallery-2.0.3.tar.gz) = 65ecb1ca8b6dfbf0792c2e6a48292f71d74edbe094daee5f2b28fae9627d545d
SHA512 (cmsplugin_gallery-2.0.3.tar.gz) = 3540ff50347165c0bd17b4e5792a17481f9b3da75d903161fa3d84b449e6c1eff9a415f90f01a82d32f31edf16d96a63711c5c1002f9c74611f260e4fa6f4ac9
Size (cmsplugin_gallery-2.0.3.tar.gz) = 13312 bytes
SHA1 (patch-setup.py) = a048ffe3a969740f360898aacfd4f9c2e801a515

View File

@ -1,15 +1,15 @@
$NetBSD: patch-setup.py,v 1.3 2020/02/19 11:09:52 adam Exp $
$NetBSD: patch-setup.py,v 1.4 2023/12/07 17:43:51 adam Exp $
Do not install tests.
--- setup.py.orig 2018-05-03 10:53:37.000000000 +0000
--- setup.py.orig 2022-04-20 15:48:34.000000000 +0000
+++ setup.py
@@ -11,7 +11,7 @@ setup(
description = 'DjangoCMS image gallery plugin with drag&drop '
'reordering in admin, support for thumbnails and '
@@ -48,7 +48,7 @@ setup(
'jQueryTOOLS overlay.',
long_description=readme + "\n\n" + history,
long_description_content_type="text/markdown",
- packages=find_packages(),
+ packages=find_packages(exclude=['tests']),
provides=['cmsplugin_gallery', ],
include_package_data=True,
install_requires = ['django-cms>=3.2.0', 'django-inline-ordering>=0.1.1',
install_requires = ['django-cms>=3.9.0', 'django-inline-ordering==1.0.2',