Fix nmap to work with our non-standard DLT_PPP_* values.

Patches mostly by Itojun.
This commit is contained in:
hubertf 2000-10-08 15:06:08 +00:00
parent 92756e88e1
commit 0d864eeaf6
5 changed files with 44 additions and 17 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2000/05/14 22:05:55 frueauf Exp $
# $NetBSD: Makefile,v 1.12 2000/10/08 15:06:08 hubertf Exp $
#
DISTNAME= nmap-2.53
@ -11,6 +11,7 @@ HOMEPAGE= http://www.insecure.org/nmap/index.html
GNU_CONFIGURE= YES
CONFIGURE_ENV+= INSTALL=${INSTALL}
CONFIGURE_ARGS+=--with-libpcap
.include "../../mk/bsd.prefs.mk"

View file

@ -1,4 +1,7 @@
$NetBSD: patch-sum,v 1.5 2000/05/10 12:04:25 hubertf Exp $
$NetBSD: patch-sum,v 1.6 2000/10/08 15:06:09 hubertf Exp $
MD5 (patch-aa) = 4d4bb581c9009c51b6101361f4c8c0e7
MD5 (patch-aa) = 7f00255950ea6661106dc599215ada60
MD5 (patch-aa.rej) = d71204582eff187cd2fb882323ce202d
MD5 (patch-ab) = bb9ea9c7ed515429b5bde12f9823459c
MD5 (patch-ac) = b9b4ce87bef4abc93052541ef95ff307
MD5 (patch-ad) = e5d448cfb6e96e708e8ea59ea1581eae

View file

@ -1,22 +1,21 @@
$NetBSD: patch-aa,v 1.4 2000/05/10 12:04:25 hubertf Exp $
--- Makefile.in.orig Sat May 6 12:33:36 2000
+++ Makefile.in Sat May 6 12:34:09 2000
@@ -36,7 +36,7 @@
DEPS = nmap.h error.h targets.h osscan.h tcpip.h utils.h global_structures.h charpool.h services.h rpc.h portlist.h
$NetBSD: patch-aa,v 1.5 2000/10/08 15:06:09 hubertf Exp $
--- Makefile.in.orig Tue May 9 15:25:42 2000
+++ Makefile.in Sun Oct 8 23:18:41 2000
@@ -14,4 +14,5 @@
CCOPT =
-LIBPCAPDIR = @libpcapdir@
-INCLS = -I. -I$(LIBPCAPDIR)
+#LIBPCAPDIR = @libpcapdir@
+INCLS = -I.
+#INCLS += -I$(LIBPCAPDIR)
DEFS = @DEFS@ -DNMAP_VERSION=\"$(NMAP_VERSION)\" -DNMAP_NAME=\"$(NMAP_NAME)\" -DNMAP_URL=\"$(NMAP_URL)\" -DNMAPDATADIR=\"$(nmapdatadir)\"
@@ -38,3 +39,3 @@
-all: $(TARGET) nmapfe/nmapfe
+all: $(TARGET)
$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS)
@echo Compiling nmap
@@ -141,7 +141,7 @@
$(MAKEDEPEND) $(INCLS) -s "# DO NOT DELETE" -- $(DEFS) -- $(SRCS)
@@ -142,3 +143,3 @@
install: $(TARGET)
- $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir) $(deskdir)
+ $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir)
$(INSTALL) -c -m 755 nmap $(bindir)/nmap
@echo "If the next command fails -- you cannot use the X front end"
-test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 nmapfe/nmapfe $(bindir)/nmapfe && $(SHTOOL) mkln -f -s $(bindir)/nmapfe $(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(deskdir)/nmapfe.desktop && $(INSTALL) -c -m 644 docs/nmapfe.1 $(mandir)/man1/nmapfe.1 && $(INSTALL) -c -m 644 docs/xnmap.1 $(mandir)/man1/xnmap.1

View file

@ -0,0 +1,7 @@
$NetBSD: patch-ac,v 1.1 2000/10/08 15:06:09 hubertf Exp $
--- configure- Sun Oct 8 23:15:09 2000
+++ configure Sun Oct 8 23:15:35 2000
@@ -1509,2 +1509,3 @@
int major, minor;
+ exit(0); /*fool it*/
sscanf(pcap_version,"%d.%d", &major, &minor);

17
net/nmap/patches/patch-ad Normal file
View file

@ -0,0 +1,17 @@
$NetBSD: patch-ad,v 1.1 2000/10/08 15:06:09 hubertf Exp $
--- tcpip.c.orig Sun Apr 30 02:12:24 2000
+++ tcpip.c
@@ -995,6 +995,12 @@
#ifdef DLT_PPP_BSDOS
case DLT_PPP_BSDOS:
#endif
+#ifdef DLT_PPP_SERIAL
+ case DLT_PPP_SERIAL:
+#endif
+#ifdef DLT_PPP_ETHER
+ case DLT_PPP_ETHER:
+#endif
#if (FREEBSD || OPENBSD || NETBSD || BSDI)
offset = 4;
#else