py-FormEncode: updated to 2.1.0

2.1.0
- Add support for Python 3.7 to 3.12, end support for older Python versions
- Context.set() now works as a context manager
- Fix binary of swedish translation
- Some internal code cleanup and modernization
This commit is contained in:
adam 2024-02-02 13:13:09 +00:00
parent cc7ad4d17b
commit 0d8ee41b2a
4 changed files with 17 additions and 152 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.9 2023/06/06 12:42:49 riastradh Exp $
# $NetBSD: Makefile,v 1.10 2024/02/02 13:13:09 adam Exp $
DISTNAME= FormEncode-2.0.1
DISTNAME= FormEncode-2.1.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_PYPI:=F/FormEncode/}
@ -11,21 +10,15 @@ HOMEPAGE= http://formencode.org/
COMMENT= HTML form validation, generation, and conversion package
LICENSE= python-software-foundation
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm>=7.0.0:../../devel/py-setuptools_scm
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
TEST_DEPENDS+= ${PYPKGPREFIX}-country-[0-9]*:../../geography/py-country
TEST_DEPENDS+= ${PYPKGPREFIX}-dns-[0-9]*:../../net/py-dns
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
TEST_DEPENDS+= ${PYPKGPREFIX}-dns>=2:../../net/py-dns
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27 # py-country
PYTHON_VERSIONS_INCOMPATIBLE= 27
PLIST_SUBST+= PYPKGPREFIX=${PYPKGPREFIX}
INSTALLATION_DIRS+= share/doc/${PYPKGPREFIX}-FormEncode
post-install:
${MV} ${DESTDIR}${PREFIX}/LICENSE.txt ${DESTDIR}${PREFIX}/share/doc/${PYPKGPREFIX}-FormEncode
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,24 +1,9 @@
@comment $NetBSD: PLIST,v 1.2 2021/12/06 14:41:21 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/docs/Design.txt
${PYSITELIB}/docs/ToDo.txt
${PYSITELIB}/docs/Validator.txt
${PYSITELIB}/docs/community.txt
${PYSITELIB}/docs/download.txt
${PYSITELIB}/docs/history.txt
${PYSITELIB}/docs/htmlfill.txt
${PYSITELIB}/docs/i18n.txt
${PYSITELIB}/docs/index.txt
${PYSITELIB}/docs/modules.txt
${PYSITELIB}/docs/whatsnew-0-to-1.2.4.txt
${PYSITELIB}/docs/whatsnew-1.2.5.txt
${PYSITELIB}/docs/whatsnew-1.3.txt
${PYSITELIB}/docs/whatsnew-2.0.txt
@comment $NetBSD: PLIST,v 1.3 2024/02/02 13:13:09 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE.txt
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/formencode/__init__.py
${PYSITELIB}/formencode/__init__.pyc
${PYSITELIB}/formencode/__init__.pyo
@ -58,61 +43,33 @@ ${PYSITELIB}/formencode/htmlgen.pyo
${PYSITELIB}/formencode/htmlrename.py
${PYSITELIB}/formencode/htmlrename.pyc
${PYSITELIB}/formencode/htmlrename.pyo
${PYSITELIB}/formencode/i18n/FormEncode.pot
${PYSITELIB}/formencode/i18n/cs/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/cs/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/da/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/da/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/de/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/de/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/el/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/el/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/es/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/es/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/et/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/et/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/fi/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/fi/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/fr/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/fr/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/it/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/it/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/ja/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/ja/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/ko/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/ko/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/lt/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/lt/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/mk/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/mk/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/nb_NO/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/nb_NO/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/nl/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/nl/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/pl/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/pl/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/pt_BR/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/pt_BR/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/pt_PT/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/pt_PT/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/ru/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/ru/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/sk/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/sk/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/sl/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/sl/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/sr/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/sr/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/sr@latin/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/sr@latin/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/sv/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/sv/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/tr/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/tr/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/zh_CN/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/zh_CN/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/i18n/zh_TW/LC_MESSAGES/FormEncode.mo
${PYSITELIB}/formencode/i18n/zh_TW/LC_MESSAGES/FormEncode.po
${PYSITELIB}/formencode/interfaces.py
${PYSITELIB}/formencode/interfaces.pyc
${PYSITELIB}/formencode/interfaces.pyo
@ -126,72 +83,9 @@ ${PYSITELIB}/formencode/rewritingparser.pyo
${PYSITELIB}/formencode/schema.py
${PYSITELIB}/formencode/schema.pyc
${PYSITELIB}/formencode/schema.pyo
${PYSITELIB}/formencode/tests/__init__.py
${PYSITELIB}/formencode/tests/__init__.pyc
${PYSITELIB}/formencode/tests/__init__.pyo
${PYSITELIB}/formencode/tests/htmlfill_data/data-error1.txt
${PYSITELIB}/formencode/tests/htmlfill_data/data-fill1.txt
${PYSITELIB}/formencode/tests/htmlfill_data/data-fill2.txt
${PYSITELIB}/formencode/tests/htmlfill_data/data-fill3.txt
${PYSITELIB}/formencode/tests/htmlfill_data/data-fill4.txt
${PYSITELIB}/formencode/tests/htmlfill_data/data-form-last-element.txt
${PYSITELIB}/formencode/tests/htmlfill_data/data-schema1.txt
${PYSITELIB}/formencode/tests/non_empty.txt
${PYSITELIB}/formencode/tests/test_cc.py
${PYSITELIB}/formencode/tests/test_cc.pyc
${PYSITELIB}/formencode/tests/test_cc.pyo
${PYSITELIB}/formencode/tests/test_compound.py
${PYSITELIB}/formencode/tests/test_compound.pyc
${PYSITELIB}/formencode/tests/test_compound.pyo
${PYSITELIB}/formencode/tests/test_context.py
${PYSITELIB}/formencode/tests/test_context.pyc
${PYSITELIB}/formencode/tests/test_context.pyo
${PYSITELIB}/formencode/tests/test_declarative.py
${PYSITELIB}/formencode/tests/test_declarative.pyc
${PYSITELIB}/formencode/tests/test_declarative.pyo
${PYSITELIB}/formencode/tests/test_doctest_xml_compare.py
${PYSITELIB}/formencode/tests/test_doctest_xml_compare.pyc
${PYSITELIB}/formencode/tests/test_doctest_xml_compare.pyo
${PYSITELIB}/formencode/tests/test_doctests.py
${PYSITELIB}/formencode/tests/test_doctests.pyc
${PYSITELIB}/formencode/tests/test_doctests.pyo
${PYSITELIB}/formencode/tests/test_email.py
${PYSITELIB}/formencode/tests/test_email.pyc
${PYSITELIB}/formencode/tests/test_email.pyo
${PYSITELIB}/formencode/tests/test_htmlfill.py
${PYSITELIB}/formencode/tests/test_htmlfill.pyc
${PYSITELIB}/formencode/tests/test_htmlfill.pyo
${PYSITELIB}/formencode/tests/test_htmlfill_control.py
${PYSITELIB}/formencode/tests/test_htmlfill_control.pyc
${PYSITELIB}/formencode/tests/test_htmlfill_control.pyo
${PYSITELIB}/formencode/tests/test_htmlgen.py
${PYSITELIB}/formencode/tests/test_htmlgen.pyc
${PYSITELIB}/formencode/tests/test_htmlgen.pyo
${PYSITELIB}/formencode/tests/test_htmlrename.py
${PYSITELIB}/formencode/tests/test_htmlrename.pyc
${PYSITELIB}/formencode/tests/test_htmlrename.pyo
${PYSITELIB}/formencode/tests/test_i18n.py
${PYSITELIB}/formencode/tests/test_i18n.pyc
${PYSITELIB}/formencode/tests/test_i18n.pyo
${PYSITELIB}/formencode/tests/test_schema.py
${PYSITELIB}/formencode/tests/test_schema.pyc
${PYSITELIB}/formencode/tests/test_schema.pyo
${PYSITELIB}/formencode/tests/test_subclassing.py
${PYSITELIB}/formencode/tests/test_subclassing.pyc
${PYSITELIB}/formencode/tests/test_subclassing.pyo
${PYSITELIB}/formencode/tests/test_subclassing_old.py
${PYSITELIB}/formencode/tests/test_subclassing_old.pyc
${PYSITELIB}/formencode/tests/test_subclassing_old.pyo
${PYSITELIB}/formencode/tests/test_validators.py
${PYSITELIB}/formencode/tests/test_validators.pyc
${PYSITELIB}/formencode/tests/test_validators.pyo
${PYSITELIB}/formencode/tests/test_variabledecode.py
${PYSITELIB}/formencode/tests/test_variabledecode.pyc
${PYSITELIB}/formencode/tests/test_variabledecode.pyo
${PYSITELIB}/formencode/validators.py
${PYSITELIB}/formencode/validators.pyc
${PYSITELIB}/formencode/validators.pyo
${PYSITELIB}/formencode/variabledecode.py
${PYSITELIB}/formencode/variabledecode.pyc
${PYSITELIB}/formencode/variabledecode.pyo
share/doc/${PYPKGPREFIX}-FormEncode/LICENSE.txt

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.7 2022/10/25 08:30:14 adam Exp $
$NetBSD: distinfo,v 1.8 2024/02/02 13:13:09 adam Exp $
BLAKE2s (FormEncode-2.0.1.tar.gz) = 13225ffbde085fb4d0920c6d91e678c11546594c335f14dc87e9333303ba30ae
SHA512 (FormEncode-2.0.1.tar.gz) = 165d2b5abfd37a361144aaf33b053537660bef5ba6a266b869beb2e1d5467719fd7a9dc6d2cec75a04f0ee0d07d46cc76d90ad6ead5b4adef570e22d566fa87b
Size (FormEncode-2.0.1.tar.gz) = 256130 bytes
SHA1 (patch-setup.py) = 819b29ba5977b0d69fca8fcb381f60f4d8541890
BLAKE2s (FormEncode-2.1.0.tar.gz) = 7e92c7099ae479c2f8deedd7ed143d1f60ba5976e3e8565e0aecd4bba8bf5cea
SHA512 (FormEncode-2.1.0.tar.gz) = 136253faaa299a6c5c92f70e11d53f410e1d7607b1c6530bd25042e8506e644409fcb0ff8ccd5fe7ed04707d4034fec224389681c8e4ff81af445b4dc67897a6
Size (FormEncode-2.1.0.tar.gz) = 277757 bytes

View File

@ -1,21 +0,0 @@
$NetBSD: patch-setup.py,v 1.3 2022/10/25 08:30:14 adam Exp $
Remove hardcoded version limits.
Remove setuptools_scm_git_archive from requirements.
--- setup.py.orig 2021-10-05 12:14:00.000000000 +0000
+++ setup.py
@@ -16,12 +16,11 @@ if not (2,7) <= sys.version_info[:2] < (
tests_require = [
'pytest<4.7' if sys.version_info[:2] < (3,0) else 'pytest',
- 'dnspython==1.16.0' if sys.version_info[:2] < (3,0) else 'dnspython>=2.0.0',
+ 'dnspython',
'pycountry<19' if sys.version_info < (3,0) else 'pycountry']
setup_requires = [
'setuptools_scm<6.0' if sys.version_info[:2] < (3,0) else 'setuptools_scm',
- 'setuptools_scm_git_archive',
]
doctests = ['docs/htmlfill.txt', 'docs/Validator.txt',