Fix trivial build error with clang to make room for the more interesting

problems.
This commit is contained in:
joerg 2012-04-22 20:32:18 +00:00
parent 5023a79e4f
commit 0d92b75fc2
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.15 2011/01/25 22:22:15 shattered Exp $
$NetBSD: distinfo,v 1.16 2012/04/22 20:32:18 joerg Exp $
SHA1 (jade-1.2.1.tar.gz) = 4326e73b7f0b865515e1bb90c622a8b2aa6ecd06
RMD160 (jade-1.2.1.tar.gz) = 615ebcc1b17a284d60a7976f13649a0ea78aa58d
@ -27,3 +27,4 @@ SHA1 (patch-ar) = 3c7676797519b35c654513885c5ca799e55a6baf
SHA1 (patch-as) = 8dc4d8867ea38b09f0cfadde840d8695ca1e110c
SHA1 (patch-at) = 6b4aaee9de24eb5f648a10362fa57f92439cd00f
SHA1 (patch-au) = f1cf55a99836b2bcbc31d4b1e12b31a1b5a28682
SHA1 (patch-lib_assert.cxx) = 72a220e15516f83903c7cea344dd9be527fd2c4d

View file

@ -0,0 +1,15 @@
$NetBSD: patch-lib_assert.cxx,v 1.1 2012/04/22 20:32:19 joerg Exp $
--- lib/assert.cxx.orig 2012-04-20 13:14:25.000000000 +0000
+++ lib/assert.cxx
@@ -5,10 +5,6 @@
#include <stdlib.h>
#include "macros.h"
-#ifdef __GNUG__
-void exit (int __status) throw () __attribute__ ((__noreturn__));
-#endif
-
#ifdef SP_NAMESPACE
namespace SP_NAMESPACE {
#endif