remove a part of the previous patch because the underlying problem

was already fixed in the xine release
(too bad that xine and mplayer are going to diverge here)
This commit is contained in:
drochner 2007-01-10 17:18:37 +00:00
parent adb38ada4e
commit 0da4010705
4 changed files with 13 additions and 51 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.41 2007/01/09 14:46:31 drochner Exp $
$NetBSD: distinfo,v 1.42 2007/01/10 17:18:37 drochner Exp $
SHA1 (xine-lib-1.1.3.tar.gz) = c0886910ddb1afa1a72572decf12c0251bba40bf
RMD160 (xine-lib-1.1.3.tar.gz) = 8e28638385ea48e7d4d4d702573ca92c4eca77c8
@ -31,6 +31,4 @@ SHA1 (patch-dc) = 11c4212029e67f22796e57706b42400a0dbcac3a
SHA1 (patch-ea) = c691eed110cfbd60e0b6349d612d765ae6560e92
SHA1 (patch-eb) = b65e2c7c30fc04115d55da1ce1f6f65216ac1d23
SHA1 (patch-ec) = edd039d574260dc96f78e0fc7e4324f3a74cc993
SHA1 (patch-ed) = b3b0dcd186d547659c01305a64850ec0bf9cbfe2
SHA1 (patch-ee) = ebefa4cf769b7175ce090fad42e387e66f0ecb59
SHA1 (patch-ef) = 885bf9df3e73946f0fd4605be2937a4e9740229f
SHA1 (patch-ed) = 2a33b25b58ff3746df3b8a55f24a78351b82055e

View file

@ -1,25 +1,15 @@
$NetBSD: patch-ed,v 1.1 2007/01/09 14:46:31 drochner Exp $
$NetBSD: patch-ed,v 1.2 2007/01/10 17:18:37 drochner Exp $
--- src/input/libreal/asmrp.c.orig 2006-11-29 20:43:01.000000000 +0100
+++ src/input/libreal/asmrp.c
@@ -37,6 +37,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
+#include "asmrp.h"
@@ -418,8 +418,8 @@ static int asmrp_operand (asmrp_t *p) {
i = asmrp_find_id (p, p->str);
if (i<0) {
lprintf ("error: unknown identifier %s\n", p->str);
- }
- ret = p->sym_tab[i].v;
+ } else
+ ret = p->sym_tab[i].v;
#define LOG_MODULE "asmrp"
#define LOG_VERBOSE
@@ -618,8 +619,10 @@ static int asmrp_eval (asmrp_t *p, int *
if (asmrp_rule (p)) {
lprintf ("rule #%d is true\n", rule_num);
- matches[num_matches] = rule_num;
- num_matches++;
+ if(num_matches < MAX_RULEMATCHES - 1)
+ matches[num_matches++] = rule_num;
+ else
+ printf("Ignoring matched asm rule %d, too many matched rules.\n", rule_num);
}
rule_num++;
asmrp_get_sym (p);
break;

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ee,v 1.1 2007/01/09 14:46:31 drochner Exp $
--- src/input/libreal/real.c.orig 2006-11-29 20:43:01.000000000 +0100
+++ src/input/libreal/real.c
@@ -472,7 +472,7 @@ rmff_header_t *real_parse_sdp(char *data
int j=0;
int n;
char b[64];
- int rulematches[16];
+ int rulematches[MAX_RULEMATCHES];
lprintf("calling asmrp_match with:\n%s\n%u\n", desc->stream[i]->asm_rule_book, bandwidth);

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ef,v 1.1 2007/01/09 14:46:31 drochner Exp $
--- src/input/libreal/asmrp.h.orig 2006-11-29 20:43:01.000000000 +0100
+++ src/input/libreal/asmrp.h
@@ -37,6 +37,8 @@
#ifndef HAVE_ASMRP_H
#define HAVE_ASMRP_H
+#define MAX_RULEMATCHES 16
+
int asmrp_match (const char *rules, int bandwidth, int *matches, int matchesizxe) ;
#endif