Update to version 0.28. Changes include:

- simple nameserver
- support for TSIG and DNAME resource records
- dynamic updates
- should be compatible with perl 5.005_3
This commit is contained in:
heinz 2002-09-09 00:22:22 +00:00
parent 45bacf7314
commit 0dbb0b8058
5 changed files with 72 additions and 14 deletions

View file

@ -1,11 +1,14 @@
Net::DNS is a Perl interface to the DNS resolver. It allows the
programmer to perform any type of DNS query from a Perl script.
For details and examples, please read the Net::DNS manual page.
For details and examples, please read the Net::DNS documentation page
('perldoc Net::DNS')
As of version 0.02, Net::DNS is written entirely in Perl. Version
0.01 was written mostly in C and used the system's resolver. The
Perl version runs quite a bit slower, but considering that the
network can be a serious bottleneck when making DNS queries, the
speed difference may not really matter in most cases. However,
future versions may contain some C to increase speed or for those
who wish to link against libresolv or libbind.
Features include a simple nameserver (Net::DNS::Nameserver), dynamic
DNS updates, signed queries (TSIG), support for DNAME resource records.
The author invites feedback on Net::DNS, especially on new features
like dynamic updates und TSIG. If there's something you'd like to
have added, please let him know (http://www.net-dns.org/).
Future versions may contain some C to increase speed or for those who
wish to link against libresolv or libbind.

View file

@ -1,20 +1,32 @@
# $NetBSD: Makefile,v 1.5 2001/11/26 06:50:10 jlam Exp $
# $NetBSD: Makefile,v 1.6 2002/09/09 00:22:22 heinz Exp $
#
DISTNAME= Net-DNS-0.12
DISTNAME= Net-DNS-0.28
PKGNAME= p5-${DISTNAME}
SVR4_PKGNAME= p5ndn
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Net/}
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Net/} \
http://www.net-dns.org/download/
MAINTAINER= hubertf@netbsd.org
HOMEPAGE= http://www.net-dns.org/
COMMENT= Net::DNS - Perl DNS Resolver Module
BUILD_DEPENDS+= p5-Test-Simple>=0.44:../../devel/p5-Test-Simple
DEPENDS+= p5-Digest-HMAC>=1.0:../../security/p5-Digest-HMAC
DEPENDS+= p5-MIME-Base64>=2.11:../../converters/p5-MIME-Base64
BUILDLINK_DEPENDS.perl= perl>=5.005_03
USE_BUILDLINK_ONLY= YES
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Net/DNS/.packlist
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
test: build
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKEFLAGS} test
.include "../../lang/perl5/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,6 @@
$NetBSD: distinfo,v 1.2 2001/04/21 11:23:26 wiz Exp $
$NetBSD: distinfo,v 1.3 2002/09/09 00:22:22 heinz Exp $
SHA1 (Net-DNS-0.12.tar.gz) = eb52cf1be39d013473a0e73ee1fab637c5329e3d
Size (Net-DNS-0.12.tar.gz) = 58374 bytes
SHA1 (Net-DNS-0.28.tar.gz) = a0705fac58f7d6a97bc8418b2dd281bbeba4b7af
Size (Net-DNS-0.28.tar.gz) = 81449 bytes
SHA1 (patch-aa) = fb4bed3ed4c1c0353716529d27929444f15f6e31
SHA1 (patch-ab) = 9e8e7d1e826bcc605a650d29d24fb4a4e380f074

View file

@ -0,0 +1,24 @@
$NetBSD: patch-aa,v 1.1 2002/09/09 00:24:12 heinz Exp $
--- Makefile.PL.orig Sat Aug 10 06:06:27 2002
+++ Makefile.PL
@@ -24,17 +24,13 @@
print <<EOT;
-You appear to be directly connected to the Internet. I have some tests
-that try to query live nameservers.
+You appear to be directly connected to the Internet.
+I will enable some tests that try to query live nameservers.
EOT
- if (prompt("Do you want to enable these tests?", "y") =~ /^y/i) {
open(ENABLED, ">t/online.enabled") || die "Can't touch ./t/online.enabled $!";
close(ENABLED);
- } else {
- unlink("t/online.enabled"); # just to be shure...
- }
}

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ab,v 1.1 2002/09/09 00:24:12 heinz Exp $
--- lib/Net/DNS/Resolver.pm.orig Wed Aug 21 02:11:40 2002
+++ lib/Net/DNS/Resolver.pm
@@ -815,9 +815,10 @@
my $sel = Net::DNS::Select->new($os, $sock);
# Perform each round of retries.
- for (my $i = 0;
+ # length of nameserver array _cannot_ be 0, see the check above
+ for (my $i = 0, my $numns = scalar(@ns);
$i < $self->{'retry'};
- ++$i, $retrans *= 2, $timeout = int($retrans / ($#ns + 1))) {
+ ++$i, $retrans *= 2, $timeout = int($retrans / $numns)) {
$timeout = 1 if ($timeout < 1);