Update to latest NetBSD -current sources rather than being built from
ancient sources predating a move in the repo. Source does not maintain a CHANGELOG. It is anticipated that most changes are build related, though PR/42651 is also addressed by this.
This commit is contained in:
parent
07637485b2
commit
0dd0bc13dd
9 changed files with 22 additions and 93 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES-2010,v 1.2112 2010/06/04 16:16:39 sborrill Exp $
|
||||
$NetBSD: CHANGES-2010,v 1.2113 2010/06/04 16:24:55 sborrill Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2010:
|
||||
|
||||
|
@ -2838,3 +2838,5 @@ Changes to the packages collection and infrastructure in 2010:
|
|||
Moved devel/netbsd-iscsi-initiator to net/netbsd-iscsi-initiator [sborrill 2010-06-04]
|
||||
Moved devel/netbsd-iscsi-target to net/netbsd-iscsi-target [sborrill 2010-06-04]
|
||||
Added devel/netbsd-iscsi-lib version 20100416 [sborrill 2010-06-04]
|
||||
Updated net/netbsd-iscsi-initiator to 20100416 [sborrill 2010-06-04]
|
||||
Updated net/netbsd-iscsi-target to 20100416 [sborrill 2010-06-04]
|
||||
|
|
|
@ -1,27 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/06/04 16:07:51 sborrill Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2010/06/04 16:24:55 sborrill Exp $
|
||||
|
||||
DISTNAME= netbsd-iscsi-20080207
|
||||
PKGNAME= ${DISTNAME:C/-iscsi/-iscsi-initiator/}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_BACKUP}
|
||||
|
||||
MAINTAINER= agc@NetBSD.org
|
||||
HOMEPAGE= http://www.alistaircrooks.co.uk/software.html
|
||||
CATEGORIES= net
|
||||
COMMENT= NetBSD's iSCSI initiator (per iSCSI RFC 3720)
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_DIRS= src
|
||||
BUILD_TARGET= all-initiator
|
||||
BUILD_DIRS+= ${WRKSRC}/src/initiator
|
||||
DISTINFO_FILE= ${.CURDIR}/../../devel/netbsd-iscsi-lib/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../devel/netbsd-iscsi-lib/patches
|
||||
|
||||
AUTO_MKDIRS= yes
|
||||
.include "../../devel/netbsd-iscsi-lib/Makefile.common"
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/iscsifs ${DESTDIR}${PREFIX}/sbin/iscsifs
|
||||
${INSTALL_MAN} ${WRKSRC}/src/iscsifs.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8/iscsifs.8
|
||||
|
||||
.include "../../mk/fuse.buildlink3.mk"
|
||||
.include "../../devel/netbsd-iscsi-lib/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/06/04 16:07:51 sborrill Exp $
|
||||
man/man8/iscsifs.8
|
||||
sbin/iscsifs
|
||||
@comment $NetBSD: PLIST,v 1.2 2010/06/04 16:24:55 sborrill Exp $
|
||||
bin/iscsi-initiator
|
||||
man/man8/iscsi-initiator.8
|
||||
|
|
|
@ -1,6 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/06/04 16:07:51 sborrill Exp $
|
||||
|
||||
SHA1 (netbsd-iscsi-20080207.tar.gz) = afe6ca2fdf46ce6dfed341dfd05aeb597584ae0f
|
||||
RMD160 (netbsd-iscsi-20080207.tar.gz) = 62417a6c7bebf95257054f96990a7009f515c064
|
||||
Size (netbsd-iscsi-20080207.tar.gz) = 249607 bytes
|
||||
SHA1 (patch-aa) = c97a1b97456cf2d11415ab22175c564baa9aae14
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/06/04 16:07:51 sborrill Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2006-06-03 00:39:22.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -16,9 +16,9 @@
|
||||
SYSCONFDIR=@sysconfdir@
|
||||
|
||||
CC= @CC@
|
||||
-PTHREAD_FLAGS= -pthread
|
||||
-PTHREAD_LDFLAGS= -pthread
|
||||
-PTHREAD_LIBS= -lpthread
|
||||
+PTHREAD_FLAGS?= -pthread
|
||||
+PTHREAD_LDFLAGS?= -pthread
|
||||
+PTHREAD_LIBS?= -lpthread
|
||||
GCC_CFLAGS= -Wall -Wstrict-prototypes -fno-strict-aliasing -fno-common -Wno-trigraphs
|
||||
COMMON_CFLAGS += -DCONFIG_ISCSI_DEBUG -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
|
||||
COMMON_CFLAGS += -DHAVE_CONFIG_H
|
|
@ -1,29 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/06/04 16:07:27 sborrill Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2010/06/04 16:24:56 sborrill Exp $
|
||||
|
||||
DISTNAME= netbsd-iscsi-20080207
|
||||
PKGNAME= ${DISTNAME:C/-iscsi/-iscsi-target/}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_BACKUP}
|
||||
|
||||
MAINTAINER= agc@NetBSD.org
|
||||
HOMEPAGE= http://www.alistaircrooks.co.uk/software.html
|
||||
CATEGORIES= net
|
||||
COMMENT= NetBSD's iSCSI target (per iSCSI RFC 3720)
|
||||
|
||||
CONFLICTS+= netbsd-iscsi>0
|
||||
BUILD_DIRS+= ${WRKSRC}/src/target
|
||||
DISTINFO_FILE= ${.CURDIR}/../../devel/netbsd-iscsi-lib/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../devel/netbsd-iscsi-lib/patches
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_DIRS= src
|
||||
|
||||
AUTO_MKDIRS= yes
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/iscsi-target ${DESTDIR}${PREFIX}/sbin/iscsi-target
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/FAQ ${DESTDIR}${PREFIX}/share/doc/iscsi/FAQ
|
||||
${INSTALL_MAN} ${WRKSRC}/src/iscsi-target.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8/iscsi-target.8
|
||||
${INSTALL_MAN} ${WRKSRC}/src/targets.5 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man5/targets.5
|
||||
.include "../../devel/netbsd-iscsi-lib/Makefile.common"
|
||||
|
||||
.include "../../devel/netbsd-iscsi-lib/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/06/04 16:07:27 sborrill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2010/06/04 16:24:56 sborrill Exp $
|
||||
bin/iscsi-target
|
||||
man/man5/targets.5
|
||||
man/man8/iscsi-target.8
|
||||
sbin/iscsi-target
|
||||
share/doc/iscsi/FAQ
|
||||
|
|
|
@ -1,6 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/06/04 16:07:27 sborrill Exp $
|
||||
|
||||
SHA1 (netbsd-iscsi-20080207.tar.gz) = afe6ca2fdf46ce6dfed341dfd05aeb597584ae0f
|
||||
RMD160 (netbsd-iscsi-20080207.tar.gz) = 62417a6c7bebf95257054f96990a7009f515c064
|
||||
Size (netbsd-iscsi-20080207.tar.gz) = 249607 bytes
|
||||
SHA1 (patch-aa) = c97a1b97456cf2d11415ab22175c564baa9aae14
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/06/04 16:07:27 sborrill Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2006-06-03 00:39:22.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -16,9 +16,9 @@
|
||||
SYSCONFDIR=@sysconfdir@
|
||||
|
||||
CC= @CC@
|
||||
-PTHREAD_FLAGS= -pthread
|
||||
-PTHREAD_LDFLAGS= -pthread
|
||||
-PTHREAD_LIBS= -lpthread
|
||||
+PTHREAD_FLAGS?= -pthread
|
||||
+PTHREAD_LDFLAGS?= -pthread
|
||||
+PTHREAD_LIBS?= -lpthread
|
||||
GCC_CFLAGS= -Wall -Wstrict-prototypes -fno-strict-aliasing -fno-common -Wno-trigraphs
|
||||
COMMON_CFLAGS += -DCONFIG_ISCSI_DEBUG -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
|
||||
COMMON_CFLAGS += -DHAVE_CONFIG_H
|
Loading…
Reference in a new issue