Upgrade devel/py-ZopeInterface to zope.interface-3.3.0.
Use eggs instead of distutils. Remove patch-aa as it no longer applies. Add licenses/zpl and add zpl to mk/license.mk:DEFAULT_ACCEPTABLE_LICENSES. Patch posted to pkgsrc-users@ and okayed by agc@.
This commit is contained in:
parent
da53ce7cc8
commit
0df3bca6ba
6 changed files with 139 additions and 254 deletions
|
@ -1,23 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.7 2008/06/12 02:14:28 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2009/07/15 06:12:44 ver Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ZopeInterface-3.0.1
|
||||
PKGNAME= ${PYPKGPREFIX}-ZopeInterface-3.0.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= zope.interface-3.3.0
|
||||
PKGNAME= ${PYPKGPREFIX}-ZopeInterface-3.3.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= http://zope.org/Products/ZopeInterface/3.0.1final/
|
||||
EXTRACT_SUFX= .tgz
|
||||
MASTER_SITES= http://www.zope.org/Products/ZopeInterface/3.3.0/
|
||||
|
||||
MAINTAINER= sifu@0xx0.net
|
||||
HOMEPAGE= http://www.zope.org/
|
||||
COMMENT= The zope.interface package used in Zope 3 and Twisted
|
||||
LICENSE= zpl
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
PYDISTUTILSPKG= yes
|
||||
|
||||
pre-build:
|
||||
${RM} ${WRKSRC}/Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/*.orig
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,137 +1,90 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 17:49:04 joerg Exp $
|
||||
${PYSITELIB}/zope/PUBLICATION.cfg
|
||||
${PYSITELIB}/zope/README.txt
|
||||
${PYSITELIB}/zope/__init__.py
|
||||
${PYSITELIB}/zope/__init__.pyc
|
||||
${PYSITELIB}/zope/__init__.pyo
|
||||
@comment $NetBSD: PLIST,v 1.3 2009/07/15 06:12:44 ver Exp $
|
||||
${PYSITELIB}/zope/interface/__init__.py
|
||||
${PYSITELIB}/zope/interface/_flatten.py
|
||||
${PYSITELIB}/zope/interface/adapter.py
|
||||
${PYSITELIB}/zope/interface/advice.py
|
||||
${PYSITELIB}/zope/interface/declarations.py
|
||||
${PYSITELIB}/zope/interface/document.py
|
||||
${PYSITELIB}/zope/interface/exceptions.py
|
||||
${PYSITELIB}/zope/interface/interface.py
|
||||
${PYSITELIB}/zope/interface/interfaces.py
|
||||
${PYSITELIB}/zope/interface/ro.py
|
||||
${PYSITELIB}/zope/interface/verify.py
|
||||
${PYSITELIB}/zope/interface/DEPENDENCIES.cfg
|
||||
${PYSITELIB}/zope/interface/PUBLICATION.cfg
|
||||
${PYSITELIB}/zope/interface/README.ru.txt
|
||||
${PYSITELIB}/zope/interface/README.txt
|
||||
${PYSITELIB}/zope/interface/SETUP.cfg
|
||||
${PYSITELIB}/zope/interface/_zope_interface_coptimizations.c
|
||||
${PYSITELIB}/zope/interface/adapter.txt
|
||||
${PYSITELIB}/zope/interface/human.ru.txt
|
||||
${PYSITELIB}/zope/interface/human.txt
|
||||
${PYSITELIB}/zope/interface/__init__.py
|
||||
${PYSITELIB}/zope/interface/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/__init__.pyo
|
||||
${PYSITELIB}/zope/interface/_flatten.py
|
||||
${PYSITELIB}/zope/interface/_flatten.pyc
|
||||
${PYSITELIB}/zope/interface/_flatten.pyo
|
||||
${PYSITELIB}/zope/interface/_zope_interface_coptimizations.so
|
||||
${PYSITELIB}/zope/interface/adapter.py
|
||||
${PYSITELIB}/zope/interface/adapter.pyc
|
||||
${PYSITELIB}/zope/interface/adapter.pyo
|
||||
${PYSITELIB}/zope/interface/advice.py
|
||||
${PYSITELIB}/zope/interface/advice.pyc
|
||||
${PYSITELIB}/zope/interface/advice.pyo
|
||||
${PYSITELIB}/zope/interface/common/__init__.py
|
||||
${PYSITELIB}/zope/interface/common/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/common/__init__.pyo
|
||||
${PYSITELIB}/zope/interface/common/idatetime.py
|
||||
${PYSITELIB}/zope/interface/common/idatetime.pyc
|
||||
${PYSITELIB}/zope/interface/common/idatetime.pyo
|
||||
${PYSITELIB}/zope/interface/common/interfaces.py
|
||||
${PYSITELIB}/zope/interface/common/interfaces.pyc
|
||||
${PYSITELIB}/zope/interface/common/interfaces.pyo
|
||||
${PYSITELIB}/zope/interface/common/__init__.py
|
||||
${PYSITELIB}/zope/interface/common/idatetime.py
|
||||
${PYSITELIB}/zope/interface/common/mapping.py
|
||||
${PYSITELIB}/zope/interface/common/mapping.pyc
|
||||
${PYSITELIB}/zope/interface/common/mapping.pyo
|
||||
${PYSITELIB}/zope/interface/common/sequence.py
|
||||
${PYSITELIB}/zope/interface/common/tests/__init__.py
|
||||
${PYSITELIB}/zope/interface/common/tests/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/common/tests/__init__.pyo
|
||||
${PYSITELIB}/zope/interface/common/tests/basemapping.py
|
||||
${PYSITELIB}/zope/interface/common/tests/basemapping.pyc
|
||||
${PYSITELIB}/zope/interface/common/tests/basemapping.pyo
|
||||
${PYSITELIB}/zope/interface/common/tests/test_idatetime.py
|
||||
${PYSITELIB}/zope/interface/common/tests/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/common/tests/basemapping.pyc
|
||||
${PYSITELIB}/zope/interface/common/tests/test_idatetime.pyc
|
||||
${PYSITELIB}/zope/interface/common/tests/test_idatetime.pyo
|
||||
${PYSITELIB}/zope/interface/declarations.py
|
||||
${PYSITELIB}/zope/interface/declarations.pyc
|
||||
${PYSITELIB}/zope/interface/declarations.pyo
|
||||
${PYSITELIB}/zope/interface/document.py
|
||||
${PYSITELIB}/zope/interface/document.pyc
|
||||
${PYSITELIB}/zope/interface/document.pyo
|
||||
${PYSITELIB}/zope/interface/exceptions.py
|
||||
${PYSITELIB}/zope/interface/exceptions.pyc
|
||||
${PYSITELIB}/zope/interface/exceptions.pyo
|
||||
${PYSITELIB}/zope/interface/interface.py
|
||||
${PYSITELIB}/zope/interface/interface.pyc
|
||||
${PYSITELIB}/zope/interface/interface.pyo
|
||||
${PYSITELIB}/zope/interface/interfaces.py
|
||||
${PYSITELIB}/zope/interface/interfaces.pyc
|
||||
${PYSITELIB}/zope/interface/interfaces.pyo
|
||||
${PYSITELIB}/zope/interface/ro.py
|
||||
${PYSITELIB}/zope/interface/ro.pyc
|
||||
${PYSITELIB}/zope/interface/ro.pyo
|
||||
${PYSITELIB}/zope/interface/tests/foodforthought.txt
|
||||
${PYSITELIB}/zope/interface/common/interfaces.pyc
|
||||
${PYSITELIB}/zope/interface/common/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/common/idatetime.pyc
|
||||
${PYSITELIB}/zope/interface/common/mapping.pyc
|
||||
${PYSITELIB}/zope/interface/common/sequence.pyc
|
||||
${PYSITELIB}/zope/interface/tests/__init__.py
|
||||
${PYSITELIB}/zope/interface/tests/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/tests/__init__.pyo
|
||||
${PYSITELIB}/zope/interface/tests/dummy.py
|
||||
${PYSITELIB}/zope/interface/tests/dummy.pyc
|
||||
${PYSITELIB}/zope/interface/tests/dummy.pyo
|
||||
${PYSITELIB}/zope/interface/tests/ifoo.py
|
||||
${PYSITELIB}/zope/interface/tests/ifoo.pyc
|
||||
${PYSITELIB}/zope/interface/tests/ifoo.pyo
|
||||
${PYSITELIB}/zope/interface/tests/m1.py
|
||||
${PYSITELIB}/zope/interface/tests/m1.pyc
|
||||
${PYSITELIB}/zope/interface/tests/m1.pyo
|
||||
${PYSITELIB}/zope/interface/tests/m2.py
|
||||
${PYSITELIB}/zope/interface/tests/m2.pyc
|
||||
${PYSITELIB}/zope/interface/tests/m2.pyo
|
||||
${PYSITELIB}/zope/interface/tests/odd.py
|
||||
${PYSITELIB}/zope/interface/tests/odd.pyc
|
||||
${PYSITELIB}/zope/interface/tests/odd.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_adapter.py
|
||||
${PYSITELIB}/zope/interface/tests/test_adapter.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_adapter.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_advice.py
|
||||
${PYSITELIB}/zope/interface/tests/test_advice.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_advice.pyo
|
||||
${PYSITELIB}/zope/interface/tests/ifoo.py
|
||||
${PYSITELIB}/zope/interface/tests/m1.py
|
||||
${PYSITELIB}/zope/interface/tests/m2.py
|
||||
${PYSITELIB}/zope/interface/tests/odd.py
|
||||
${PYSITELIB}/zope/interface/tests/test_declarations.py
|
||||
${PYSITELIB}/zope/interface/tests/test_declarations.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_declarations.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_document.py
|
||||
${PYSITELIB}/zope/interface/tests/test_document.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_document.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_element.py
|
||||
${PYSITELIB}/zope/interface/tests/test_element.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_element.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_advice.py
|
||||
${PYSITELIB}/zope/interface/tests/test_interface.py
|
||||
${PYSITELIB}/zope/interface/tests/test_interface.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_interface.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_document.py
|
||||
${PYSITELIB}/zope/interface/tests/test_element.py
|
||||
${PYSITELIB}/zope/interface/tests/test_odd_declarations.py
|
||||
${PYSITELIB}/zope/interface/tests/test_odd_declarations.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_odd_declarations.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_sorting.py
|
||||
${PYSITELIB}/zope/interface/tests/test_sorting.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_sorting.pyo
|
||||
${PYSITELIB}/zope/interface/tests/test_verify.py
|
||||
${PYSITELIB}/zope/interface/tests/test_verify.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_verify.pyo
|
||||
${PYSITELIB}/zope/interface/tests/unitfixtures.py
|
||||
${PYSITELIB}/zope/interface/tests/foodforthought.txt
|
||||
${PYSITELIB}/zope/interface/tests/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/tests/dummy.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_adapter.pyc
|
||||
${PYSITELIB}/zope/interface/tests/m1.pyc
|
||||
${PYSITELIB}/zope/interface/tests/ifoo.pyc
|
||||
${PYSITELIB}/zope/interface/tests/m2.pyc
|
||||
${PYSITELIB}/zope/interface/tests/odd.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_declarations.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_advice.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_interface.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_document.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_element.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_odd_declarations.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_sorting.pyc
|
||||
${PYSITELIB}/zope/interface/tests/test_verify.pyc
|
||||
${PYSITELIB}/zope/interface/tests/unitfixtures.pyc
|
||||
${PYSITELIB}/zope/interface/tests/unitfixtures.pyo
|
||||
${PYSITELIB}/zope/interface/verify.py
|
||||
${PYSITELIB}/zope/interface/_zope_interface_coptimizations.so
|
||||
${PYSITELIB}/zope/interface/__init__.pyc
|
||||
${PYSITELIB}/zope/interface/_flatten.pyc
|
||||
${PYSITELIB}/zope/interface/adapter.pyc
|
||||
${PYSITELIB}/zope/interface/advice.pyc
|
||||
${PYSITELIB}/zope/interface/declarations.pyc
|
||||
${PYSITELIB}/zope/interface/document.pyc
|
||||
${PYSITELIB}/zope/interface/exceptions.pyc
|
||||
${PYSITELIB}/zope/interface/interface.pyc
|
||||
${PYSITELIB}/zope/interface/interfaces.pyc
|
||||
${PYSITELIB}/zope/interface/ro.pyc
|
||||
${PYSITELIB}/zope/interface/verify.pyc
|
||||
${PYSITELIB}/zope/interface/verify.pyo
|
||||
${PYSITELIB}/zope/testing/__init__.py
|
||||
${PYSITELIB}/zope/testing/__init__.pyc
|
||||
${PYSITELIB}/zope/testing/__init__.pyo
|
||||
${PYSITELIB}/zope/testing/cleanup.py
|
||||
${PYSITELIB}/zope/testing/cleanup.pyc
|
||||
${PYSITELIB}/zope/testing/cleanup.pyo
|
||||
${PYSITELIB}/zope/testing/doctest.py
|
||||
${PYSITELIB}/zope/testing/doctest.pyc
|
||||
${PYSITELIB}/zope/testing/doctest.pyo
|
||||
${PYSITELIB}/zope/testing/doctestunit.py
|
||||
${PYSITELIB}/zope/testing/doctestunit.pyc
|
||||
${PYSITELIB}/zope/testing/doctestunit.pyo
|
||||
${PYSITELIB}/zope/testing/loggingsupport.py
|
||||
${PYSITELIB}/zope/testing/loggingsupport.pyc
|
||||
${PYSITELIB}/zope/testing/loggingsupport.pyo
|
||||
${PYSITELIB}/zope/testing/loghandler.py
|
||||
${PYSITELIB}/zope/testing/loghandler.pyc
|
||||
${PYSITELIB}/zope/testing/loghandler.pyo
|
||||
${PYSITELIB}/zope/testing/tests.py
|
||||
${PYSITELIB}/zope/testing/tests.pyc
|
||||
${PYSITELIB}/zope/testing/tests.pyo
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/SOURCES.txt
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/PKG-INFO
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/namespace_packages.txt
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/dependency_links.txt
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/top_level.txt
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/not-zip-safe
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6.egg-info/requires.txt
|
||||
${PYSITELIB}/zope.interface-3.3.0-py2.6-nspkg.pth
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2006/08/26 16:42:25 kristerw Exp $
|
||||
$NetBSD: distinfo,v 1.3 2009/07/15 06:12:44 ver Exp $
|
||||
|
||||
SHA1 (ZopeInterface-3.0.1.tgz) = 3707f7129acf085d5a0b6b616893ab647cbc7c84
|
||||
RMD160 (ZopeInterface-3.0.1.tgz) = 77ae531b20e069de959807ae980a76b460e3f76c
|
||||
Size (ZopeInterface-3.0.1.tgz) = 108336 bytes
|
||||
SHA1 (patch-aa) = d81d2cb810fdd59d6c82f0e12d1234e27fba4e6a
|
||||
SHA1 (zope.interface-3.3.0.tar.gz) = 6a5cdb2c03c9dfbaec51b243a4eb8328909f7e30
|
||||
RMD160 (zope.interface-3.3.0.tar.gz) = e44ad35c94e517130cb3dd951f9a637e9407cb1c
|
||||
Size (zope.interface-3.3.0.tar.gz) = 104204 bytes
|
||||
|
|
|
@ -1,121 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/08/26 16:42:25 kristerw Exp $
|
||||
|
||||
Reorder functions to fix "static declaration follows non-static" error
|
||||
with gcc 4.
|
||||
|
||||
--- Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/_zope_interface_coptimizations.c.orig 2006-08-26 18:12:52.000000000 +0200
|
||||
+++ Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/_zope_interface_coptimizations.c 2006-08-26 18:19:11.000000000 +0200
|
||||
@@ -24,6 +24,8 @@ static PyObject *BuiltinImplementationSp
|
||||
static PyObject *str__class__, *str__providedBy__, *strisOrExtends;
|
||||
static PyObject *empty, *fallback, *str_implied, *str_cls, *str_implements;
|
||||
static PyTypeObject *Implements;
|
||||
+static PyObject *Spec_providedBy(PyObject *self, PyObject *ob);
|
||||
+static PyObject *Spec_implementedBy(PyObject *self, PyObject *cls);
|
||||
|
||||
static int imported_declarations = 0;
|
||||
|
||||
@@ -70,7 +72,6 @@ import_declarations(void)
|
||||
return 0;
|
||||
}
|
||||
|
||||
-extern PyTypeObject SpecType; /* Forward */
|
||||
|
||||
static PyObject *
|
||||
implementedByFallback(PyObject *cls)
|
||||
@@ -279,50 +280,10 @@ static char Spec_providedBy__doc__[] =
|
||||
"Test whether an interface is implemented by the specification"
|
||||
;
|
||||
|
||||
-static PyObject *
|
||||
-Spec_providedBy(PyObject *self, PyObject *ob)
|
||||
-{
|
||||
- PyObject *decl, *item;
|
||||
-
|
||||
- decl = providedBy(NULL, ob);
|
||||
- if (decl == NULL)
|
||||
- return NULL;
|
||||
-
|
||||
- if (PyObject_TypeCheck(ob, &SpecType))
|
||||
- item = Spec_extends(decl, self);
|
||||
- else
|
||||
- /* decl is probably a security proxy. We have to go the long way
|
||||
- around.
|
||||
- */
|
||||
- item = PyObject_CallMethodObjArgs(decl, strisOrExtends, self, NULL);
|
||||
-
|
||||
- Py_DECREF(decl);
|
||||
- return item;
|
||||
-}
|
||||
-
|
||||
-
|
||||
static char Spec_implementedBy__doc__[] =
|
||||
"Test whether the specification is implemented by instances of a class"
|
||||
;
|
||||
|
||||
-static PyObject *
|
||||
-Spec_implementedBy(PyObject *self, PyObject *cls)
|
||||
-{
|
||||
- PyObject *decl, *item;
|
||||
-
|
||||
- decl = implementedBy(NULL, cls);
|
||||
- if (decl == NULL)
|
||||
- return NULL;
|
||||
-
|
||||
- if (PyObject_TypeCheck(decl, &SpecType))
|
||||
- item = Spec_extends(decl, self);
|
||||
- else
|
||||
- item = PyObject_CallMethodObjArgs(decl, strisOrExtends, self, NULL);
|
||||
-
|
||||
- Py_DECREF(decl);
|
||||
- return item;
|
||||
-}
|
||||
-
|
||||
static struct PyMethodDef Spec_methods[] = {
|
||||
{"providedBy",
|
||||
(PyCFunction)Spec_providedBy, METH_O,
|
||||
@@ -370,6 +331,45 @@ static PyTypeObject SpecType = {
|
||||
};
|
||||
|
||||
static PyObject *
|
||||
+Spec_providedBy(PyObject *self, PyObject *ob)
|
||||
+{
|
||||
+ PyObject *decl, *item;
|
||||
+
|
||||
+ decl = providedBy(NULL, ob);
|
||||
+ if (decl == NULL)
|
||||
+ return NULL;
|
||||
+
|
||||
+ if (PyObject_TypeCheck(ob, &SpecType))
|
||||
+ item = Spec_extends(decl, self);
|
||||
+ else
|
||||
+ /* decl is probably a security proxy. We have to go the long way
|
||||
+ around.
|
||||
+ */
|
||||
+ item = PyObject_CallMethodObjArgs(decl, strisOrExtends, self, NULL);
|
||||
+
|
||||
+ Py_DECREF(decl);
|
||||
+ return item;
|
||||
+}
|
||||
+
|
||||
+static PyObject *
|
||||
+Spec_implementedBy(PyObject *self, PyObject *cls)
|
||||
+{
|
||||
+ PyObject *decl, *item;
|
||||
+
|
||||
+ decl = implementedBy(NULL, cls);
|
||||
+ if (decl == NULL)
|
||||
+ return NULL;
|
||||
+
|
||||
+ if (PyObject_TypeCheck(decl, &SpecType))
|
||||
+ item = Spec_extends(decl, self);
|
||||
+ else
|
||||
+ item = PyObject_CallMethodObjArgs(decl, strisOrExtends, self, NULL);
|
||||
+
|
||||
+ Py_DECREF(decl);
|
||||
+ return item;
|
||||
+}
|
||||
+
|
||||
+static PyObject *
|
||||
OSD_descr_get(PyObject *self, PyObject *inst, PyObject *cls)
|
||||
{
|
||||
PyObject *provides;
|
59
licenses/zpl
Normal file
59
licenses/zpl
Normal file
|
@ -0,0 +1,59 @@
|
|||
Zope Public License (ZPL) Version 2.0
|
||||
-----------------------------------------------
|
||||
|
||||
This software is Copyright (c) Zope Corporation (tm) and
|
||||
Contributors. All rights reserved.
|
||||
|
||||
This license has been certified as open source. It has also
|
||||
been designated as GPL compatible by the Free Software
|
||||
Foundation (FSF).
|
||||
|
||||
Redistribution and use in source and binary forms, with or
|
||||
without modification, are permitted provided that the
|
||||
following conditions are met:
|
||||
|
||||
1. Redistributions in source code must retain the above
|
||||
copyright notice, this list of conditions, and the following
|
||||
disclaimer.
|
||||
|
||||
2. Redistributions in binary form must reproduce the above
|
||||
copyright notice, this list of conditions, and the following
|
||||
disclaimer in the documentation and/or other materials
|
||||
provided with the distribution.
|
||||
|
||||
3. The name Zope Corporation (tm) must not be used to
|
||||
endorse or promote products derived from this software
|
||||
without prior written permission from Zope Corporation.
|
||||
|
||||
4. The right to distribute this software or to use it for
|
||||
any purpose does not give you the right to use Servicemarks
|
||||
(sm) or Trademarks (tm) of Zope Corporation. Use of them is
|
||||
covered in a separate agreement (see
|
||||
http://www.zope.com/Marks).
|
||||
|
||||
5. If any files are modified, you must cause the modified
|
||||
files to carry prominent notices stating that you changed
|
||||
the files and the date of any change.
|
||||
|
||||
Disclaimer
|
||||
|
||||
THIS SOFTWARE IS PROVIDED BY ZOPE CORPORATION ``AS IS''
|
||||
AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT
|
||||
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
|
||||
AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
|
||||
NO EVENT SHALL ZOPE CORPORATION OR ITS CONTRIBUTORS BE
|
||||
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
|
||||
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
|
||||
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
|
||||
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
|
||||
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
|
||||
DAMAGE.
|
||||
|
||||
|
||||
This software consists of contributions made by Zope
|
||||
Corporation and many individuals on behalf of Zope
|
||||
Corporation. Specific attributions are listed in the
|
||||
accompanying credits file.
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: license.mk,v 1.26 2009/07/10 16:24:56 tron Exp $
|
||||
# $NetBSD: license.mk,v 1.27 2009/07/15 06:12:45 ver Exp $
|
||||
#
|
||||
# This file handles everything about the LICENSE variable. It is
|
||||
# included automatically by bsd.pkg.mk.
|
||||
|
@ -103,7 +103,8 @@ DEFAULT_ACCEPTABLE_LICENSES= \
|
|||
cddl-1.0 \
|
||||
cpl-1.0 \
|
||||
open-font-license \
|
||||
mpl-1.1
|
||||
mpl-1.1 \
|
||||
zpl
|
||||
|
||||
##### Variant spellings
|
||||
|
||||
|
|
Loading…
Reference in a new issue