import the Debian libpaper-1.1.22, a library to supply information about
paper sizes
This commit is contained in:
parent
95244d507d
commit
0df3df3af0
7 changed files with 98 additions and 0 deletions
3
print/libpaper/DESCR
Normal file
3
print/libpaper/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
The paper library and accompanying files are intended to provide a simple
|
||||
way for applications to take actions based on a system- or user-specified
|
||||
paper size.
|
8
print/libpaper/INSTALL
Normal file
8
print/libpaper/INSTALL
Normal file
|
@ -0,0 +1,8 @@
|
|||
#!/bin/sh
|
||||
# $NetBSD: INSTALL,v 1.1.1.1 2007/09/04 20:10:12 drochner Exp $
|
||||
|
||||
case ${STAGE} in
|
||||
POST-INSTALL)
|
||||
${PREFIX}/sbin/paperconfig -p @PAPERSIZE@
|
||||
;;
|
||||
esac
|
20
print/libpaper/Makefile
Normal file
20
print/libpaper/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/09/04 20:10:12 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libpaper_1.1.22
|
||||
PKGNAME= libpaper-1.1.22
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/libp/libpaper/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://packages.debian.org/unstable/libs/libpaper1
|
||||
COMMENT= Paper size handling library
|
||||
|
||||
WRKSRC= ${WRKDIR}/libpaper-1.1.22
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
FILES_SUBST+= PAPERSIZE=${PAPERSIZE}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
23
print/libpaper/PLIST
Normal file
23
print/libpaper/PLIST
Normal file
|
@ -0,0 +1,23 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/09/04 20:10:12 drochner Exp $
|
||||
bin/paperconf
|
||||
include/paper.h
|
||||
lib/libpaper.la
|
||||
man/man1/paperconf.1
|
||||
man/man3/defaultpapername.3
|
||||
man/man3/defaultpapersizefile.3
|
||||
man/man3/paperdone.3
|
||||
man/man3/paperfirst.3
|
||||
man/man3/paperinfo.3
|
||||
man/man3/paperinit.3
|
||||
man/man3/paperlast.3
|
||||
man/man3/papernext.3
|
||||
man/man3/paperprev.3
|
||||
man/man3/paperpsheight.3
|
||||
man/man3/paperpsname.3
|
||||
man/man3/paperpswidth.3
|
||||
man/man3/paperwithsize.3
|
||||
man/man3/systempapername.3
|
||||
man/man3/systempapersizefile.3
|
||||
man/man5/papersize.5
|
||||
man/man8/paperconfig.8
|
||||
sbin/paperconfig
|
19
print/libpaper/buildlink3.mk
Normal file
19
print/libpaper/buildlink3.mk
Normal file
|
@ -0,0 +1,19 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2007/09/04 20:10:12 drochner Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
LIBPAPER_BUILDLINK3_MK:= ${LIBPAPER_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= libpaper
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibpaper}
|
||||
BUILDLINK_PACKAGES+= libpaper
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}libpaper
|
||||
|
||||
.if ${LIBPAPER_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.libpaper+= libpaper>=1.1.22
|
||||
BUILDLINK_PKGSRCDIR.libpaper?= ../../print/libpaper
|
||||
.endif # LIBPAPER_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
6
print/libpaper/distinfo
Normal file
6
print/libpaper/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/09/04 20:10:12 drochner Exp $
|
||||
|
||||
SHA1 (libpaper_1.1.22.tar.gz) = b811b432b25ae699c5ea5583841703460f793b88
|
||||
RMD160 (libpaper_1.1.22.tar.gz) = c889d2cdd843f3ce9e553369c82a292208789b1b
|
||||
Size (libpaper_1.1.22.tar.gz) = 351106 bytes
|
||||
SHA1 (patch-aa) = 389af838d6d1d532227b63fb1cf93bbb889d4abd
|
19
print/libpaper/patches/patch-aa
Normal file
19
print/libpaper/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/09/04 20:10:12 drochner Exp $
|
||||
|
||||
--- src/paperconfig.in.orig 2007-09-04 20:59:02.000000000 +0200
|
||||
+++ src/paperconfig.in
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /bin/bash
|
||||
+#! /bin/sh
|
||||
|
||||
# paperconfig: configuration of system paper name
|
||||
#
|
||||
@@ -44,7 +44,7 @@ export @RUNPARTSDIRVAR@
|
||||
|
||||
force=0
|
||||
|
||||
-if [ "$#" == 0 ]
|
||||
+if [ "$#" = 0 ]
|
||||
then
|
||||
usage
|
||||
fi
|
Loading…
Reference in a new issue