Update to 2.95.

* Tue Jul 13 2010 Eric S. Raymond <esr@snark.thyrsus.com> - 2.95
  The autonomous robot submarine total world domination release!
  Rationalize clearing and generation of DOPs, this makes epx/epy much
  more generally available. Fixed the test productions for the udev
  magic and added a troubleshooting note in INSTALL. cgps now displays
  epx/epy rather than eph. Speed is now always reported if our last
  two fixes were good, even if the GPS didn't compute it.  Reading
  packets from UDP datagrams by specifying a listening address and
  port is now supported, and the regression-test driver cam now be
  told to force this with -u; this enables regression testing in
  chroot jails where access to ptys is locked out. AIS code now
  interprets message type 6 and 8 application IDs correctly as a
  Designated Area Code and Functional ID pair. gpspipe has a new -T
  option for setting the timestamp format.  xgpsspeed is completely
  rewritten in Python, eliminating some dependencies on ancient X
  libraries.  We now ship a Qt binding for the client library. Note
  a GCC 4.2.1 optimizer bug.  gpsdcode now uses | as a field separator
  in -c mode, as string fields can contain commas.  Corrected error
  or reporting of AIS rate-of-turn fields.
This commit is contained in:
gdt 2010-07-14 16:53:04 +00:00
parent ec388c5466
commit 0df412d76c
4 changed files with 10 additions and 28 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.18 2010/05/25 00:50:15 gdt Exp $
# $NetBSD: Makefile,v 1.19 2010/07/14 16:53:04 gdt Exp $
DISTNAME= gpsd-2.94
DISTNAME= gpsd-2.95
CATEGORIES= geography
MASTER_SITES= http://download.berlios.de/gpsd/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2010/05/25 00:50:15 gdt Exp $
@comment $NetBSD: PLIST,v 1.9 2010/07/14 16:53:04 gdt Exp $
bin/cgps
bin/gpscat
bin/gpsctl
@ -10,6 +10,7 @@ bin/gpsprof
bin/gpxlogger
bin/lcdgps
bin/xgps
bin/xgpsspeed
include/gps.h
include/gpsd.h
include/libgpsmm.h
@ -19,6 +20,8 @@ lib/pkgconfig/libgps.pc
lib/pkgconfig/libgpsd.pc
${PYSITELIB}/gps/__init__.py
${PYSITELIB}/gps/__init__.pyc
${PYSITELIB}/gps/client.py
${PYSITELIB}/gps/client.pyc
${PYSITELIB}/gps/clienthelpers.so
${PYSITELIB}/gps/fake.py
${PYSITELIB}/gps/fake.pyc

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.18 2010/06/16 22:16:31 gdt Exp $
$NetBSD: distinfo,v 1.19 2010/07/14 16:53:04 gdt Exp $
SHA1 (gpsd-2.94.tar.gz) = d1c0661ebd6b41d019249b6588b7478927b7eba6
RMD160 (gpsd-2.94.tar.gz) = 7c3a2d36eefb1ee533c138d6b77da8e1ece8fd2f
Size (gpsd-2.94.tar.gz) = 1209893 bytes
SHA1 (gpsd-2.95.tar.gz) = af1f575c8ec3a2db7a71c35f2296fd339a4a1ff3
RMD160 (gpsd-2.95.tar.gz) = c9e8d3b7ff73c655d65f0f6e329ca7ff241b10f6
Size (gpsd-2.95.tar.gz) = 1385681 bytes
SHA1 (patch-aa) = b77bd7491ee890fc66f807cbfe4c6d62423d67d5
SHA1 (patch-ab) = 20d8311e3a71e2569e4a12a5775a3b0d29be8f30

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ab,v 1.6 2010/06/16 22:16:31 gdt Exp $
This change is present post-2.94 in upstream git as
commit 01296e67701bac187d83a5a88395de3478326f93.
--- Makefile.in.orig 2010-06-16 11:40:45.000000000 +0000
+++ Makefile.in
@@ -1996,7 +1996,11 @@ gpsd_maskdump.c: gpsd.h-tail maskaudit.p
# Install Python modules
@HAVE_PYTHON_TRUE@install-exec-local:
-@HAVE_PYTHON_TRUE@ $(PYTHON) setup.py install --prefix=${prefix} --root=$(DESTDIR)
+@HAVE_PYTHON_TRUE@ if test -z "$(DESTDIR)"; then \
+@HAVE_PYTHON_TRUE@ $(PYTHON) setup.py install --prefix=${prefix}; \
+@HAVE_PYTHON_TRUE@ else \
+@HAVE_PYTHON_TRUE@ $(PYTHON) setup.py install --prefix=${prefix} --root=$(DESTDIR); \
+@HAVE_PYTHON_TRUE@ fi
@HAVE_XSLT_PROCESSOR_TRUE@.xml.1:
@HAVE_XSLT_PROCESSOR_TRUE@ $(MANGENERATOR) $(MANFLAGS) $(MANTARGET) $<