kitemviews: Avoid ambiguous function call.

This commit is contained in:
jperkin 2024-02-28 11:13:18 +00:00
parent fb9d045bdd
commit 0e1919a553
2 changed files with 17 additions and 1 deletions

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.17 2024/02/06 10:46:34 markd Exp $
$NetBSD: distinfo,v 1.18 2024/02/28 11:13:18 jperkin Exp $
BLAKE2s (kitemviews-5.114.0.tar.xz) = b1946404734b304ede97c9bbcb80bb8610c4cac75b686111230cd647a7b47b79
SHA512 (kitemviews-5.114.0.tar.xz) = f431e0db8a0245bea10f76583b259314b2378fa91a89072db516a50cd1835a4526df34f32a9ed2eef8453226f9205f8d96beefd8727ff648cee4379fd1bc54a5
Size (kitemviews-5.114.0.tar.xz) = 2264800 bytes
SHA1 (patch-src_kcategorydrawer.cpp) = 866d2f7de33e9495a43de26bdc6b8ad4ff2d9d17

View File

@ -0,0 +1,15 @@
$NetBSD: patch-src_kcategorydrawer.cpp,v 1.1 2024/02/28 11:13:18 jperkin Exp $
Avoid ambiguous function call.
--- src/kcategorydrawer.cpp.orig 2024-02-28 10:28:36.635078552 +0000
+++ src/kcategorydrawer.cpp
@@ -78,7 +78,7 @@ void KCategoryDrawer::drawCategory(const
QRect backgroundRect(option.rect);
backgroundRect.setLeft(fontMetrics.horizontalAdvance(category) + sidePadding * 2);
backgroundRect.setRight(backgroundRect.right() - sidePadding);
- backgroundRect.setTop(backgroundRect.top() + topPadding + ceil(fontMetrics.height() / 2));
+ backgroundRect.setTop(backgroundRect.top() + topPadding + std::ceil(fontMetrics.height() / 2));
backgroundRect.setHeight(1);
painter->save();
painter->setBrush(backgroundColor);