Update to 2.4.2:

Changes from version 2.4.1 to version 2.4.2:
- Security fix in formatted output functions (buffer overflow).
- Formatted output functions: 6 is now the default value for
  empty precision field with %Rf.
- Better portability of configure script.
- Detection of intmax_t and uintmax_t types.
- Improved documentation: mpfr_get_z_exp, mpfr_strtofr, mpfr_get_str and
  formatted output functions.
- Improved message in case of assertion failure.
- Test coverage: 97.0% lines of code.
- Updated tcmp_ld test to really test the long double.
- Some documentation files are installed in $docdir.
- Removed mpfr_init_cache (unused and undocumented function).
- Fixed the way $CC / $CFLAGS are got from gmp.h (__GMP_CC / __GMP_CFLAGS).
- Bug fixes.
- Also note that GCC 4.4.0 (only this obsolete version) does not build
  MPFR 2.4.2 correctly; this is detected by "make check" (failures in
  tget_z and tpow_all).
This commit is contained in:
wiz 2009-12-15 12:35:57 +00:00
parent 7fdb3dd27f
commit 0e1ae43a9d
4 changed files with 21 additions and 24 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.12 2009/03/19 11:54:53 drochner Exp $
# $NetBSD: Makefile,v 1.13 2009/12/15 12:35:57 wiz Exp $
#
DISTNAME= mpfr-2.4.1
DISTNAME= mpfr-2.4.2
CATEGORIES= math
MASTER_SITES= http://www.mpfr.org/mpfr-current/

View file

@ -1,5 +1,16 @@
@comment $NetBSD: PLIST,v 1.2 2006/03/02 19:09:39 drochner Exp $
@comment $NetBSD: PLIST,v 1.3 2009/12/15 12:35:57 wiz Exp $
include/mpf2mpfr.h
include/mpfr.h
info/mpfr.info
lib/libmpfr.la
share/doc/mpfr/AUTHORS
share/doc/mpfr/BUGS
share/doc/mpfr/COPYING
share/doc/mpfr/COPYING.LIB
share/doc/mpfr/FAQ.html
share/doc/mpfr/NEWS
share/doc/mpfr/TODO
share/doc/mpfr/examples/ReadMe
share/doc/mpfr/examples/divworst.c
share/doc/mpfr/examples/rndo-add.c
share/doc/mpfr/examples/sample.c

View file

@ -1,10 +1,9 @@
$NetBSD: distinfo,v 1.7 2009/03/19 11:54:53 drochner Exp $
$NetBSD: distinfo,v 1.8 2009/12/15 12:35:57 wiz Exp $
SHA1 (mpfr-2.4.1/mpfr-2.4.1.tar.gz) = e9c46db8bfbfb9bcd6d623a2a3b1aa4fdc0b43ab
RMD160 (mpfr-2.4.1/mpfr-2.4.1.tar.gz) = c72db1cf8976a07ac4b9f5fa00a5221c963f04b4
Size (mpfr-2.4.1/mpfr-2.4.1.tar.gz) = 1375528 bytes
SHA1 (mpfr-2.4.1/patches) = 23289ad26fd4b5853d267198eb93a618d8f27f6c
RMD160 (mpfr-2.4.1/patches) = d3cbc137f7899f343ecfd5a64f5f6dd47d3143a8
Size (mpfr-2.4.1/patches) = 10044 bytes
SHA1 (mpfr-2.4.2/mpfr-2.4.2.tar.gz) = d2c3504bd0318dda8332ca80523659e9779c367c
RMD160 (mpfr-2.4.2/mpfr-2.4.2.tar.gz) = 97f90103dd791b860a2736a73391a300441bcd35
Size (mpfr-2.4.2/mpfr-2.4.2.tar.gz) = 1412116 bytes
SHA1 (mpfr-2.4.2/patches) = 9c8a8325848b4331e5c032abee1c765ad2e56de2
RMD160 (mpfr-2.4.2/patches) = e612c1f8013860bbe53354022700855fdbc804f2
Size (mpfr-2.4.2/patches) = 7136 bytes
SHA1 (patch-aa) = c86d768a642287fe6c4ef011f65aba7c59e089c0
SHA1 (patch-ab) = 46bcb0f03a9489904fdd4cc7720e12db100d8c87

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1 2009/03/19 11:54:53 drochner Exp $
--- configure.orig 2009-03-18 19:19:49.000000000 +0100
+++ configure
@@ -24782,7 +24782,7 @@ $as_echo "$ac_try_echo") >&5
{ $as_echo "$as_me:$LINENO: result: yes" >&5
$as_echo "yes" >&6; }
-if test "$ac_cv_type_intmax_t" == yes; then
+if test "$ac_cv_type_intmax_t" = yes; then
{ $as_echo "$as_me:$LINENO: checking if gmp_printf supports \"%jd\"" >&5
$as_echo_n "checking if gmp_printf supports \"%jd\"... " >&6; }