notmuch: Update 0.31.2

Changelog:
What's new in notmuch 0.31.2
=========================

Build
-----

Catch one more occurence of "version" in the build system, which
caused the file to be regenerated in the release tarball.


What's new in notmuch 0.31.1
=========================

Library
-------

Fix a memory initialization bug in notmuch_database_get_config_list.

Build
-----

Rename file 'version' to 'version.txt'. The old file name conflicted
with a C++ header for some compilers.

Replace use of coreutils `realpath` in configure.
This commit is contained in:
ryoon 2020-11-10 14:39:44 +00:00
parent b72185a0b7
commit 0e36160742
5 changed files with 7 additions and 52 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.59 2020/09/06 03:11:31 ryoon Exp $
# $NetBSD: Makefile,v 1.60 2020/11/10 14:39:44 ryoon Exp $
DISTNAME= notmuch-0.31
DISTNAME= notmuch-0.31.2
CATEGORIES= mail
MASTER_SITES= https://notmuchmail.org/releases/
EXTRACT_SUFX= .tar.xz
@ -45,9 +45,6 @@ SUBST_VARS.gpg= GPGME_GPG
LDFLAGS.SunOS+= -lnsl
post-extract:
${MV} ${WRKSRC}/version ${WRKSRC}/version.txt
.include "../../lang/python/application.mk"
BUILDLINK_API_DEPENDS.gmime3+= gmime3>=3.0.3
.include "../../mail/gmime3/buildlink3.mk"

View file

@ -1,11 +1,8 @@
$NetBSD: distinfo,v 1.46 2020/09/06 03:11:31 ryoon Exp $
$NetBSD: distinfo,v 1.47 2020/11/10 14:39:44 ryoon Exp $
SHA1 (notmuch-0.31.tar.xz) = 22216a1042eb56ad77736486b3a0e3f9bae0dbf0
RMD160 (notmuch-0.31.tar.xz) = fb81323f925597cd6dbcb7bc555138d4ed492e40
SHA512 (notmuch-0.31.tar.xz) = 928acc07b9dbed4275e7d39d94202bea7685e9d433a7bf4c07e40e191ed4fe8cf15ac04c18792e46f4605ffac548b942998005d8176a58ad76c82d4085a408e5
Size (notmuch-0.31.tar.xz) = 713144 bytes
SHA1 (patch-Makefile.global) = f436bdb163e3110a8d097f3c88198aefb126eafc
SHA1 (patch-Makefile.local) = d0a83ff130de36164f1667236860aa31d481d025
SHA1 (notmuch-0.31.2.tar.xz) = 0bc325f82c44ec2144d4bd42500be7f23d7eb410
RMD160 (notmuch-0.31.2.tar.xz) = 566a65c82b23946bc2bde8a3505384555041097d
SHA512 (notmuch-0.31.2.tar.xz) = b134ef79648cb6fe9f17b2f1b600d651d57359ae9fa576c808b794aa64a09955f0597a624cc3c498da4ef56e44bca6bb485bc402c2dff48cd000959f9a9ceeaa
Size (notmuch-0.31.2.tar.xz) = 713388 bytes
SHA1 (patch-configure) = 540b17f70befb7eced5f0a0361c3232a71cc48a1
SHA1 (patch-doc_conf.py) = 7492c878c96da68df16827aa0d6407c2e9808701
SHA1 (patch-emacs_Makefile.local) = 4a36a2c165852a098a45c8b99c8372d65d33b07c

View file

@ -1,13 +0,0 @@
$NetBSD: patch-Makefile.global,v 1.3 2018/12/27 15:07:05 joerg Exp $
--- Makefile.global.orig 2018-12-25 23:07:48.081408526 +0000
+++ Makefile.global
@@ -16,7 +16,7 @@ else
DATE:=$(shell date +%F)
endif
-VERSION:=$(shell cat ${srcdir}/version)
+VERSION:=$(shell cat ${srcdir}/version.txt)
ELPA_VERSION:=$(subst ~,_,$(VERSION))
ifeq ($(filter release release-message pre-release update-versions,$(MAKECMDGOALS)),)
ifeq ($(IS_GIT),yes)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-Makefile.local,v 1.6 2018/12/27 15:07:05 joerg Exp $
--- Makefile.local.orig 2018-12-25 23:06:56.845922522 +0000
+++ Makefile.local
@@ -19,7 +19,7 @@ endif
# Depend (also) on the file 'version'. In case of ifeq ($(IS_GIT),yes)
# this file may already have been updated.
-version.stamp: $(srcdir)/version
+version.stamp: $(srcdir)/version.txt
echo $(VERSION) > $@
$(TAR_FILE):

View file

@ -1,13 +0,0 @@
$NetBSD: patch-doc_conf.py,v 1.1 2018/12/27 15:07:05 joerg Exp $
--- doc/conf.py.orig 2018-12-25 23:11:46.371067128 +0000
+++ doc/conf.py
@@ -17,7 +17,7 @@ copyright = u'2009-2018, Carl Worth and
location = os.path.dirname(__file__)
for pathdir in ['.', '..']:
- version_file = os.path.join(location,pathdir,'version')
+ version_file = os.path.join(location,pathdir,'version.txt')
if os.path.exists(version_file):
with open(version_file,'r') as infile:
version=infile.read().replace('\n','')