py-sphinx-autodoc-typehints: update to 1.10.3.
1.10.3 ====== * Fixed ``TypeError`` (or wrong rendered class name) when an annotation is a generic class that has a ``name`` property 1.10.2 ====== * Fixed inner classes missing their parent class name(s) when rendered 1.10.1 ====== * Fixed ``KeyError`` when encountering mocked annotations (``autodoc_mock_imports``) 1.10.0 ====== * Rewrote the annotation formatting logic (fixes Python 3.5.2 compatibility regressions and an ``AttributeError`` regression introduced in v1.9.0) * Fixed decorator classes not being processed as classes 1.9.0 ===== * Added support for typing_extensions_ * Added the ``typehints_document_rtype`` option (PR by Simon-Martin Schröder) * Fixed metaclasses as annotations causing ``TypeError`` * Fixed rendering of ``typing.Literal`` * Fixed OSError when generating docs for SQLAlchemy mapped classes * Fixed unparametrized generic classes being rendered with their type parameters (e.g. ``Dict[~KT, ~VT]``) .. _typing_extensions: https://pypi.org/project/typing-extensions/ 1.8.0 ===== * Fixed regression which caused ``TypeError`` or ``OSError`` when trying to set annotations due to PR #87 * Fixed unintentional mangling of annotation type names * Added proper ``:py:data`` targets for ``NoReturn``, ``ClassVar`` and ``Tuple`` * Added support for inline type comments (like ``(int, str) -> None``) (PR by Bernát Gábor) * Use the native AST parser for type comment support on Python 3.8+ 1.7.0 ===== * Dropped support for Python 3.4 * Fixed unwrapped local functions causing errors (PR by Kimiyuki Onaka) * Fixed ``AttributeError`` when documenting the ``__init__()`` method of a data class * Added support for type hint comments (PR by Markus Unterwaditzer) * Added flag for rendering classes with their fully qualified names (PR by Holly Becker) 1.6.0 ===== * Fixed ``TypeError`` when formatting annotations from a class that inherits from a concrete generic type (report and tests by bpeake-illuscio) * Added support for ``typing_extensions.Protocol`` (PR by Ian Good) * Added support for ``typing.NewType`` (PR by George Leslie-Waksman) 1.5.2 ===== * Emit a warning instead of crashing when an unresolvable forward reference is encountered in type annotations 1.5.1 ===== * Fixed escape characters in parameter default values getting lost during signature processing * Replaced use of the ``config-inited`` event (which inadvertently required Sphinx 1.8) with the ``builder-inited`` event 1.5.0 ===== * The setting of the ``typing.TYPECHECKING`` flag is now configurable using the ``set_type_checking_flag`` option 1.4.0 ===== * The extension now sets ``typing.TYPECHECKING`` to ``True`` during setup to include conditional imports which may be used in type annotations * Fixed parameters with trailing underscores (PR by Daniel Knell) * Fixed KeyError with private methods (PR by Benito Palacios Sánchez) * Fixed deprecation warning about the use of formatargspec (PR by Y. Somda) * The minimum Sphinx version is now v1.7.0 1.3.1 ===== * Fixed rendering of generic types outside the typing module (thanks to Tim Poterba for the PR)
This commit is contained in:
parent
9ebf8f7be4
commit
0e362ed2ec
3 changed files with 14 additions and 23 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.3 2019/05/02 09:27:09 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2020/04/06 08:06:30 wiz Exp $
|
||||
|
||||
DISTNAME= sphinx-autodoc-typehints-1.3.0
|
||||
DISTNAME= sphinx-autodoc-typehints-1.10.3
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=s/sphinx-autodoc-typehints/}
|
||||
|
@ -12,11 +12,18 @@ LICENSE= mit
|
|||
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm-[0-9]*:../../devel/py-setuptools_scm
|
||||
DEPENDS+= ${PYPKGPREFIX}-sphinx>=1.4:../../textproc/py-sphinx
|
||||
DEPENDS+= ${PYPKGPREFIX}-sphobjinv-[0-9]*:../../textproc/py-sphobjinv
|
||||
DEPENDS+= ${PYPKGPREFIX}-typing-extensions-[0-9]*:../../devel/py-typing-extensions
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test>=3.1.0:../../devel/py-test
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 27
|
||||
|
||||
TEST_ENV+= PYTHONPATH=${WRKSRC}/build/lib
|
||||
|
||||
do-test:
|
||||
cd ${WRKSRC} && ${MAKE_ENV} ${TEST_ENV} py.test-${PYVERSSUFFIX}
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2018/05/27 01:59:35 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.2 2020/04/06 08:06:30 wiz Exp $
|
||||
|
||||
SHA1 (sphinx-autodoc-typehints-1.3.0.tar.gz) = f748fe87594438ffd9475ed2ab4c787e66d6c955
|
||||
RMD160 (sphinx-autodoc-typehints-1.3.0.tar.gz) = 099eb1d9801982b3c297383f4a9c68a1b26b8c60
|
||||
SHA512 (sphinx-autodoc-typehints-1.3.0.tar.gz) = 04b7398f5b969c2802022799609c55cfd3201e4cd60f85fa5ef5670e67fc6154904872410776b37258f58517a629885d15f08aa1ba5281dad2ad2480cd89cc5b
|
||||
Size (sphinx-autodoc-typehints-1.3.0.tar.gz) = 10043 bytes
|
||||
SHA1 (patch-setup.cfg) = 1ccc450914d50544268b87b485df63a54feebbfb
|
||||
SHA1 (sphinx-autodoc-typehints-1.10.3.tar.gz) = 2b4de74f22ce3ad223fbbb78b1592595fe9fbe20
|
||||
RMD160 (sphinx-autodoc-typehints-1.10.3.tar.gz) = c3fd63f02a1017ff6882931c764192ec2653241f
|
||||
SHA512 (sphinx-autodoc-typehints-1.10.3.tar.gz) = 170fd6cea10d730eefeef4e2e4de985119dbcde06d43181bb522ec31923ddc49dd7757ca623c820e2e5008198ef9b522d70e08c0c6ff5349921f1777b797bddb
|
||||
Size (sphinx-autodoc-typehints-1.10.3.tar.gz) = 16396 bytes
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-setup.cfg,v 1.1 2018/05/27 01:59:35 minskim Exp $
|
||||
|
||||
Remove a non-ascii character.
|
||||
|
||||
--- setup.cfg.orig 2018-03-18 16:36:50.000000000 +0000
|
||||
+++ setup.cfg
|
||||
@@ -2,7 +2,7 @@
|
||||
name = sphinx-autodoc-typehints
|
||||
description = Type hints (PEP 484) support for the Sphinx autodoc extension
|
||||
long_description = file: README.rst
|
||||
-author = Alex Grönholm
|
||||
+author = Alex Gronholm
|
||||
author_email = alex.gronholm@nextday.fi
|
||||
url = https://github.com/agronholm/sphinx-autodoc-typehints
|
||||
license = MIT
|
Loading…
Reference in a new issue