Changes 6.16.0:

* Bug fixes
This commit is contained in:
adam 2008-11-10 09:45:43 +00:00
parent 08f224b888
commit 0e4b46698f
3 changed files with 8 additions and 23 deletions

View file

@ -1,8 +1,6 @@
# $NetBSD: Makefile,v 1.64 2008/06/23 21:09:43 markd Exp $
#
# $NetBSD: Makefile,v 1.65 2008/11/10 09:45:43 adam Exp $
DISTNAME= tcsh-6.15.00
PKGREVISION= 2
DISTNAME= tcsh-6.16.00
CATEGORIES= shells
MASTER_SITES= ftp://ftp.astron.com/pub/tcsh/ \
ftp://ftp.gw.com/pub/unix/tcsh/ \
@ -35,9 +33,9 @@ INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
post-install:
@${ECHO} "Installing message catalogues"
cp ${PKGDIR:Q}/PLIST ${PLIST_SRC:Q}
cp ${PKGDIR}/PLIST ${PLIST_SRC}
set -e; \
if [ -f ${WRKSRC:Q}/tcsh.C.cat ]; \
if [ -f ${WRKSRC}/tcsh.C.cat ]; \
then \
[ -d ${DESTDIR}${PREFIX:Q}/${NLSDIR:Q}/C ] || \
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX:Q}/${NLSDIR:Q}/C;\

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.23 2008/06/23 21:09:43 markd Exp $
$NetBSD: distinfo,v 1.24 2008/11/10 09:45:43 adam Exp $
SHA1 (tcsh-6.15.00.tar.gz) = d24f7bf27e80222a6293b6629c14db547f0b7387
RMD160 (tcsh-6.15.00.tar.gz) = 8065279e93bd3fddb2a95a3f74a680858d36508c
Size (tcsh-6.15.00.tar.gz) = 870886 bytes
SHA1 (tcsh-6.16.00.tar.gz) = 3d3536bbb9201abdf39b8b364b95e0a218970a5c
RMD160 (tcsh-6.16.00.tar.gz) = ed23351273bb737c184658235f33869488e64696
Size (tcsh-6.16.00.tar.gz) = 886468 bytes
SHA1 (patch-aa) = 5ba012bfa662b57be300f5e81a8fcce44b218e72
SHA1 (patch-ab) = ab71a3826bbcef0702a7d43446f13454176aa671
SHA1 (patch-ac) = f933d4e162b2d8a5e79d425118677cec32c624c5

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ac,v 1.11 2008/06/23 21:09:43 markd Exp $
--- sh.glob.c.orig 2006-10-15 06:57:21.000000000 +1300
+++ sh.glob.c
@@ -667,6 +667,7 @@ dobackp(Char *cp, int literal)
}
if (!*rp) {
oops:
+ cleanup_until(&bb);
stderror(ERR_UNMATCHED, '`');
}
ep = Strnsave(lp, rp - lp);