lua-socket: Build missing unix.so und serial.so files

This commit is contained in:
tm 2024-02-05 13:23:16 +00:00
parent 00600e8b75
commit 0e797613c0
5 changed files with 32 additions and 9 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2020/07/11 15:14:30 nia Exp $
# $NetBSD: Makefile,v 1.14 2024/02/05 13:23:16 tm Exp $
DISTNAME= luasocket-3.0-rc1
PKGNAME= ${LUA_PKGPREFIX}-${DISTNAME:S/lua//:S/-rc/rc/}
@ -13,7 +13,7 @@ LICENSE= mit
MAKE_FILE= makefile
LDFLAGS.SunOS= -lrt -lresolv
LDFLAGS.SunOS= -lrt -lresolv -lsocket -lnsl
MAKE_FLAGS+= LUAV=${_LUA_DOT_VERSION}
MAKE_FLAGS+= LUAINC_linux_base=${PREFIX}/include

View File

@ -1,6 +1,8 @@
@comment $NetBSD: PLIST,v 1.3 2014/01/22 16:20:51 jperkin Exp $
@comment $NetBSD: PLIST,v 1.4 2024/02/05 13:23:16 tm Exp $
${LUA_CDIR}/mime/core.so
${LUA_CDIR}/socket/core.so
${LUA_CDIR}/socket/serial.so
${LUA_CDIR}/socket/unix.so
${LUA_LDIR}/ltn12.lua
${LUA_LDIR}/mime.lua
${LUA_LDIR}/socket.lua

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.7 2021/10/26 11:05:58 nia Exp $
$NetBSD: distinfo,v 1.8 2024/02/05 13:23:16 tm Exp $
BLAKE2s (luasocket-3.0-rc1.tar.gz) = e63616d8206b9d242fd7a16ce6a439def91698968cb3920943039549172ff882
SHA512 (luasocket-3.0-rc1.tar.gz) = f6efce259aaacaa11472911471f8a13b118fe009b8953a82c6aa18b9ec829cd1293180904e56935cb130d36d267e3f27c91db2d78e03f7488f3e100571ed0540
Size (luasocket-3.0-rc1.tar.gz) = 328598 bytes
SHA1 (patch-makefile) = 2a6380adfa8f7ef63e70e0de9ef4eb4e76eff334
SHA1 (patch-src_makefile) = eacf2d6152c68e8954bbe45f270c9cf13e731500
SHA1 (patch-makefile) = 9040afc943b773569d5fc260e31ed38eb2a87b28
SHA1 (patch-src_makefile) = 6d385804dc9f36ccff1d335388472dccb742bb91

View File

@ -1,6 +1,7 @@
$NetBSD: patch-makefile,v 1.1 2013/09/13 14:24:28 fhajny Exp $
$NetBSD: patch-makefile,v 1.2 2024/02/05 13:23:16 tm Exp $
Pass our LDFLAGS.
--- makefile.orig 2013-06-14 11:27:32.000000000 +0000
+++ makefile
@@ -15,7 +15,7 @@ PLATS= macosx linux win32 mingw

View File

@ -1,6 +1,8 @@
$NetBSD: patch-src_makefile,v 1.2 2016/06/04 23:08:13 alnsn Exp $
$NetBSD: patch-src_makefile,v 1.3 2024/02/05 13:23:16 tm Exp $
Pass our LDFLAGS.
Build unix.so, serial.so and install them always.
Fix luaL_checkint problem in 5.3. Pass our LDFLAGS.
--- src/makefile.orig 2013-06-14 11:27:32.000000000 +0000
+++ src/makefile
@@ -145,13 +145,13 @@ SOCKET_macosx=usocket.o
@ -19,3 +21,21 @@ Fix luaL_checkint problem in 5.3. Pass our LDFLAGS.
LD_linux=gcc
SOCKET_linux=usocket.o
@@ -307,7 +307,7 @@ none:
@echo "where PLATFORM is one of these:"
@echo " $(PLATS)"
-all: $(SOCKET_SO) $(MIME_SO)
+all: $(SOCKET_SO) $(MIME_SO) $(UNIX_SO) $(SERIAL_SO)
$(SOCKET_SO): $(SOCKET_OBJS)
$(LD) $(SOCKET_OBJS) $(LDFLAGS)$@
@@ -332,6 +332,8 @@ install:
$(INSTALL_EXEC) $(SOCKET_SO) $(INSTALL_SOCKET_CDIR)/core.$(SO)
$(INSTALL_DIR) $(INSTALL_MIME_CDIR)
$(INSTALL_EXEC) $(MIME_SO) $(INSTALL_MIME_CDIR)/core.$(SO)
+ $(INSTALL_EXEC) $(UNIX_SO) $(INSTALL_SOCKET_CDIR)/$(UNIX_SO)
+ $(INSTALL_EXEC) $(SERIAL_SO) $(INSTALL_SOCKET_CDIR)/$(SERIAL_SO)
install-unix: install
$(INSTALL_EXEC) $(UNIX_SO) $(INSTALL_SOCKET_CDIR)/$(UNIX_SO)