not_tetris: patch to avoid startup crash

plus a whole bunch of logic to extract & compress the .love file again

bump pkgrevision
This commit is contained in:
maya 2024-01-19 02:34:29 +00:00
parent e840c3454e
commit 0e8e41b5bd
3 changed files with 30 additions and 2 deletions

View File

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.2 2020/01/26 17:31:17 rillig Exp $
# $NetBSD: Makefile,v 1.3 2024/01/19 02:34:29 maya Exp $
DISTNAME= nottetris2-source
PKGNAME= not_tetris-2.0
PKGREVISION= 1
CATEGORIES= games
MASTER_SITES= http://stabyourself.net/dl.php?file=nottetris2/
DIST_SUBDIR= ${PKGNAME_NOREV}
@ -15,6 +16,13 @@ LICENSE= public-domain # Specified in https://github.com/Stabyourself/nottetris2
WRKSRC= ${WRKDIR}
USE_LANGUAGES= # none
post-extract:
@${MKDIR} ${WRKDIR}/${LOVE_GAME}_archive
(cd ${WRKDIR}/${LOVE_GAME}_archive && ${UNZIP_CMD} -qo ${WRKDIR}/*.love)
pre-install:
(cd ${WRKDIR} && ${UNZIP_CMD} ${LOVE_DATA} ${WRKDIR}/${LOVE_GAME}_archive)
LOVE_GAME= not_tetris
LOVE_DATA= "Not Tetris 2.love"
LOVE_VERSION= 0.7

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2021/10/26 10:44:17 nia Exp $
$NetBSD: distinfo,v 1.4 2024/01/19 02:34:29 maya Exp $
BLAKE2s (not_tetris-2.0/nottetris2-source.zip) = 4c1e565b115c20f2f803c5004771103e607290c6aff91bcd2ebbcbeceb64fd92
SHA512 (not_tetris-2.0/nottetris2-source.zip) = 475061353217f99e0dd35a34097b6b35275a350ab112bfd27d85ea5fe32434c6b4ed107056af5a243d06d2b5988d2bf73776c01077ba2a17e223e8bd0778b563
Size (not_tetris-2.0/nottetris2-source.zip) = 2773694 bytes
SHA1 (patch-not__tetris-2.0_menu.lua) = 4d078116d721958ab46dbb501be69e2e95d1a78d

View File

@ -0,0 +1,19 @@
$NetBSD: patch-not__tetris-2.0_menu.lua,v 1.1 2024/01/19 02:34:30 maya Exp $
Avoid uninitialized oldtime
Prevent startup crash
--- not_tetris_archive/menu.lua.orig 2024-01-19 02:26:25.027517359 +0000
+++ not_tetris_archive/menu.lua
@@ -1,3 +1,4 @@
+oldtime = 0
function menu_load()
gamestate = "logo"
creditstext = {
@@ -284,4 +285,4 @@ function menu_update(dt)
end
end
end
-end
\ No newline at end of file
+end