Update to IOzone 3.408

Changes since version 3.397:

Revision 3.408
Bug fix for clobbering of buffer. "tfile" needed to be bigger, as its
address was loaded into filearray[] and then that was overwritten
by the mfflag causing parsed names to get loaded.

Revision 3.407
Work around for cache_line_size suddenly becoming zero and breaking fetchit()

Revision 3.406
Increase buffer size for configuration lines. They might be 700 chars long.

Revision 3.405
Reduce CPU consumption in the op_rate control mechanism.

Revision 3.404
Fix type-oh in usage message.

Revision 3.403
Add -+W to permit chid_skew. This permits adding files, and continuing
the proper sharing/dedup within each quadrant, within same seed group
and with previously existing files that were created with a different
number of threads.

Revision 3.402
Mods for DragonFly support.

Revision 3.401
bug fix for re-write rec.

Revision 3.398
Adding thread_read_test and thread_write_test.
This commit is contained in:
asau 2012-06-07 15:57:20 +00:00
parent 34da93fc48
commit 0ea15a90b1
5 changed files with 27 additions and 56 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.43 2012/01/12 15:11:37 hans Exp $
# $NetBSD: Makefile,v 1.44 2012/06/07 15:57:20 asau Exp $
DISTNAME= iozone3_397
PKGNAME= iozone-3.397
DISTNAME= iozone3_408
PKGNAME= iozone-3.408
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
EXTRACT_SUFX= .tar

View file

@ -1,10 +1,8 @@
$NetBSD: distinfo,v 1.19 2012/01/24 23:45:00 marino Exp $
$NetBSD: distinfo,v 1.20 2012/06/07 15:57:20 asau Exp $
SHA1 (iozone3_397.tar) = 6095a38542286376f6eb2a203f253dc4c31ddeda
RMD160 (iozone3_397.tar) = b87e1732206eae0762d1e6bd552b33af8bdc045a
Size (iozone3_397.tar) = 1679360 bytes
SHA1 (iozone3_408.tar) = 3dc56a251949151d12fc033f179cb6852abc71de
RMD160 (iozone3_408.tar) = c9caa3f02f0404d3b4a3a7c7fad040439bfff8f1
Size (iozone3_408.tar) = 1822720 bytes
SHA1 (patch-aa) = e209a364cdeca38c3995fbaebde3758bdd74e582
SHA1 (patch-ab) = 934e83868b1b23e951034484b2017b2cf4289441
SHA1 (patch-ab) = 8af7a97fb4c8bfc39320b03b1b5c63acff5a3be7
SHA1 (patch-ac) = a7df47dca37d33e2658b27c4888294ad541fd1b2
SHA1 (patch-iozone_visualizer.pl) = cd5cd6ed4892bfae3ed7c48088ccdf5c9a5a53ee
SHA1 (patch-report.pl) = 9101f79c78a55ca60993723923dd79dd51720490

View file

@ -1,17 +1,17 @@
$NetBSD: patch-ab,v 1.10 2012/01/24 23:45:00 marino Exp $
$NetBSD: patch-ab,v 1.11 2012/06/07 15:57:20 asau Exp $
--- iozone.c.orig 2011-05-06 15:39:00.000000000 +0000
--- iozone.c.orig 2012-05-10 05:14:12.000000000 +0000
+++ iozone.c
@@ -70,7 +70,7 @@
#include <windows.h>
#include <errno.h>
#else
-#if defined(linux) || defined(solaris) || defined(macosx) || defined(__AIX__) || defined(FreeBSD) || defined(_HPUX_SOURCE)
+#if defined(linux) || defined(solaris) || defined(macosx) || defined(__AIX__) || defined(FreeBSD) || defined(_HPUX_SOURCE) || defined (__NetBSD__) || defined(__DragonFly__)
-#if defined(linux) || defined(solaris) || defined(macosx) || defined(__AIX__) || defined(FreeBSD) || defined(_HPUX_SOURCE) || defined(__OpenBSD__) || defined(__DragonFly__)
+#if defined(linux) || defined(solaris) || defined(macosx) || defined(__AIX__) || defined(__FreeBSD__) || defined(_HPUX_SOURCE) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
#include <errno.h>
#else
extern int errno; /* imported for errors */
@@ -285,7 +285,7 @@ THISVERSION,
@@ -288,7 +288,7 @@ THISVERSION,
#if !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__APPLE__) && !defined(__DragonFly__)
#include <malloc.h>
#endif
@ -20,7 +20,16 @@ $NetBSD: patch-ab,v 1.10 2012/01/24 23:45:00 marino Exp $
#include <stdlib.h>
#include <string.h>
#endif
@@ -441,6 +441,9 @@ struct piovec piov[PVECMAX];
@@ -299,7 +299,7 @@ THISVERSION,
#endif
#endif
-#if defined (__FreeBSD__) || defined(__DSragonFly__)
+#if defined (__FreeBSD__) || defined(__DragonFly__)
#ifndef O_RSYNC
#define O_RSYNC O_FSYNC
#endif
@@ -444,6 +444,9 @@ struct piovec piov[PVECMAX];
struct iovec piov[PVECMAX];
#define piov_base iov_base
#define piov_len iov_len
@ -30,7 +39,7 @@ $NetBSD: patch-ab,v 1.10 2012/01/24 23:45:00 marino Exp $
#endif
#endif
@@ -6876,7 +6879,11 @@ long long *data2;
@@ -7363,7 +7366,11 @@ long long *data2;
if(odsync)
file_flags |= O_DSYNC;
#endif
@ -43,7 +52,7 @@ $NetBSD: patch-ab,v 1.10 2012/01/24 23:45:00 marino Exp $
if(read_sync)
file_flags |=O_RSYNC|O_SYNC;
#endif
@@ -10098,7 +10105,11 @@ long long *data1, *data2;
@@ -10585,7 +10592,11 @@ long long *data1, *data2;
open_flags |=O_DIRECTIO;
#endif
#endif
@ -56,7 +65,7 @@ $NetBSD: patch-ab,v 1.10 2012/01/24 23:45:00 marino Exp $
if(read_sync)
open_flags |=O_RSYNC|O_SYNC;
#endif
@@ -10454,7 +10465,7 @@ long long *data1,*data2;
@@ -10941,7 +10952,7 @@ long long *data1,*data2;
purgeit(piov[xx].piov_base,reclen);
}
if(pwritev(fd, piov,numvecs
@ -65,7 +74,7 @@ $NetBSD: patch-ab,v 1.10 2012/01/24 23:45:00 marino Exp $
, list_off[0]
#endif
) != (reclen*numvecs))
@@ -10781,7 +10792,7 @@ long long *data1,*data2;
@@ -11268,7 +11279,7 @@ long long *data1,*data2;
purgeit(piov[xx].piov_base,reclen);
}
if(preadv(fd, piov, numvecs

View file

@ -1,18 +0,0 @@
$NetBSD: patch-iozone_visualizer.pl,v 1.1 2011/12/02 15:31:44 hauke Exp $
--- iozone_visualizer.pl.orig 2011-12-02 13:57:45.000000000 +0000
+++ iozone_visualizer.pl
@@ -190,11 +190,11 @@ set ytics $yoffset
set logscale x 2
set logscale y 2
set autoscale z
-set xrange [2.**5:2.**24]
+#set xrange [2.**5:2.**24]
set xlabel "File size in KBytes" -2
set ylabel "Record size in Kbytes" 2
set zlabel "Kbytes/sec" 4,8
-set data style lines
+set style data lines
set dgrid3d 80,80,3
#set terminal png small picsize 900 700
set terminal png small size $size3d nocrop

View file

@ -1,18 +0,0 @@
$NetBSD: patch-report.pl,v 1.1 2011/12/02 15:31:44 hauke Exp $
--- report.pl.orig 2011-12-02 13:57:45.000000000 +0000
+++ report.pl
@@ -103,11 +103,11 @@ set ytics
set logscale x 2
set logscale y 2
set autoscale z
-set xrange [2.**5:2.**24]
+#set xrange [2.**5:2.**24]
set xlabel "File size in KBytes"
set ylabel "Record size in Kbytes"
set zlabel "Kbytes/sec"
-set data style lines
+set style data lines
set dgrid3d 80,80,3
#set terminal png small picsize 900 700
set terminal png small size 900 700