As the detection of non-python doesn't really work, pull it in.
Also depend on xmlto, otherwise the man pages are not created. Bump revision.
This commit is contained in:
parent
db854673a7
commit
0ecd2b9a6f
4 changed files with 39 additions and 16 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.15 2009/12/07 20:08:59 gdt Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2009/12/10 16:56:59 joerg Exp $
|
||||
|
||||
DISTNAME= gpsd-2.90
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= geography
|
||||
MASTER_SITES= http://download.berlios.de/gpsd/
|
||||
|
||||
|
@ -11,8 +12,11 @@ COMMENT= GPS information daemon
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILD_DEPENDS+= xmlto-[0-9]*:../../textproc/xmlto
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
CONFIGURE_ENV+= PYTHON=${PYTHONBIN}
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
@ -20,9 +24,7 @@ USE_NCURSES= yes
|
|||
|
||||
INSTALLATION_DIRS= sbin
|
||||
|
||||
# XXX This package should have an option for python to install gpsfake
|
||||
# and gpsctl.
|
||||
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,9 +1,12 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2009/12/07 20:08:59 gdt Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2009/12/10 16:56:59 joerg Exp $
|
||||
bin/cgps
|
||||
bin/gpscat
|
||||
bin/gpsctl
|
||||
bin/gpsdecode
|
||||
bin/gpsfake
|
||||
bin/gpsmon
|
||||
bin/gpspipe
|
||||
bin/gpsprof
|
||||
bin/gpxlogger
|
||||
bin/lcdgps
|
||||
include/gps.h
|
||||
|
@ -12,13 +15,27 @@ include/libgpsmm.h
|
|||
lib/libgps.la
|
||||
lib/pkgconfig/libgps.pc
|
||||
lib/pkgconfig/libgpsd.pc
|
||||
${PYSITELIB}/gps.py
|
||||
${PYSITELIB}/gps.pyc
|
||||
${PYSITELIB}/gps.pyo
|
||||
${PYSITELIB}/gpscap.py
|
||||
${PYSITELIB}/gpscap.pyc
|
||||
${PYSITELIB}/gpscap.pyo
|
||||
${PYSITELIB}/gpsfake.py
|
||||
${PYSITELIB}/gpsfake.pyc
|
||||
${PYSITELIB}/gpsfake.pyo
|
||||
${PYSITELIB}/gpslib.so
|
||||
${PYSITELIB}/gpspacket.so
|
||||
man/man1/cgps.1
|
||||
man/man1/cgpxlogger.1
|
||||
man/man1/gps.1
|
||||
man/man1/gpscat.1
|
||||
man/man1/gpsctl.1
|
||||
man/man1/gpsdecode.1
|
||||
man/man1/gpsfake.1
|
||||
man/man1/gpsmon.1
|
||||
man/man1/gpspipe.1
|
||||
man/man1/gpsprof.1
|
||||
man/man1/lcdgps.1
|
||||
man/man1/xgps.1
|
||||
man/man1/xgpsspeed.1
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.13 2009/12/07 20:08:59 gdt Exp $
|
||||
$NetBSD: distinfo,v 1.14 2009/12/10 16:56:59 joerg Exp $
|
||||
|
||||
SHA1 (gpsd-2.90.tar.gz) = e8831bd8013015633c49e6af37537ee6228e5372
|
||||
RMD160 (gpsd-2.90.tar.gz) = 556f58520d9b931aa60be0fc76b82106220984de
|
||||
Size (gpsd-2.90.tar.gz) = 915578 bytes
|
||||
SHA1 (patch-aa) = 794856c5f43c655a9f5f5df69f072663c022e0ac
|
||||
SHA1 (patch-aa) = 0ff78d9d9201512cc3c12557a2b2dbe454759fed
|
||||
|
|
|
@ -1,12 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.6 2009/12/07 20:08:59 gdt Exp $
|
||||
$NetBSD: patch-aa,v 1.7 2009/12/10 16:56:59 joerg Exp $
|
||||
|
||||
Not 100% sure about this, but it is not apparently fixed upstream.
|
||||
I think we should have a configure.ac patch as well for regeneration.)
|
||||
|
||||
|
||||
--- configure.orig 2009-12-04 15:45:59.000000000 -0500
|
||||
--- configure.orig 2009-12-04 21:45:59.000000000 +0100
|
||||
+++ configure
|
||||
@@ -16571,13 +16571,13 @@ if test "x$ac_cv_lib_c_open" = x""yes; t
|
||||
@@ -4630,7 +4630,6 @@ sys.exit(sys.hexversion < minverhex)"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
$as_echo "yes" >&6; }
|
||||
else
|
||||
- as_fn_error "too old" "$LINENO" 5
|
||||
fi
|
||||
am_display_PYTHON=$PYTHON
|
||||
else
|
||||
@@ -16571,13 +16570,13 @@ if test "x$ac_cv_lib_c_open" = x""yes; t
|
||||
fi
|
||||
|
||||
|
||||
|
@ -23,7 +27,7 @@ I think we should have a configure.ac patch as well for regeneration.)
|
|||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
@@ -16608,7 +16608,7 @@ fi
|
||||
@@ -16608,7 +16607,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_pthread_pthread_setcancelstate" >&5
|
||||
$as_echo "$ac_cv_lib_pthread_pthread_setcancelstate" >&6; }
|
||||
if test "x$ac_cv_lib_pthread_pthread_setcancelstate" = x""yes; then :
|
||||
|
|
Loading…
Reference in a new issue