Initial addition of a nice little puzzle game with color graphics and sound.
Fixes pr 5572 by Tim Rightnour with some fixing.
This commit is contained in:
parent
847266f808
commit
0ecfe1ab42
6 changed files with 107 additions and 0 deletions
26
games/mirrormagic/Makefile
Normal file
26
games/mirrormagic/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1 1998/06/12 13:43:17 frueauf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= mirrormagic-1.3
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= games
|
||||
|
||||
MAINTAINER= root@garbled.net
|
||||
|
||||
DEPENDS= xpm-3.4j:../../graphics/xpm
|
||||
|
||||
USE_X11= YES
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mirrormagic ${X11BASE}/bin
|
||||
${MKDIR} ${X11BASE}/share/mirrormagic/sounds
|
||||
${MKDIR} ${X11BASE}/share/mirrormagic/graphics
|
||||
${INSTALL_DATA} ${WRKSRC}/sounds/* ${X11BASE}/share/mirrormagic/sounds
|
||||
${INSTALL_DATA} ${WRKSRC}/graphics/* ${X11BASE}/share/mirrormagic/graphics
|
||||
${INSTALL_DATA} ${WRKSRC}/RAY.* ${X11BASE}/share/mirrormagic
|
||||
${GUNZIP_CMD} ${X11BASE}/share/mirrormagic/graphics/*.gz
|
||||
${TOUCH} ${X11BASE}/share/mirrormagic/RAY.score ${X11BASE}/share/mirrormagic/RAY.names
|
||||
chmod 666 ${X11BASE}/share/mirrormagic/RAY.score ${X11BASE}/share/mirrormagic/RAY.names
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
1
games/mirrormagic/files/md5
Normal file
1
games/mirrormagic/files/md5
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (mirrormagic-1.3.tar.gz) = 4b130375b8a923788470f616b28dddfe
|
29
games/mirrormagic/patches/patch-aa
Normal file
29
games/mirrormagic/patches/patch-aa
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- Makefile.orig Thu Jun 11 13:25:51 1998
|
||||
+++ Makefile Thu Jun 11 13:28:21 1998
|
||||
@@ -10,7 +10,7 @@
|
||||
|
||||
-GFX_PATH = -DGFX_PATH=\"./graphics\" # path where the graphics are
|
||||
-SND_PATH = -DSND_PATH=\"./sounds\" # path where the sounds are
|
||||
-LEVEL_PATH = -DLEVEL_PATH=\".\" # path where the level file is
|
||||
-SCORE_PATH = -DSCORE_PATH=\".\" # path where the score file is
|
||||
-NAMES_PATH = -DNAMES_PATH=\".\" # path where the names file is
|
||||
+GFX_PATH = -DGFX_PATH=\"${X11BASE}/share/mirrormagic/graphics\" # path where the graphics are
|
||||
+SND_PATH = -DSND_PATH=\"${X11BASE}/share/mirrormagic/sounds\" # path where the sounds are
|
||||
+LEVEL_PATH = -DLEVEL_PATH=\"${X11BASE}/share/mirrormagic\" # path where the level file is
|
||||
+SCORE_PATH = -DSCORE_PATH=\"${X11BASE}/share/mirrormagic\" # path where the score file is
|
||||
+NAMES_PATH = -DNAMES_PATH=\"${X11BASE}/share/mirrormagic\" # path where the names file is
|
||||
# SOUNDS = -DNO_SOUNDS # don't play any sounds
|
||||
@@ -28,3 +28,3 @@
|
||||
# DEBUG = -DDEBUG -g -Wall
|
||||
-DEBUG = -O6
|
||||
+DEBUG = -O2
|
||||
|
||||
@@ -33,6 +33,6 @@
|
||||
# SYSTEM = -DSYSV # for systems without 'usleep()'
|
||||
-# INCL = -I/usr/include/X11R5 # for HP-UX and others
|
||||
+INCL = -I${X11BASE}/include # for HP-UX and others
|
||||
# LIBS = -lXpm -lX11 -lm
|
||||
# LIBS = -L/usr/lib/X11R5 -lXpm -lX11 -lm # for HP-UX and others
|
||||
-LIBS = -lXpm -lXpm -lXpm -lX11 -lm # triple "-lXpm" because of Xpm error
|
||||
+LIBS = -L${X11BASE}/lib -lXpm -lX11 -lm # triple "-lXpm" because of Xpm error
|
||||
|
1
games/mirrormagic/pkg/COMMENT
Normal file
1
games/mirrormagic/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
A nice little puzzle game with color graphics and sound.
|
10
games/mirrormagic/pkg/DESCR
Normal file
10
games/mirrormagic/pkg/DESCR
Normal file
|
@ -0,0 +1,10 @@
|
|||
This is a nice little game with color graphics and sound for your
|
||||
Unix system with color X11. You need an 8-Bit color display or better.
|
||||
It is not recommended on black&white systems, and maybe not on gray
|
||||
scale systems.
|
||||
|
||||
It was first released as "Mirror Magic" in the year 1989 on the Amiga
|
||||
(with ports on other computer systems). As the Amiga is a bit outdated
|
||||
now, I decided to port it to Unix systems.
|
||||
|
||||
A game for Unix/X11 by Holger Schemel, (c) 1995 by Holger Schemel.
|
40
games/mirrormagic/pkg/PLIST
Normal file
40
games/mirrormagic/pkg/PLIST
Normal file
|
@ -0,0 +1,40 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 1998/06/12 13:43:19 frueauf Exp $
|
||||
bin/mirrormagic
|
||||
share/mirrormagic/RAY.level
|
||||
share/mirrormagic/graphics/DoubleRayDoor.xpm
|
||||
share/mirrormagic/graphics/DoubleRayDoorMaske.xbm
|
||||
share/mirrormagic/graphics/DoubleRayFont.xpm
|
||||
share/mirrormagic/graphics/DoubleRayFont2.xpm
|
||||
share/mirrormagic/graphics/DoubleRayFont2Maske.xbm
|
||||
share/mirrormagic/graphics/DoubleRayFontMaske.xbm
|
||||
share/mirrormagic/graphics/DoubleRayMaskeF.xbm
|
||||
share/mirrormagic/graphics/DoubleRayScreen.xpm
|
||||
share/mirrormagic/graphics/DoubleRayScreenMaske.xbm
|
||||
share/mirrormagic/graphics/mirrormagic_icon.xbm
|
||||
share/mirrormagic/graphics/mirrormagic_iconmask.xbm
|
||||
share/mirrormagic/sounds/amoebe.8svx
|
||||
share/mirrormagic/sounds/antigrav.8svx
|
||||
share/mirrormagic/sounds/autsch.8svx
|
||||
share/mirrormagic/sounds/bong.8svx
|
||||
share/mirrormagic/sounds/fuel.8svx
|
||||
share/mirrormagic/sounds/halloffame.8svx
|
||||
share/mirrormagic/sounds/holz.8svx
|
||||
share/mirrormagic/sounds/hui.8svx
|
||||
share/mirrormagic/sounds/kabumm.8svx
|
||||
share/mirrormagic/sounds/kink.8svx
|
||||
share/mirrormagic/sounds/kling.8svx
|
||||
share/mirrormagic/sounds/laser.8svx
|
||||
share/mirrormagic/sounds/oeffnen.8svx
|
||||
share/mirrormagic/sounds/quiek.8svx
|
||||
share/mirrormagic/sounds/rhythmloop.8svx
|
||||
share/mirrormagic/sounds/roaaar.8svx
|
||||
share/mirrormagic/sounds/sirr.8svx
|
||||
share/mirrormagic/sounds/slurp.8svx
|
||||
share/mirrormagic/sounds/tyger.8svx
|
||||
share/mirrormagic/sounds/voyager.8svx
|
||||
share/mirrormagic/sounds/warnton.8svx
|
||||
share/mirrormagic/sounds/whoosh.8svx
|
||||
@unexec rm -f %D/share/mirrormagic/RAY.*
|
||||
@dirrm share/mirrormagic/graphics
|
||||
@dirrm share/mirrormagic/sounds
|
||||
@dirrm share/mirrormagic
|
Loading…
Reference in a new issue