Update xmess to 0.104.
Changes from 0.103: - Everything from MAME 0.104 (http://x.mame.net/changes-mame.html) and MESS 0.104 (http://x.mame.net/changes-mess.html).
This commit is contained in:
parent
b7a3d4d3f0
commit
0ef42c4a35
3 changed files with 83 additions and 26 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.83 2006/02/05 23:09:05 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.84 2006/03/09 20:51:13 kristerw Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xmame-0.103
|
||||
PKGNAME= xmess-0.103
|
||||
PKGREVISION= 2
|
||||
DISTNAME= xmame-0.104
|
||||
PKGNAME= xmess-0.104
|
||||
CATEGORIES= emulators games x11
|
||||
MASTER_SITES= http://x.mame.net/download/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.44 2006/01/22 18:37:52 kristerw Exp $
|
||||
$NetBSD: distinfo,v 1.45 2006/03/09 20:51:13 kristerw Exp $
|
||||
|
||||
SHA1 (xmame-0.103.tar.bz2) = ba8f0cb5e6622cd5892b08072be88a5e11c37da3
|
||||
RMD160 (xmame-0.103.tar.bz2) = 84e029d4c24a37c77b5d0fbfb2ba9e7a0351159c
|
||||
Size (xmame-0.103.tar.bz2) = 16122491 bytes
|
||||
SHA1 (patch-aa) = b0052a1250e4b497653aae7d649dff2eac30c34e
|
||||
SHA1 (xmame-0.104.tar.bz2) = d974cdc5edbdc1591eb276dadfc6c35ec4d10e43
|
||||
RMD160 (xmame-0.104.tar.bz2) = 5eda9ca4fcfe5cd76adcd0ab78104fd74acceb77
|
||||
Size (xmame-0.104.tar.bz2) = 16249286 bytes
|
||||
SHA1 (patch-aa) = c35437dfd80adbb6dd1423dfb6afec1537375af6
|
||||
SHA1 (patch-ab) = dd21329b7e1a05bc7ea12b5a98a05d502dc36656
|
||||
SHA1 (patch-ac) = f4e0f614577924d19713e1862efa1e6d42e791c4
|
||||
SHA1 (patch-ad) = 087e162f8b05d894532e6d5091d8b0008c3f0e80
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.23 2006/01/22 18:37:52 kristerw Exp $
|
||||
$NetBSD: patch-aa,v 1.24 2006/03/09 20:51:13 kristerw Exp $
|
||||
|
||||
--- makefile.unix.orig 2006-01-22 11:08:05.000000000 +0100
|
||||
+++ makefile.unix 2006-01-22 11:11:39.000000000 +0100
|
||||
--- makefile.unix.orig 2006-03-09 19:41:47.000000000 +0100
|
||||
+++ makefile.unix 2006-03-09 19:46:38.000000000 +0100
|
||||
@@ -33,7 +33,7 @@
|
||||
###########################################################################
|
||||
|
||||
|
@ -38,7 +38,7 @@ $NetBSD: patch-aa,v 1.23 2006/01/22 18:37:52 kristerw Exp $
|
|||
|
||||
# GCC on x86 with some optimizations
|
||||
# CFLAGS = -O2 -mtune=i686 -fomit-frame-pointer -fstrength-reduce -ffast-math
|
||||
@@ -183,16 +183,16 @@
|
||||
@@ -183,13 +183,13 @@
|
||||
#########################################################################
|
||||
|
||||
# Check for C89 + GNU extensions compliance.
|
||||
|
@ -54,12 +54,8 @@ $NetBSD: patch-aa,v 1.23 2006/01/22 18:37:52 kristerw Exp $
|
|||
+ # CFLAGS += -Wno-unused
|
||||
|
||||
# Warn about declarations after statements.
|
||||
- CFLAGS += -Wdeclaration-after-statement
|
||||
+ # CFLAGS += -Wdeclaration-after-statement
|
||||
|
||||
# Don't warn about code that might break strict aliasing rules.
|
||||
# CFLAGS += -Wno-strict-aliasing
|
||||
@@ -328,7 +328,7 @@
|
||||
# CFLAGS += -Wdeclaration-after-statement
|
||||
@@ -328,16 +328,16 @@
|
||||
ifeq ($(CC),icc)
|
||||
|
||||
# Optimizations for the Intel compiler.
|
||||
|
@ -68,15 +64,68 @@ $NetBSD: patch-aa,v 1.23 2006/01/22 18:37:52 kristerw Exp $
|
|||
|
||||
else
|
||||
ifeq ($(CC),sun-forte)
|
||||
@@ -551,7 +551,7 @@
|
||||
###########################################################################
|
||||
#
|
||||
# sun-forte given above is just an artifice to get us into this section
|
||||
- CC = cc
|
||||
+ # CC = cc
|
||||
|
||||
# i386, GNU asm
|
||||
-MY_CPU = i386
|
||||
+# MY_CPU = i386
|
||||
# uncomment to set compiler defaults oriented for maximum performance
|
||||
- XOPT += -fast
|
||||
+ # XOPT += -fast
|
||||
|
||||
# i386, no asm -- needed for the Intel C++ compiler, which does not fully
|
||||
# understand GCC's inline assembly syntax, though you may still enable
|
||||
# Choose one optimization level;
|
||||
#XOPT += -xO0
|
||||
@@ -346,7 +346,7 @@
|
||||
#XOPT += -xO3
|
||||
# -xO4 and above automatically inline
|
||||
#XOPT += -xO4
|
||||
- XOPT += -xO5
|
||||
+ # XOPT += -xO5
|
||||
|
||||
# uncomment for code generation targeted to the local machine; this
|
||||
# supplies -xarch, -xcpu, -xtarget. It also seems to cause an annoying
|
||||
@@ -354,11 +354,11 @@
|
||||
# older hardware, which apparently can't be disabled. As an alternative,
|
||||
# the particular -xtarget for your system could be specified;
|
||||
# -xtarget=ultra2/2300
|
||||
- XTARGET += -native
|
||||
+ # XTARGET += -native
|
||||
#XTARGET += -xtarget=ultra2/2300
|
||||
|
||||
# uncomment to inline library math functions
|
||||
- EXTRA_OPTS += -xlibmil
|
||||
+ # EXTRA_OPTS += -xlibmil
|
||||
|
||||
######################################################
|
||||
# Additional options for parallelization optimizations
|
||||
@@ -374,7 +374,7 @@
|
||||
|
||||
# Sparc only, uncomment to do loop restructuring optimizations
|
||||
# and speculative prefetch for v8plusa and above
|
||||
- EXTRA_OPTS += -xdepend -xsafe=mem
|
||||
+ #EXTRA_OPTS += -xdepend -xsafe=mem
|
||||
|
||||
#################################################
|
||||
# Additional options for glx builds
|
||||
@@ -384,14 +384,14 @@
|
||||
# (libGLU dlopen() complains of missing name mangled symbols)
|
||||
# GLCFLAGS += -DSUN_FORTE_DLOPEN_LIBCRUN='\"libCrun.so.1\"'
|
||||
|
||||
- CFLAGS= $(XOPT) $(XTARGET) $(XPARALLEL) $(EXTRA_OPTS)
|
||||
- LDFLAGS=$(XOPT) $(XTARGET) $(XPARALLEL) $(EXTRA_OPTS)
|
||||
+ #CFLAGS= $(XOPT) $(XTARGET) $(XPARALLEL) $(EXTRA_OPTS)
|
||||
+ #LDFLAGS=$(XOPT) $(XTARGET) $(XPARALLEL) $(EXTRA_OPTS)
|
||||
|
||||
# uncomment for silence...
|
||||
- CFLAGS += -erroff
|
||||
+ #CFLAGS += -erroff
|
||||
# Tell xmame that we really are in fact elf. If not supplied, SHARED_PREFIX
|
||||
# is set causing dlopen()'s to fail.
|
||||
- CFLAGS += -D__ELF__
|
||||
+ #CFLAGS += -D__ELF__
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
@@ -589,7 +589,7 @@
|
||||
###########################################################################
|
||||
|
||||
|
@ -86,6 +135,15 @@ $NetBSD: patch-aa,v 1.23 2006/01/22 18:37:52 kristerw Exp $
|
|||
|
||||
# FreeBSD
|
||||
# ARCH = freebsd
|
||||
@@ -701,7 +701,7 @@
|
||||
# use SDL.
|
||||
|
||||
# X11 (including Glide & OpenGL if enabled below)
|
||||
-DISPLAY_METHOD = x11
|
||||
+# DISPLAY_METHOD = x11
|
||||
|
||||
# SDL library
|
||||
# DISPLAY_METHOD = SDL
|
||||
@@ -732,7 +732,7 @@
|
||||
X11_MITSHM = 1
|
||||
|
||||
|
|
Loading…
Reference in a new issue