Ensure that operator look up works with standard compliant compilers.

Redo patches to be relative to WRKDIR.
This commit is contained in:
joerg 2012-11-16 00:37:06 +00:00
parent f907e39e80
commit 0ef70b0ee0
46 changed files with 300 additions and 260 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.33 2012/10/03 11:24:39 asau Exp $
# $NetBSD: Makefile,v 1.34 2012/11/16 00:37:06 joerg Exp $
DISTNAME= estic-1.61
PKGREVISION= 2
@ -14,7 +14,7 @@ LICENSE= estic-license
EXTRACT_ONLY= estic-1.60-sources${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV:C/-.*//}
WRKSRC= ${WRKDIR}
USE_LANGUAGES= c c++
USE_TOOLS+= patch unzip
@ -23,6 +23,8 @@ BUILD_TARGET= depend all
ESTICPATCH= ${DISTNAME}-patch-from-1.60${EXTRACT_SUFX}
MAKE_FILE= make/freebsd-x.mak
BUILD_DIRS= ${WRKDIR}/${PKGNAME_NOREV:C/-.*//}
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS"
CPPFLAGS+= -DSOLARIS
@ -33,7 +35,7 @@ CPPFLAGS+= -DFREEBSD
INSTALLATION_DIRS= bin
post-extract:
cd ${WRKSRC} && \
cd ${BUILD_DIRS} && \
unzip -p ${DISTDIR}/${ESTICPATCH} \
| ${PATCH} -p0 ${PATCH_DIST_ARGS}
@ -41,12 +43,12 @@ pre-build:
cd ${WRKDIR}/spunk && ${BUILD_MAKE_CMD} depend lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xestic ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/estic.res ${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${BUILD_DIRS}/xestic ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${BUILD_DIRS}/estic.res ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/estic
${INSTALL_DATA} ${WRKSRC}/estic.doc ${DESTDIR}${PREFIX}/share/doc/estic
${INSTALL_DATA} ${BUILD_DIRS}/estic.doc ${DESTDIR}${PREFIX}/share/doc/estic
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/examples/estic
cd ${WRKSRC}/samples && \
cd ${BUILD_DIRS}/samples && \
${INSTALL_DATA} * ${DESTDIR}${PREFIX}/share/examples/estic
.include "../../x11/libX11/buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2012/02/16 16:47:57 hans Exp $
$NetBSD: distinfo,v 1.13 2012/11/16 00:37:06 joerg Exp $
SHA1 (estic-1.60-sources.zip) = ce66a6d52faaf6adba492bb3f74e49eab608d0c3
RMD160 (estic-1.60-sources.zip) = be071c72ab881c815dc9a0847f2b09914bdeb2ed
@ -6,38 +6,38 @@ Size (estic-1.60-sources.zip) = 892311 bytes
SHA1 (estic-1.61-patch-from-1.60.zip) = b58cf388e2eb60685402a84cc260d88dc7c1820f
RMD160 (estic-1.61-patch-from-1.60.zip) = d450161014f353892d72b5ddb87f9d6560ee8c1d
Size (estic-1.61-patch-from-1.60.zip) = 1017 bytes
SHA1 (patch-.._spunk_coll.cc) = 5500da1f5332475b5e07a2da53d6b7936a8b4f2d
SHA1 (patch-.._spunk_machine.h) = e6e14ff2f1ae0c053cdc007cace23e80cda693c1
SHA1 (patch-.._spunk_menuedit.h) = 1768a768c5782ba85a600cc79480ec88c52c4a18
SHA1 (patch-.._spunk_menuitem.h) = da14216e8e51eec825c7cedffbee9d60359dedf3
SHA1 (patch-.._spunk_str.cc) = 01ff453a244f9ac7f14273073635b2a7cfdcaa36
SHA1 (patch-.._spunk_xsrc_screen.cc) = 0ec1b7362fea28694cef83a118b3ec9e0ad52389
SHA1 (patch-aa) = ca4da0f9f231f4f48d9a001b03d3bcbf35efbc12
SHA1 (patch-ab) = 1ee3659e221e07796f4581bd191145c8cc6673a1
SHA1 (patch-ac) = 2dd445fc1b14bc58d361fed4d6e2366a060b5203
SHA1 (patch-ad) = b7287df75abc237859ee25ce04c5b3df4d338c37
SHA1 (patch-ae) = 29ce3dafba535a26aef00e53da05d51eb09617be
SHA1 (patch-af) = 7e24769f8ab5ca49e1a784b3aa964e3b994622ac
SHA1 (patch-ag) = 0bcc50298d0950cf5909eb770c5d1a29959991dd
SHA1 (patch-ah) = 4a5ce78d5d7173132c91ec5dbcf20b0484afe882
SHA1 (patch-ai) = d7fdcc29f357a9a8b0790e2491f577160d05db34
SHA1 (patch-aj) = afaa7e22e01fc698418fb6543fe8e7f81feab106
SHA1 (patch-ak) = 197a2dccb3433c8d48e2eb3b9a846e3992cd6b7c
SHA1 (patch-al) = 2d813b690b07e390f4ec6718ef6add7320800807
SHA1 (patch-am) = 497dc20fc2a6d5164fdc41100d840cfb202672a7
SHA1 (patch-an) = 087a21d344336e2190c3e76b16670551686cd7c0
SHA1 (patch-ao) = a6385f7d356d1422695a382b33db4fb150e14d7a
SHA1 (patch-ap) = 1aee1dead27df8b62ba560dad19fe083fe8d6204
SHA1 (patch-aq) = 7f5a947ae8ed36e3d41d92f639b3419273732335
SHA1 (patch-ar) = d9fbecdc0cd5aa04e8f3b4a89c1e3482566ec0a9
SHA1 (patch-as) = cbbd38095f9e14e6a8290e73a8f8aee083387b8f
SHA1 (patch-at) = 87ea33bc400397c5ee9f7aeedf7c8b409dc9dbe7
SHA1 (patch-au) = 0de3e83ee0fe9881dd68ed2b9ffb7511376da911
SHA1 (patch-av) = e9239931b98b0ba1444e426df4ae4df7e9aaca7d
SHA1 (patch-aw) = ed428001d0ffc2428a67182a22fa54a726ca103a
SHA1 (patch-ax) = 18f16c755f05d5899d13be239544366a1393d7d3
SHA1 (patch-ay) = 25ec057efcb071f83ab53ca7d7d2af22e9a2c93f
SHA1 (patch-az) = 661710c038aa502216c7cf5c7374515a43518a7f
SHA1 (patch-ba) = cced4632684abfe71b115ec0cc65bbd77a7d2770
SHA1 (patch-devstate.cc) = 653d7f34add30a554f31dc94aee532a2aae4db5d
SHA1 (patch-iclog.cc) = 670599dfb2abe3c17d67ddbf1be9850fa30e00db
SHA1 (patch-estic_devstate.cc) = c4f9230cb931ae8976972d93fe1ed08780b14b8a
SHA1 (patch-estic_estic.cc) = 1108d14c55f837aae1db6c45a927ef463b7e2b5c
SHA1 (patch-estic_icbaseed.cc) = 0540d8af7b6cc9a675ca7d004090fb988855fe1b
SHA1 (patch-estic_icdevs.cc) = 3f40ccfee8eb5b192b5b7cea97703d0157b9f0fe
SHA1 (patch-estic_iclog.cc) = 19590158f9936027db2916eb3c83795aed8b6f4c
SHA1 (patch-estic_icshort.cc) = b26cd4372b02b8e02eb952c2e7a2babcd3295890
SHA1 (patch-estic_make_freebsd-x.mak) = 932e4de40da0d6b3744aa2026f09b4d086a8caca
SHA1 (patch-spunk_check.cc) = 254f7eb114fb183b2a792ba32536cd7fe956845d
SHA1 (patch-spunk_check.h) = 274ecf50ab4ad31be5c92dad87bb597ccdd27281
SHA1 (patch-spunk_coll.cc) = 41fa8fe8842e600edc875113cf2674e18afc261d
SHA1 (patch-spunk_coll.h) = c454021ffc88fdfcc055cf9ffb1cf4647d2dad36
SHA1 (patch-spunk_filepath.h) = e5e70586884321b9cf2f29c6c19e5331d9e9585a
SHA1 (patch-spunk_filesys.h) = c3c69ce2ba9a0f8aa9299e6722d6bea50f71db62
SHA1 (patch-spunk_itemwin.h) = 5fa92f8e6f7583f7f8dcce6607b9be90170ec552
SHA1 (patch-spunk_machine.h) = c035b1102d634ca669e57952dddd5230df70b573
SHA1 (patch-spunk_make_freebsd-x.mak) = 7f83e101e15fb6c0cfdb2ad02d281f58844ad5b7
SHA1 (patch-spunk_menue.cc) = 3c258e145a09ce45ba189a40845c8885b2d837d0
SHA1 (patch-spunk_menuedit.h) = adc14742088e3811919799cf900eb27ddb1984ea
SHA1 (patch-spunk_menuitem.h) = b5934b3c71f6f55c0f7b40d71bd58ef87a77d138
SHA1 (patch-spunk_messages.txt) = 4cc4450ce860a1a907d87b8bcee3050df24477dc
SHA1 (patch-spunk_palette.h) = f8bd632f01af998ffcd7b469d4d7851c17321a27
SHA1 (patch-spunk_password.cc) = 6dbcb2565d0d36868601a26c37c1f22eeeca8231
SHA1 (patch-spunk_resitem.cc) = 0f9cf4e8aeede1ea979c0a245715f5fca8fa0b2e
SHA1 (patch-spunk_sercom.h) = fd54ae296f85085f1324a853db744b1d33c77673
SHA1 (patch-spunk_statdef.h) = 0d83c8ea6c498328df4b40cac862a5d32fc3ac2d
SHA1 (patch-spunk_str.cc) = cb249f5d1a85dba88d266e22aef748ad6dfde6f6
SHA1 (patch-spunk_str.h) = 590efb00bf37174abfc842c685040dad8408cece
SHA1 (patch-spunk_stream.cc) = d8e6f3de1952787d1f4146a4599aa8c683a0bbcf
SHA1 (patch-spunk_stream.h) = 8cf034d800f74da6b2747e9f7170f0ad80632a8e
SHA1 (patch-spunk_textstrm.cc) = cf55efefe96c21c41075e819f26912e4f845c3be
SHA1 (patch-spunk_unixsrc_delay.cc) = 51101ff8b395d1220b73e59ac7d6880e8608f104
SHA1 (patch-spunk_unixsrc_filesys.cc) = c12ce7c8d86f0d69d0a7547ce1ddf64ffbaa5145
SHA1 (patch-spunk_window.cc) = 1e88efe103749b1b18ea68494a1592f0b9ca8348
SHA1 (patch-spunk_xsrc_console.cc) = ea85bb4e8f91c763cb37b207df4368c38749b1c5
SHA1 (patch-spunk_xsrc_screen.cc) = 6ee01bd920471ed05bbee15991a83eea4bb6eef4

View file

@ -1,13 +0,0 @@
$NetBSD: patch-.._spunk_coll.cc,v 1.1 2011/11/27 19:36:09 joerg Exp $
--- ../spunk/coll.cc.orig 2011-11-27 02:13:15.000000000 +0000
+++ ../spunk/coll.cc
@@ -21,7 +21,7 @@
#include <stdlib.h>
#include <string.h>
-#include <iostream.h>
+#include <iostream>
#include "machine.h"
#include "check.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-.._spunk_menuedit.h,v 1.1 2012/02/16 16:47:58 hans Exp $
--- ../spunk/menuedit.h.orig 1996-11-07 18:06:48.000000000 +0100
+++ ../spunk/menuedit.h 2012-01-25 18:38:05.997403890 +0100
@@ -28,6 +28,7 @@
#include "datetime.h"
#include "charset.h"
+#undef CS
/*****************************************************************************/

View file

@ -1,12 +0,0 @@
$NetBSD: patch-.._spunk_str.cc,v 1.1 2012/02/16 16:47:58 hans Exp $
--- ../spunk/str.cc.orig 1996-12-01 11:23:50.000000000 +0100
+++ ../spunk/str.cc 2012-01-25 18:54:36.312130772 +0100
@@ -31,6 +31,7 @@
#include "stream.h"
#include "streamid.h"
+#undef CS
// Register class String

View file

@ -1,15 +0,0 @@
$NetBSD: patch-.._spunk_xsrc_screen.cc,v 1.1 2012/02/16 16:47:58 hans Exp $
--- ../spunk/xsrc/screen.cc.orig 1996-11-07 18:06:58.000000000 +0100
+++ ../spunk/xsrc/screen.cc 2012-01-25 18:43:41.244123272 +0100
@@ -21,6 +21,10 @@
#include <string.h>
+#ifdef __sun
+#include <alloca.h>
+#endif
+
#include "../cont.h"
#include "../winattr.h"
#include "../environ.h"

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ah,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
--- ../spunk/unixsrc/delay.cc.orig Thu Nov 7 18:06:58 1996
+++ ../spunk/unixsrc/delay.cc Sat Feb 10 18:38:34 2001
@@ -73,7 +73,7 @@
//
// The function returns the real time passed or just ms.
{
- const ChunkSize = 256;
+ const u32 ChunkSize = 256;
// Check the argument...
if (ms <= ChunkSize) {

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aj,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
--- ../spunk/xsrc/console.cc.orig Tue Feb 18 14:32:40 1997
+++ ../spunk/xsrc/console.cc Sat Feb 10 18:38:34 2001
@@ -1013,7 +1013,7 @@
void ScrSetMode (unsigned Mode)
// Set a screen mode
{
- unsigned XSize, YSize;
+ int XSize, YSize;
_ColorMode NewColorMode = ColorMode;
// Check the new dimensions

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ax,v 1.1 2003/12/28 21:53:45 tron Exp $
--- ../spunk/check.cc.orig 1996-11-07 18:06:46.000000000 +0100
+++ ../spunk/check.cc 2003-12-28 22:48:02.000000000 +0100
@@ -50,9 +50,6 @@
// The fail vector
-#ifdef __GNUC__
-volatile
-#endif
void (*CheckFailed) (const char*, const char* Cond,
int Code, const char* File, int Line) = _CheckFailed;

View file

@ -1,12 +0,0 @@
$NetBSD: patch-devstate.cc,v 1.1 2012/02/16 16:47:58 hans Exp $
--- devstate.cc.orig 1997-01-31 03:57:14.000000000 +0100
+++ devstate.cc 2012-01-25 18:49:00.031935640 +0100
@@ -38,6 +38,7 @@
#include "iccom.h"
#include "iclog.h"
+#undef DS
/*****************************************************************************/

View file

@ -0,0 +1,12 @@
$NetBSD: patch-estic_devstate.cc,v 1.1 2012/11/16 00:37:45 joerg Exp $
--- estic/devstate.cc.orig 1997-01-31 03:57:14.000000000 +0000
+++ estic/devstate.cc
@@ -38,6 +38,7 @@
#include "iccom.h"
#include "iclog.h"
+#undef DS
/*****************************************************************************/

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.2 2012/02/16 16:47:58 hans Exp $
$NetBSD: patch-estic_estic.cc,v 1.1 2012/11/16 00:37:45 joerg Exp $
--- estic.cc.orig Wed Mar 5 21:20:42 1997
+++ estic.cc Sat Feb 10 18:38:34 2001
--- estic/estic.cc.orig 1997-03-05 21:20:42.000000000 +0000
+++ estic/estic.cc
@@ -1,5 +1,4 @@
-/*****************************************************************************/
-/* */

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-estic_icbaseed.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- icbaseed.cc.orig Sat Nov 30 01:00:44 1996
+++ icbaseed.cc Sat Feb 10 18:38:34 2001
@@ -451,26 +451,26 @@
--- estic/icbaseed.cc.orig 1996-11-30 01:00:44.000000000 +0000
+++ estic/icbaseed.cc
@@ -451,26 +451,26 @@ void EditBaseConfig (IstecConfig& Config
// otherwise, Changed is left untouched.
{
// ID's of menue items for EditBaseConfig

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-estic_icdevs.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- icdevs.cc.orig Wed Mar 5 21:48:44 1997
+++ icdevs.cc Sat Feb 10 18:38:34 2001
@@ -157,8 +157,8 @@
--- estic/icdevs.cc.orig 1997-03-05 21:48:44.000000000 +0000
+++ estic/icdevs.cc
@@ -157,8 +157,8 @@ const String& DevListBox::ServiceName (u
String DevListBox::RerouteName (const String& Num)
// Map the reroute capability to a string with fixed length
{
@ -13,7 +13,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
String Res (PadLength);
if (Num.IsEmpty ()) {
@@ -269,9 +269,9 @@
@@ -269,9 +269,9 @@ static int ExtRerouteOk (const String& P
static void EditExtReroute (const Point& Pos, IstecDevConfig& Config)
// Edit the extended reroute capabilities of FW 2.0 in a separate menu
{
@ -26,7 +26,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
// Load the menu
Menue* M = (Menue*) LoadResource ("@ICDEVS.RerouteMenue");
@@ -407,38 +407,38 @@
@@ -407,38 +407,38 @@ static void EditDevConfig (IstecDevConfi
static const String StgPosName = "EditDevConfig.ConfigMenue.Position";
// Menue constants

View file

@ -0,0 +1,12 @@
$NetBSD: patch-estic_iclog.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- estic/iclog.cc.orig 2012-11-15 10:44:05.000000000 +0000
+++ estic/iclog.cc
@@ -31,6 +31,7 @@
#include "iccli.h"
#include "iclog.h"
+#undef DS
/*****************************************************************************/

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ae,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-estic_icshort.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- icshort.cc.orig Fri Jan 31 04:29:12 1997
+++ icshort.cc Sat Feb 10 18:38:34 2001
@@ -574,17 +574,17 @@
--- estic/icshort.cc.orig 2012-11-15 10:44:05.000000000 +0000
+++ estic/icshort.cc
@@ -578,17 +578,17 @@ void ShortNumberListBox::Print (int Inde
// Item numbers for the short number edit menu

View file

@ -1,8 +1,8 @@
$NetBSD: patch-af,v 1.2 2012/02/16 16:47:58 hans Exp $
$NetBSD: patch-estic_make_freebsd-x.mak,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- make/freebsd-x.mak.orig Fri Jan 31 03:57:24 1997
+++ make/freebsd-x.mak Sat Feb 10 18:38:34 2001
@@ -27,22 +27,20 @@
--- estic/make/freebsd-x.mak.orig 1997-01-31 03:57:24.000000000 +0000
+++ estic/make/freebsd-x.mak
@@ -27,22 +27,20 @@ AS = gas
AR = ar
LD = ld
ZIP = zip
@ -28,7 +28,7 @@ $NetBSD: patch-af,v 1.2 2012/02/16 16:47:58 hans Exp $
# ------------------------------------------------------------------------------
# All OBJ files
@@ -71,18 +69,19 @@
@@ -71,18 +69,19 @@ OBJS = callwin.o \
icintcon.o \
iclog.o \
icmsgwin.o \
@ -51,7 +51,7 @@ $NetBSD: patch-af,v 1.2 2012/02/16 16:47:58 hans Exp $
# ------------------------------------------------------------------------------
@@ -90,7 +89,7 @@
@@ -90,7 +89,7 @@ xestic: $(LIB) $(OBJS)
depend dep:
@echo "Creating dependency information"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-iclog.cc,v 1.1 2012/02/16 16:47:58 hans Exp $
--- iclog.cc.orig 2012-01-25 18:32:44.447476635 +0100
+++ iclog.cc 2012-01-25 18:50:27.905634296 +0100
@@ -31,6 +31,7 @@
#include "iccli.h"
#include "iclog.h"
+#undef DS
/*****************************************************************************/

View file

@ -0,0 +1,14 @@
$NetBSD: patch-spunk_check.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- spunk/check.cc.orig 1996-11-07 18:06:46.000000000 +0000
+++ spunk/check.cc
@@ -50,9 +50,6 @@ static void _CheckFailed (const char* Ms
// The fail vector
-#ifdef __GNUC__
-volatile
-#endif
void (*CheckFailed) (const char*, const char* Cond,
int Code, const char* File, int Line) = _CheckFailed;

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ay,v 1.1 2003/12/28 21:53:45 tron Exp $
$NetBSD: patch-spunk_check.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/check.h.orig 1996-11-07 18:06:46.000000000 +0100
+++ ../spunk/check.h 2003-12-28 22:50:57.000000000 +0100
@@ -38,9 +38,6 @@
--- spunk/check.h.orig 1996-11-07 18:06:46.000000000 +0000
+++ spunk/check.h
@@ -38,9 +38,6 @@ extern const char* _MsgCheckFailed;
extern

View file

@ -0,0 +1,13 @@
$NetBSD: patch-spunk_coll.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- spunk/coll.cc.orig 1996-11-30 00:40:58.000000000 +0000
+++ spunk/coll.cc
@@ -21,7 +21,7 @@
#include <stdlib.h>
#include <string.h>
-#include <iostream.h>
+#include <iostream>
#include "machine.h"
#include "check.h"

View file

@ -1,7 +1,7 @@
$NetBSD: patch-am,v 1.3 2011/11/27 19:36:09 joerg Exp $
$NetBSD: patch-spunk_coll.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/coll.h.orig 1996-12-18 23:42:14.000000000 +0000
+++ ../spunk/coll.h
--- spunk/coll.h.orig 1996-12-18 23:42:14.000000000 +0000
+++ spunk/coll.h
@@ -24,7 +24,7 @@
@ -41,6 +41,15 @@ $NetBSD: patch-am,v 1.3 2011/11/27 19:36:09 joerg Exp $
// Item not found
return -1;
@@ -512,7 +512,7 @@ void SortedCollection<T, U>::Insert (T*
}
// Index points to the correct position, insert item
- AtInsert (Index, Item);
+ this->AtInsert (Index, Item);
}
@@ -522,7 +522,7 @@ int SortedCollection<T, U>::Search (cons
{
// do a binary search

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aq,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_filepath.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/filepath.h.orig Thu Nov 14 00:12:02 1996
+++ ../spunk/filepath.h Sat Feb 10 18:38:35 2001
@@ -88,14 +88,6 @@
--- spunk/filepath.h.orig 1996-11-14 00:12:02.000000000 +0000
+++ spunk/filepath.h
@@ -88,14 +88,6 @@ int FHasWildcards (const String& Pathnam
// Return 1 if the given path contains one of the wildcard characters '*', '?'
// or '[]', return zero otherwise.

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ap,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_filesys.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/filesys.h.orig Thu Nov 7 18:06:48 1996
+++ ../spunk/filesys.h Sat Feb 10 18:38:35 2001
--- spunk/filesys.h.orig 1996-11-07 18:06:48.000000000 +0000
+++ spunk/filesys.h
@@ -44,10 +44,10 @@
extern const char FileSysPathSep; // Path separator

View file

@ -1,9 +1,7 @@
$NetBSD: patch-az,v 1.1 2008/01/06 18:39:38 rillig Exp $
$NetBSD: patch-spunk_itemwin.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
See mk/help/c++.help.
--- ../spunk/itemwin.h.orig 1996-11-07 18:06:48.000000000 +0000
+++ ../spunk/itemwin.h 2008-01-06 18:52:26.000000000 +0000
--- spunk/itemwin.h.orig 1996-11-07 18:06:48.000000000 +0000
+++ spunk/itemwin.h
@@ -55,6 +55,8 @@ const u16 ifNoSub = 0x0010
/*****************************************************************************/

View file

@ -1,7 +1,7 @@
$NetBSD: patch-.._spunk_machine.h,v 1.2 2012/02/16 16:47:58 hans Exp $
$NetBSD: patch-spunk_machine.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/machine.h.orig 2011-11-27 02:08:02.000000000 +0000
+++ ../spunk/machine.h
--- spunk/machine.h.orig 1997-02-18 14:41:50.000000000 +0000
+++ spunk/machine.h
@@ -238,7 +238,7 @@ typedef unsigned u32;
# define CPU_LITTLE_ENDIAN
#elif (BYTE_ORDER == BIG_ENDIAN)

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ag,v 1.5 2012/02/16 16:47:58 hans Exp $
$NetBSD: patch-spunk_make_freebsd-x.mak,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/make/freebsd-x.mak.orig 1996-11-24 22:33:26.000000000 +0100
+++ ../spunk/make/freebsd-x.mak
--- spunk/make/freebsd-x.mak.orig 1996-11-24 22:33:26.000000000 +0000
+++ spunk/make/freebsd-x.mak
@@ -27,10 +27,9 @@ AS = gas
AR = ar
LD = ld

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ar,v 1.2 2012/02/16 16:47:58 hans Exp $
$NetBSD: patch-spunk_menue.cc,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- ../spunk/menue.cc.orig Sun Jan 26 18:17:32 1997
+++ ../spunk/menue.cc Sat Feb 10 18:38:35 2001
--- spunk/menue.cc.orig 1997-01-26 18:17:32.000000000 +0000
+++ spunk/menue.cc
@@ -26,6 +26,10 @@
#include <stdlib.h>
#endif

View file

@ -0,0 +1,12 @@
$NetBSD: patch-spunk_menuedit.h,v 1.1 2012/11/16 00:37:46 joerg Exp $
--- spunk/menuedit.h.orig 1996-11-07 18:06:48.000000000 +0000
+++ spunk/menuedit.h
@@ -28,6 +28,7 @@
#include "datetime.h"
#include "charset.h"
+#undef CS
/*****************************************************************************/

View file

@ -1,7 +1,7 @@
$NetBSD: patch-.._spunk_menuitem.h,v 1.1 2012/02/16 16:47:58 hans Exp $
$NetBSD: patch-spunk_menuitem.h,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/menuitem.h.orig 1996-12-10 14:41:04.000000000 +0100
+++ ../spunk/menuitem.h 2012-01-25 18:39:54.872853784 +0100
--- spunk/menuitem.h.orig 1996-12-10 14:41:04.000000000 +0000
+++ spunk/menuitem.h
@@ -27,7 +27,7 @@
#include "datetime.h"
#include "charset.h"

View file

@ -1,7 +1,7 @@
$NetBSD: patch-as,v 1.1.1.1 2001/02/10 18:34:25 tron Exp $
$NetBSD: patch-spunk_messages.txt,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/messages.txt.orig Thu Nov 7 18:06:48 1996
+++ ../spunk/messages.txt Sat Feb 10 19:00:19 2001
--- spunk/messages.txt.orig 1996-11-07 18:06:48.000000000 +0000
+++ spunk/messages.txt
@@ -6,7 +6,7 @@
; \n newline, Zeilenumbruch in einem Menue
; \c center, Zeile zentrieren (Textfenster)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-al,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_palette.h,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/palette.h.orig Thu Nov 7 18:06:48 1996
+++ ../spunk/palette.h Sat Feb 10 18:38:34 2001
@@ -40,19 +40,19 @@
--- spunk/palette.h.orig 1996-11-07 18:06:48.000000000 +0000
+++ spunk/palette.h
@@ -40,19 +40,19 @@ extern class Palette* Pal;
// Indices into the palette arrays

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ac,v 1.2 2001/10/14 17:19:58 tron Exp $
$NetBSD: patch-spunk_password.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/password.cc.orig Thu Nov 7 18:06:48 1996
+++ ../spunk/password.cc Sun Oct 14 19:09:32 2001
@@ -525,14 +525,14 @@
--- spunk/password.cc.orig 1996-11-07 18:06:48.000000000 +0000
+++ spunk/password.cc
@@ -525,14 +525,14 @@ LINK (PasswordColl, ID_PasswordColl);

View file

@ -1,8 +1,8 @@
$NetBSD: patch-at,v 1.1.1.1 2001/02/10 18:34:25 tron Exp $
$NetBSD: patch-spunk_resitem.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/resitem.cc.orig Fri Feb 21 12:05:30 1997
+++ ../spunk/resitem.cc Sat Feb 10 19:08:38 2001
@@ -1539,16 +1539,16 @@
--- spunk/resitem.cc.orig 1997-02-21 12:05:30.000000000 +0000
+++ spunk/resitem.cc
@@ -1539,16 +1539,16 @@ void ResEditApp::ItemMenue (WindowItem*
// Data edit menue
{
// Menue IDs
@ -29,7 +29,7 @@ $NetBSD: patch-at,v 1.1.1.1 2001/02/10 18:34:25 tron Exp $
// Load the menue from the resource
Menue* M = (Menue*) LoadResource ("@RESITEM.ItemDataMenue");
@@ -1785,13 +1785,13 @@
@@ -1785,13 +1785,13 @@ void ResEditApp::ChangeLimits (WindowIte
void ResEditApp::ChangeCharset (WindowItem* Item)
{

View file

@ -1,7 +1,7 @@
$NetBSD: patch-an,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_sercom.h,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/sercom.h.orig Thu Nov 7 18:06:52 1996
+++ ../spunk/sercom.h Sat Feb 10 18:38:35 2001
--- spunk/sercom.h.orig 1996-11-07 18:06:52.000000000 +0000
+++ spunk/sercom.h
@@ -43,29 +43,29 @@

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ao,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_statdef.h,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/statdef.h.orig Thu Nov 7 18:06:52 1996
+++ ../spunk/statdef.h Sat Feb 10 18:38:35 2001
--- spunk/statdef.h.orig 1996-11-07 18:06:52.000000000 +0000
+++ spunk/statdef.h
@@ -33,120 +33,6 @@

View file

@ -0,0 +1,12 @@
$NetBSD: patch-spunk_str.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- spunk/str.cc.orig 1996-12-01 11:23:50.000000000 +0000
+++ spunk/str.cc
@@ -31,6 +31,7 @@
#include "stream.h"
#include "streamid.h"
+#undef CS
// Register class String

View file

@ -1,9 +1,7 @@
$NetBSD: patch-ba,v 1.1 2008/01/06 18:39:39 rillig Exp $
$NetBSD: patch-spunk_str.h,v 1.1 2012/11/16 00:37:47 joerg Exp $
See mk/help/c++.help.
--- ../spunk/str.h.orig 1996-12-18 13:18:50.000000000 +0000
+++ ../spunk/str.h 2008-01-06 19:26:53.000000000 +0000
--- spunk/str.h.orig 1996-12-18 13:18:50.000000000 +0000
+++ spunk/str.h
@@ -91,6 +91,13 @@ extern const class String EmptyString;
// Note: This string class may not work with strings greater than INT_MAX or
// 0xFFFF, whichever is less

View file

@ -1,8 +1,8 @@
$NetBSD: patch-au,v 1.1 2001/10/14 17:19:59 tron Exp $
$NetBSD: patch-spunk_stream.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/stream.cc.orig Wed Dec 18 13:09:02 1996
+++ ../spunk/stream.cc Sun Oct 14 19:12:10 2001
@@ -347,7 +347,7 @@
--- spunk/stream.cc.orig 1996-12-18 13:09:02.000000000 +0000
+++ spunk/stream.cc
@@ -347,7 +347,7 @@ void Stream::Write (const void*, size_t)
void Stream::CopyFrom (Stream& S, size_t Count)
{

View file

@ -1,8 +1,41 @@
$NetBSD: patch-ak,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_stream.h,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/stream.h.orig Thu Nov 7 18:06:52 1996
+++ ../spunk/stream.h Sat Feb 10 18:38:34 2001
@@ -50,19 +50,19 @@
--- spunk/stream.h.orig 1996-11-07 18:06:52.000000000 +0000
+++ spunk/stream.h
@@ -44,25 +44,52 @@
#include <stdio.h>
#include <string.h>
+#include "machine.h"
+
+class Stream;
+
+Stream& operator << (Stream&, char);
+Stream& operator << (Stream&, unsigned char);
+Stream& operator << (Stream&, signed char);
+Stream& operator << (Stream&, i16);
+Stream& operator << (Stream&, u16);
+Stream& operator << (Stream&, i32);
+Stream& operator << (Stream&, u32);
+Stream& operator << (Stream&, float);
+Stream& operator << (Stream&, double);
+Stream& operator << (Stream&, char*);
+
+Stream& operator >> (Stream&, char&);
+Stream& operator >> (Stream&, unsigned char&);
+Stream& operator >> (Stream&, signed char&);
+Stream& operator >> (Stream&, i16&);
+Stream& operator >> (Stream&, u16&);
+Stream& operator >> (Stream&, i32&);
+Stream& operator >> (Stream&, u32&);
+Stream& operator >> (Stream&, float&);
+Stream& operator >> (Stream&, double&);
+Stream& operator >> (Stream&, char*);
+
+
#include "strmable.h"
#include "coll.h"
#include "str.h"

View file

@ -1,8 +1,8 @@
$NetBSD: patch-av,v 1.1 2001/10/14 17:19:59 tron Exp $
$NetBSD: patch-spunk_textstrm.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/textstrm.cc.orig Thu Nov 7 18:06:52 1996
+++ ../spunk/textstrm.cc Sun Oct 14 19:14:11 2001
@@ -66,8 +66,8 @@
--- spunk/textstrm.cc.orig 1996-11-07 18:06:52.000000000 +0000
+++ spunk/textstrm.cc
@@ -66,8 +66,8 @@ void TextFileStream::MakeLineIndex (int
// LineLen is the estimated length of a line in the file used for
// estimating the size of the buffer.
{

View file

@ -0,0 +1,13 @@
$NetBSD: patch-spunk_unixsrc_delay.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- spunk/unixsrc/delay.cc.orig 1996-11-07 18:06:58.000000000 +0000
+++ spunk/unixsrc/delay.cc
@@ -73,7 +73,7 @@ u32 Delay (u32 ms)
//
// The function returns the real time passed or just ms.
{
- const ChunkSize = 256;
+ const u32 ChunkSize = 256;
// Check the argument...
if (ms <= ChunkSize) {

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ai,v 1.1.1.1 2001/02/10 18:34:23 tron Exp $
$NetBSD: patch-spunk_unixsrc_filesys.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/unixsrc/filesys.cc.orig Thu Nov 7 18:06:58 1996
+++ ../spunk/unixsrc/filesys.cc Sat Feb 10 18:38:34 2001
--- spunk/unixsrc/filesys.cc.orig 1996-11-07 18:06:58.000000000 +0000
+++ spunk/unixsrc/filesys.cc
@@ -42,10 +42,10 @@
extern const char FileSysPathSep = '/'; // Path separator

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aw,v 1.1 2001/10/14 17:19:59 tron Exp $
$NetBSD: patch-spunk_window.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- ../spunk/window.cc.orig Sun Jan 26 18:17:38 1997
+++ ../spunk/window.cc Sun Oct 14 19:15:25 2001
@@ -1432,7 +1432,7 @@
--- spunk/window.cc.orig 1997-01-26 18:17:38.000000000 +0000
+++ spunk/window.cc
@@ -1432,7 +1432,7 @@ void Window::Write (int X, int Y, const
// Write a string to the inner window. Note: Attr is an index, not a real
// attribute !
{
@ -11,7 +11,7 @@ $NetBSD: patch-aw,v 1.1 2001/10/14 17:19:59 tron Exp $
u16 Buf [256];
// Check if the given string is empty
@@ -1554,7 +1554,7 @@
@@ -1554,7 +1554,7 @@ void Window::CWrite (int X, int Y, const
// Write a string to the inner window. Note: Attr is an index, not a real
// attribute !
{

View file

@ -0,0 +1,13 @@
$NetBSD: patch-spunk_xsrc_console.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- spunk/xsrc/console.cc.orig 1997-02-18 14:32:40.000000000 +0000
+++ spunk/xsrc/console.cc
@@ -1013,7 +1013,7 @@ void ScrSetCursorPos (unsigned X, unsign
void ScrSetMode (unsigned Mode)
// Set a screen mode
{
- unsigned XSize, YSize;
+ int XSize, YSize;
_ColorMode NewColorMode = ColorMode;
// Check the new dimensions

View file

@ -0,0 +1,15 @@
$NetBSD: patch-spunk_xsrc_screen.cc,v 1.1 2012/11/16 00:37:47 joerg Exp $
--- spunk/xsrc/screen.cc.orig 1996-11-07 18:06:58.000000000 +0000
+++ spunk/xsrc/screen.cc
@@ -21,6 +21,10 @@
#include <string.h>
+#ifdef __sun
+#include <alloca.h>
+#endif
+
#include "../cont.h"
#include "../winattr.h"
#include "../environ.h"