Remove libac3 -- newer version in audio/liba52.
This commit is contained in:
parent
e29ce0b4a8
commit
0f09daa236
7 changed files with 1 additions and 99 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.337 2006/10/23 23:59:56 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.338 2006/10/24 00:00:47 wiz Exp $
|
||||
#
|
||||
|
||||
COMMENT= Audio tools
|
||||
|
@ -136,7 +136,6 @@ SUBDIR+= kmp
|
|||
SUBDIR+= ladspa
|
||||
SUBDIR+= lame
|
||||
SUBDIR+= liba52
|
||||
SUBDIR+= libac3
|
||||
SUBDIR+= libao
|
||||
SUBDIR+= libao-arts
|
||||
SUBDIR+= libao-esound
|
||||
|
|
|
@ -1,2 +0,0 @@
|
|||
libac3 is a AC-3 stream decoder library written by Aaron Holtzman. This
|
||||
software is distributed under the Gnu Public License.
|
|
@ -1,25 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.8 2006/10/04 20:44:19 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ac3dec-0.6.1
|
||||
PKGNAME= ${DISTNAME:S/ac3dec/libac3/}
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://liba52.sourceforge.net/files/
|
||||
|
||||
MAINTAINER= rh@NetBSD.org
|
||||
HOMEPAGE= http://liba52.sourceforge.net/
|
||||
# obsolete -- remove in favor of liba52?
|
||||
COMMENT= AC3 audio (as used on DVDs) decoding library
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
INSTALLATION_DIRS= include lib
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC}/libac3 && ${MAKE}
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libac3/ac3.h ${PREFIX}/include
|
||||
${INSTALL_DATA} ${WRKSRC}/libac3/libac3.a ${PREFIX}/lib
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,3 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/11/01 00:17:00 zuntum Exp $
|
||||
include/ac3.h
|
||||
lib/libac3.a
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/11/11 17:48:25 joerg Exp $
|
||||
|
||||
SHA1 (ac3dec-0.6.1.tar.gz) = 5c3315a58425be508bfbf076054e636451b685fd
|
||||
RMD160 (ac3dec-0.6.1.tar.gz) = 1c61ab0f203a86bdf885d7a1dcfb43a224c84400
|
||||
Size (ac3dec-0.6.1.tar.gz) = 84978 bytes
|
||||
SHA1 (patch-aa) = 957a19c7437205dfb901d22734d19e564f4375b9
|
||||
SHA1 (patch-ab) = f436a56f91d3aa67e0e3a4b8df1d3745e92da14f
|
|
@ -1,38 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2005/11/11 17:48:25 joerg Exp $
|
||||
|
||||
--- configure.orig 2000-03-30 00:51:49.000000000 +0000
|
||||
+++ configure
|
||||
@@ -1254,32 +1254,12 @@ fi
|
||||
|
||||
case "$host" in
|
||||
*-linux*) rm -f output.c; ln -s output_linux.c output.c;;
|
||||
-*-openbsd*|*-freebsd*) rm -f output.c; ln -s output_linux.c output.c;;
|
||||
+*-openbsd*|*-freebsd*|*-netbsd*|*-dragonfly*) rm -f output.c; ln -s output_linux.c output.c;;
|
||||
*-irix*) rm -f output.c; ln -s output_irix.c output.c;;
|
||||
*-solaris*) rm -f output.c; ln -s output_solaris.c output.c;;
|
||||
*) echo "$host is not currently supported by ac3dec"; exit 1;;
|
||||
esac
|
||||
|
||||
-case "$host" in
|
||||
-i?86-*) cat >> confdefs.h <<\EOF
|
||||
-#define __i386__ 1
|
||||
-EOF
|
||||
-;;
|
||||
-alpha*-*) cat >> confdefs.h <<\EOF
|
||||
-#define __alpha__ 1
|
||||
-EOF
|
||||
-;;
|
||||
-sparc-*) cat >> confdefs.h <<\EOF
|
||||
-#define __sparc__ 1
|
||||
-EOF
|
||||
-;;
|
||||
-ppc-*) cat >> confdefs.h <<\EOF
|
||||
-#define __ppc__ 1
|
||||
-EOF
|
||||
-;;
|
||||
-*) echo "$host is not currently supported by ac3dec"; exit 1;;
|
||||
-esac
|
||||
-
|
||||
trap '' 1 2 15
|
||||
cat > confcache <<\EOF
|
||||
# This file is a shell script that caches the results of configure
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2005/11/11 17:48:25 joerg Exp $
|
||||
|
||||
--- libac3/bitstream.c.orig 2000-03-30 00:51:24.000000000 +0000
|
||||
+++ libac3/bitstream.c
|
||||
@@ -23,6 +23,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
|
||||
#include "ac3.h"
|
||||
#include "ac3_internal.h"
|
||||
@@ -90,7 +91,8 @@ bitstream_buffer_frame(uint_32 frame_siz
|
||||
static inline void
|
||||
bitstream_fill_current()
|
||||
{
|
||||
- current_word = *((uint_32*)buffer_start)++;
|
||||
+ current_word = *(uint_32*)buffer_start;
|
||||
+ buffer_start += sizeof(uint_32);
|
||||
current_word = swab32(current_word);
|
||||
}
|
||||
|
Loading…
Reference in a new issue