Initial import of new "plotmtv" package:
Multipurpose X11 plotting program
This commit is contained in:
parent
43fc1ac0f0
commit
0f23b11e6f
9 changed files with 149 additions and 0 deletions
31
graphics/plotmtv/Makefile
Normal file
31
graphics/plotmtv/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
|
||||
DISTNAME= Plotmtv1.4.1
|
||||
PKGNAME= plotmtv-1.4.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB:=applications/}
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
||||
MAINTAINER= jtb@netbsd.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/Plotmtv1.4.1
|
||||
|
||||
USE_IMAKE= YES
|
||||
USE_X11_BASE= YES
|
||||
|
||||
pre-build:
|
||||
@(cd ${WRKDIR}/Plotmtv1.4.1; ${MV} -f Docs/plotmtv.man Plot/;)
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/plotmtv
|
||||
@(cd ${WRKDIR}/Plotmtv1.4.1/Tests/; \
|
||||
for i in *.mtv; \
|
||||
do \
|
||||
${INSTALL_DATA} $$i ${PREFIX}/share/examples/plotmtv; \
|
||||
done; \
|
||||
for i in run.sh run.csh; \
|
||||
do \
|
||||
${INSTALL_SCRIPT} $$i ${PREFIX}/share/examples/plotmtv; \
|
||||
done;)
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
graphics/plotmtv/files/md5
Normal file
3
graphics/plotmtv/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
|
||||
MD5 (Plotmtv1.4.1.tar.Z) = 71e8c04c1026c423bbed070c2a2f77ff
|
5
graphics/plotmtv/files/patch-sum
Normal file
5
graphics/plotmtv/files/patch-sum
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
|
||||
MD5 (patch-aa) = 4b99b911dd43b2d0eca3550df38efdf5
|
||||
MD5 (patch-ab) = 93c3dc2ef7d4c6e62fcf30ec57ee56a4
|
||||
MD5 (patch-ac) = 290d7a65e3476f9859c80197294630a5
|
11
graphics/plotmtv/patches/patch-aa
Normal file
11
graphics/plotmtv/patches/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
|
||||
*** Imakefile.orig
|
||||
--- Imakefile
|
||||
***************
|
||||
*** 22,23 ****
|
||||
! CDEBUGFLAGS = -g
|
||||
! DEFINES = -DPRINTER_NAME=\"hpps\" -DPRINTER_CMD=\"lpr\ -h\"
|
||||
--- 22,23 ----
|
||||
! CDEBUGFLAGS = -O3
|
||||
! DEFINES = -DPRINTER_NAME=\"S\" -DPRINTER_CMD=\"lpr\ -h\"
|
25
graphics/plotmtv/patches/patch-ab
Normal file
25
graphics/plotmtv/patches/patch-ab
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
|
||||
--- Tests/run.csh.orig
|
||||
+++ Tests/run.csh
|
||||
@@ -8,16 +8,16 @@
|
||||
#
|
||||
|
||||
# program location
|
||||
-set PLOTMTV="../Bin/plotmtv"
|
||||
+set PLOTMTV="plotmtv"
|
||||
|
||||
# Use this to test color postscript
|
||||
-#set PLOTMTV="../Bin/plotmtv -scale 0.5 -colorps"
|
||||
+#set PLOTMTV="plotmtv -scale 0.5 -colorps"
|
||||
|
||||
# Use this to test 3D postscript and the scale factor
|
||||
-#set PLOTMTV="../Bin/plotmtv -3D -scale 0.8"
|
||||
+#set PLOTMTV="plotmtv -3D -scale 0.8"
|
||||
|
||||
# Use this to generate lots of postscript files (without prompting)
|
||||
-#set PLOTMTV="../Bin/plotmtv -noxplot -print"
|
||||
+#set PLOTMTV="plotmtv -noxplot -print"
|
||||
|
||||
alias run_script '$PLOTMTV $DATAFILE'
|
||||
alias run_3d_script '$PLOTMTV -3d $DATAFILE'
|
25
graphics/plotmtv/patches/patch-ac
Normal file
25
graphics/plotmtv/patches/patch-ac
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
|
||||
--- Tests/run.sh.orig
|
||||
+++ Tests/run.sh
|
||||
@@ -6,16 +6,16 @@
|
||||
#
|
||||
|
||||
# program location
|
||||
-PLOTMTV="../Bin/plotmtv"
|
||||
+PLOTMTV="plotmtv"
|
||||
|
||||
# Use this to test color postscript
|
||||
-#PLOTMTV="../Bin/plotmtv -scale 0.5 -colorps"
|
||||
+#PLOTMTV="plotmtv -scale 0.5 -colorps"
|
||||
|
||||
# Use this to test 3D postscript and the scale factor
|
||||
-#PLOTMTV="../Bin/plotmtv -3D -scale 0.8"
|
||||
+#PLOTMTV="plotmtv -3D -scale 0.8"
|
||||
|
||||
# Use this to generate lots of postscript files (without prompting)
|
||||
-#PLOTMTV="../Bin/plotmtv -noxplot -print"
|
||||
+#PLOTMTV="plotmtv -noxplot -print"
|
||||
|
||||
# do each test-case one-by-one, prompting for input
|
||||
ALLPLOT=0
|
1
graphics/plotmtv/pkg/COMMENT
Normal file
1
graphics/plotmtv/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Multipurpose X11 plotting program
|
6
graphics/plotmtv/pkg/DESCR
Normal file
6
graphics/plotmtv/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Plotmtv's capabilities include 2D line and scatter plots (x-vs-y),
|
||||
contour plots, 3D surface, line and scatter plots as well as vector
|
||||
plots. The program has a rough but functional Graphical User
|
||||
Interface, through which it is possible to zoom in, zoom out, pan,
|
||||
toggle between 2D and 3D plots, and rotate 3D plots. Both color and
|
||||
grayscale postscript output are supported.
|
42
graphics/plotmtv/pkg/PLIST
Normal file
42
graphics/plotmtv/pkg/PLIST
Normal file
|
@ -0,0 +1,42 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/11/25 21:06:04 jtb Exp $
|
||||
bin/ctr2mtv
|
||||
bin/drawplot2mtv
|
||||
bin/mtv2mtv
|
||||
bin/pdraw2mtv
|
||||
bin/plotmtv
|
||||
man/cat1/plotmtv.0
|
||||
share/examples/plotmtv/run.csh
|
||||
share/examples/plotmtv/run.sh
|
||||
share/examples/plotmtv/test_abs.mtv
|
||||
share/examples/plotmtv/test_abs2.mtv
|
||||
share/examples/plotmtv/test_annot.mtv
|
||||
share/examples/plotmtv/test_annot2.mtv
|
||||
share/examples/plotmtv/test_axisflip.mtv
|
||||
share/examples/plotmtv/test_axislabel.mtv
|
||||
share/examples/plotmtv/test_bar.mtv
|
||||
share/examples/plotmtv/test_column.mtv
|
||||
share/examples/plotmtv/test_column2.mtv
|
||||
share/examples/plotmtv/test_ctrcolors.mtv
|
||||
share/examples/plotmtv/test_ctrelb.mtv
|
||||
share/examples/plotmtv/test_ctrelb2.mtv
|
||||
share/examples/plotmtv/test_ctrelb3.mtv
|
||||
share/examples/plotmtv/test_ctrs.mtv
|
||||
share/examples/plotmtv/test_curve2D.mtv
|
||||
share/examples/plotmtv/test_curve3D.mtv
|
||||
share/examples/plotmtv/test_curve3D2.mtv
|
||||
share/examples/plotmtv/test_exp.mtv
|
||||
share/examples/plotmtv/test_fillclrs.mtv
|
||||
share/examples/plotmtv/test_fillclrs2.mtv
|
||||
share/examples/plotmtv/test_grid4D.mtv
|
||||
share/examples/plotmtv/test_histogram.mtv
|
||||
share/examples/plotmtv/test_lines.mtv
|
||||
share/examples/plotmtv/test_log.mtv
|
||||
share/examples/plotmtv/test_markers.mtv
|
||||
share/examples/plotmtv/test_prob.mtv
|
||||
share/examples/plotmtv/test_pyramid.mtv
|
||||
share/examples/plotmtv/test_smallnum.mtv
|
||||
share/examples/plotmtv/test_spln.mtv
|
||||
share/examples/plotmtv/test_trictr.mtv
|
||||
share/examples/plotmtv/test_vector.mtv
|
||||
share/examples/plotmtv/test_vector2.mtv
|
||||
@dirrm share/examples/plotmtv
|
Loading…
Reference in a new issue