Fixed "test ==".

This commit is contained in:
rillig 2006-10-17 21:32:37 +00:00
parent be3ce4cfc1
commit 0f4de084ed
2 changed files with 16 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2006/05/29 19:44:24 joerg Exp $
$NetBSD: distinfo,v 1.3 2006/10/17 21:32:37 rillig Exp $
SHA1 (Csound5.01_src.tar.gz) = b387da9b6c24961397e89ddcedd1229cdfebffe7
RMD160 (Csound5.01_src.tar.gz) = 24652f8f650464d886f6d537ae991654f475ad4a
@ -16,3 +16,4 @@ SHA1 (patch-al) = 7da1e82a280b6803e2f0f75b8fb1eafbc3206636
SHA1 (patch-am) = 9770973e54770b9eebcf66c17f90f459e71a71c6
SHA1 (patch-an) = 7dfbd38a4eca8c7767a53c2b93bb4967344c0f0e
SHA1 (patch-ao) = 64ee0a2a70dd317c992088212bc3f241f6296113
SHA1 (patch-ap) = 9229c0166b37fb6991da5557c475d754715df711

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ap,v 1.1 2006/10/17 21:32:37 rillig Exp $
--- cleanup.sh.orig 2005-12-20 20:50:46.000000000 +0100
+++ cleanup.sh 2006-10-17 23:28:47.000000000 +0200
@@ -1,7 +1,7 @@
#!/bin/sh
-if [ "$#" == "2" ] ; then
- if [ "$1" == "remove" ] ; then
+if [ "$#" = "2" ] ; then
+ if [ "$1" = "remove" ] ; then
if ( test -e "$2" ) ; then
echo -e "Removing '$2'"
rm -Rf "$2" ;