Fix incorrect use of "glib2" inlining which breaks the build if C99

compliant inlining is used. This package builds again with the
Mac OS X Leopard patch in the "glib2" package.
This commit is contained in:
tron 2007-11-26 14:00:41 +00:00
parent f845b85681
commit 0f7788d98b
2 changed files with 19 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.38 2007/10/31 19:48:32 drochner Exp $
$NetBSD: distinfo,v 1.39 2007/11/26 14:00:41 tron Exp $
SHA1 (ORBit2-2.14.10.tar.bz2) = f5d7bbe36562b5daad48b92cc5b17afa12d211ee
RMD160 (ORBit2-2.14.10.tar.bz2) = f6df0bf38218ba0d02e2e332d570cf3e1831ec53
@ -6,3 +6,4 @@ Size (ORBit2-2.14.10.tar.bz2) = 734630 bytes
SHA1 (patch-aa) = 6e87e28e3634908f35c219f81a47d0353cfaf551
SHA1 (patch-ab) = 1661eaaa0119895a860e0c667990ea71b80e8ace
SHA1 (patch-ac) = 075a11883b9d0a3ec7d5d93b37007ba64e1baf41
SHA1 (patch-ad) = a6599d163cf577230b310845999cee2d343d7613

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ad,v 1.3 2007/11/26 14:00:41 tron Exp $
--- include/orbit/GIOP/giop-endian.h.orig 2007-09-10 13:11:47.000000000 +0100
+++ include/orbit/GIOP/giop-endian.h 2007-11-26 13:48:57.000000000 +0000
@@ -8,9 +8,9 @@
#ifdef ORBIT2_INTERNAL_API
/* This is also defined in IIOP-types.c */
-void giop_byteswap(guchar *outdata,
- const guchar *data,
- gulong datalen);
+G_INLINE_FUNC void giop_byteswap(guchar *outdata,
+ const guchar *data,
+ gulong datalen);
#if defined(G_CAN_INLINE) && !defined(GIOP_DO_NOT_INLINE_IIOP_BYTESWAP)
G_INLINE_FUNC void giop_byteswap(guchar *outdata,