Update databases/lmdb to 0.9.16.
Use Github for distfiles. Simplify build/install fixes. Readability. LMDB 0.9.16 Release (2015/08/14) - Fix cursor EOF bug (ITS#8190) - Fix handling of subDB records (ITS#8181) - Fix mdb_midl_shrink() usage (ITS#8200) LMDB 0.9.15 Release (2015/06/19) - Fix txn init (ITS#7961,#7987) - Fix MDB_PREV_DUP (ITS#7955,#7671) - Fix compact of empty env (ITS#7956) - Fix mdb_copy file mode - Fix mdb_env_close() after failed mdb_env_open() - Fix mdb_rebalance collapsing root (ITS#8062) - Fix mdb_load with large values (ITS#8066) - Fix to retry writes on EINTR (ITS#8106) - Fix mdb_cursor_del on empty DB (ITS#8109) - Fix MDB_INTEGERDUP key compare (ITS#8117) - Fix error handling (ITS#7959,#8157,etc.) - Fix race conditions (ITS#7969,7970) - Added workaround for fdatasync bug in ext3fs - Don't use -fPIC for static lib - Update .gitignore (ITS#7952,#7953) - Cleanup for "make test" (ITS#7841), "make clean", mtest*.c - Misc. Android/Windows cleanup - Fix MDB_APPEND doc - Fix MDB_MAXKEYSIZE doc (ITS#8156) - Fix mdb_cursor_put,mdb_cursor_del EACCES description - Fix mdb_env_sync(MDB_RDONLY env) doc (ITS#8021) - Clarify MDB_WRITEMAP doc (ITS#8021) - Clarify mdb_env_open doc - Clarify mdb_dbi_open doc
This commit is contained in:
parent
ae4a085aa9
commit
0f7dfb2d8a
3 changed files with 42 additions and 25 deletions
|
@ -1,34 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.3 2015/10/07 10:00:20 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2015/10/07 10:15:12 fhajny Exp $
|
||||
|
||||
VERSION= 0.9.14
|
||||
DISTNAME= mdb-${VERSION}
|
||||
PKGNAME= lmdb-${VERSION}
|
||||
PKGREVISION= 1
|
||||
DISTNAME= LMDB-0.9.16
|
||||
PKGNAME= ${DISTNAME:tl}
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://ftp.NetBSD.org/pub/pkgsrc/distfiles/
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=LMDB/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://symas.com/mdb/
|
||||
COMMENT= Symas Lightning Memory-Mapped Database
|
||||
USE_TOOLS+= gmake
|
||||
INSTALLATION_DIRS+= man/man1
|
||||
INSTALLATION_DIRS+= lib
|
||||
INSTALLATION_DIRS+= bin
|
||||
INSTALLATION_DIRS+= include
|
||||
LICENSE= modified-bsd
|
||||
|
||||
WRKSRC= ${WRKDIR}/mdb-mdb
|
||||
BUILD_DIRS= libraries/liblmdb
|
||||
GITHUB_PROJECT= ${PKGBASE}
|
||||
GITHUB_TAG= ${DISTNAME:S/-/_/}
|
||||
WRKSRC= ${WRKDIR}/${PKGBASE}-${GITHUB_TAG}
|
||||
|
||||
USE_GCC_RUNTIME= yes
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
SUBST_CLASSES+= makefile
|
||||
SUBST_STAGE.makefile= pre-configure
|
||||
SUBST_MESSAGE.makefile= Fixing CFLAGS and PREFIX
|
||||
SUBST_FILES.makefile= libraries/liblmdb/Makefile
|
||||
SUBST_SED.makefile= -e 's,/usr/local,${PREFIX},g'
|
||||
SUBST_SED.makefile+= -e 's,XCFLAGS),XCFLAGS) -D_SEM_SEMUN_UNDEFINED ,g'
|
||||
SUBST_SED.makefile+= -e 's,gcc,${CC},g'
|
||||
SUBST_SED.makefile+= -e 's,do cp,do install,g'
|
||||
BUILD_DIRS= libraries/liblmdb
|
||||
MAKE_FLAGS+= XCFLAGS=-D_SEM_SEMUN_UNDEFINED
|
||||
INSTALL_MAKE_FLAGS+= prefix=${PREFIX}
|
||||
|
||||
INSTALLATION_DIRS+= bin
|
||||
INSTALLATION_DIRS+= include
|
||||
INSTALLATION_DIRS+= lib
|
||||
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2015/03/01 21:05:54 mspo Exp $
|
||||
$NetBSD: distinfo,v 1.2 2015/10/07 10:15:12 fhajny Exp $
|
||||
|
||||
SHA1 (mdb-0.9.14.tar.gz) = 672fd3b3431fe47252ae2bdc6f2c64d9e0857e8b
|
||||
RMD160 (mdb-0.9.14.tar.gz) = 9d6197d447b21403be50bc6db336c3af102339a3
|
||||
Size (mdb-0.9.14.tar.gz) = 131208 bytes
|
||||
SHA1 (LMDB-0.9.16.tar.gz) = 367182e1d9dbc314db76459a71be719209f131b4
|
||||
RMD160 (LMDB-0.9.16.tar.gz) = 7b6701cb74e04593b1258377164f04f91f502aaf
|
||||
Size (LMDB-0.9.16.tar.gz) = 130343 bytes
|
||||
SHA1 (patch-libraries_liblmdb_Makefile) = fa0543f50fbc1ea964841c26811dd16965f127af
|
||||
|
|
21
databases/lmdb/patches/patch-libraries_liblmdb_Makefile
Normal file
21
databases/lmdb/patches/patch-libraries_liblmdb_Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-libraries_liblmdb_Makefile,v 1.1 2015/10/07 10:15:12 fhajny Exp $
|
||||
|
||||
Use proper install commands.
|
||||
|
||||
--- libraries/liblmdb/Makefile.orig 2015-08-14 00:00:38.000000000 +0000
|
||||
+++ libraries/liblmdb/Makefile
|
||||
@@ -36,10 +36,10 @@ PROGS = $(IPROGS) mtest mtest2 mtest3 mt
|
||||
all: $(ILIBS) $(PROGS)
|
||||
|
||||
install: $(ILIBS) $(IPROGS) $(IHDRS)
|
||||
- for f in $(IPROGS); do cp $$f $(DESTDIR)$(prefix)/bin; done
|
||||
- for f in $(ILIBS); do cp $$f $(DESTDIR)$(prefix)/lib; done
|
||||
- for f in $(IHDRS); do cp $$f $(DESTDIR)$(prefix)/include; done
|
||||
- for f in $(IDOCS); do cp $$f $(DESTDIR)$(prefix)/man/man1; done
|
||||
+ for f in $(IPROGS); do $(BSD_INSTALL_PROGRAM) $$f $(DESTDIR)$(prefix)/bin; done
|
||||
+ for f in $(ILIBS); do $(BSD_INSTALL_LIB) $$f $(DESTDIR)$(prefix)/lib; done
|
||||
+ for f in $(IHDRS); do $(BSD_INSTALL_DATA) $$f $(DESTDIR)$(prefix)/include; done
|
||||
+ for f in $(IDOCS); do $(BSD_INSTALL_MAN) $$f $(DESTDIR)$(prefix)/$(PKGMANDIR)/man1; done
|
||||
|
||||
clean:
|
||||
rm -rf $(PROGS) *.[ao] *.[ls]o *~ testdb
|
Loading…
Reference in a new issue