lang/ruby30-base: update to 3.0.3

Ruby 3.0.3 Released
Posted by nagachika on 24 Nov 2021

Ruby 3.0.3 has been released.

This release includes security fixes.  Please check the topics below for
details.

* CVE-2021-41817: Regular Expression Denial of Service Vulnerability of Date
  Parsing Methods

* CVE-2021-41816: Buffer Overrun in CGI.escape_html

* CVE-2021-41819: Cookie Prefix Spoofing in CGI::Cookie.parse

See the commit logs for details.
This commit is contained in:
taca 2021-11-25 16:35:52 +00:00
parent 606cb049b9
commit 0f8155171c
4 changed files with 114 additions and 55 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: rubyversion.mk,v 1.239 2021/11/25 16:01:18 taca Exp $
# $NetBSD: rubyversion.mk,v 1.240 2021/11/25 16:35:52 taca Exp $
#
# This file determines which Ruby version is used as a dependency for
@ -215,7 +215,7 @@ RUBY_VERSION_REQD?= ${PKGNAME_REQD:C/ruby([0-9][0-9])-.*/\1/}
# current supported Ruby's version
RUBY26_VERSION= 2.6.9
RUBY27_VERSION= 2.7.5
RUBY30_VERSION= 3.0.2
RUBY30_VERSION= 3.0.3
# current API compatible version; used for version of shared library
RUBY26_API_VERSION= 2.6.0
@ -377,37 +377,37 @@ RUBY_SUFFIX= ${_RUBY_VER_MAJOR}${_RUBY_VER_MINOR}
RUBY_VERSION= ${RUBY30_VERSION}
RUBY_ABI_VERSION= ${RUBY_VERSION}
RUBY_RDOC_VERSION= 6.3.1
RUBY_RDOC_VERSION= 6.3.3
# bundled gems
RUBY_MINITEST_VERSION= 5.14.2
RUBY_POWER_ASSERT_VERSION= 1.2.0
RUBY_RAKE_VERSION= 13.0.3
RUBY_RBS_VERSION= 1.0.4
RUBY_RBS_VERSION= 1.4.0
RUBY_REXML_VERSION= 3.2.5
RUBY_RSS_VERSION= 0.2.9
RUBY_TEST_UNIT_VERSION= 3.3.7
RUBY_TYPEPROF_VERSION= 0.12.0
RUBY_TYPEPROF_VERSION= 0.15.2
# bundled extensions
RUBY_BIGDECIMAL_VERSION= 3.0.0
RUBY_DATE_VERSION= 3.1.0
RUBY_DATE_VERSION= 3.1.3
RUBY_DBM_VERSION= 1.1.0
RUBY_DIGEST_VERSION= 3.0.0
RUBY_ETC_VERSION= 1.2.0
RUBY_FCNTL_VERSION= 1.0.0
RUBY_ETC_VERSION= 1.3.0
RUBY_FCNTL_VERSION= 1.0.1
RUBY_FIDDLE_VERSION= 1.0.4
RUBY_IO_CONSOLE_VERSION= 0.5.7
RUBY_JSON_VERSION= 2.5.1
RUBY_OPENSSL_VERSION= 2.2.0
RUBY_PSYCH_VERSION= 3.3.0
RUBY_RACC_VERSION= 1.5.1
RUBY_STRINGIO_VERSION= 3.0.0
RUBY_STRSCAN_VERSION= 3.0.0
RUBY_ZLIB_VERSION= 1.1.0
RUBY_OPENSSL_VERSION= 2.2.1
RUBY_PSYCH_VERSION= 3.3.2
RUBY_RACC_VERSION= 1.5.2
RUBY_STRINGIO_VERSION= 3.0.1
RUBY_STRSCAN_VERSION= 3.0.1
RUBY_ZLIB_VERSION= 2.0.0
# bundled libraries
RUBY_BUNDLER_VERSION= 2.2.22
RUBY_BUNDLER_VERSION= 2.2.32
RUBY_CSV_VERSION= 3.1.9
RUBY_DID_YOU_MEAN_VERSION= 1.5.0
RUBY_FILEUTILS_VERSION= 1.5.0

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2021/07/07 16:10:01 taca Exp $
@comment $NetBSD: PLIST,v 1.4 2021/11/25 16:35:52 taca Exp $
bin/bundle${RUBY_SUFFIX}
bin/bundler${RUBY_SUFFIX}
bin/erb${RUBY_SUFFIX}
@ -192,7 +192,7 @@ ${RUBY_INC}/ruby/thread_native.h
${RUBY_INC}/ruby/util.h
${RUBY_INC}/ruby/version.h
${RUBY_INC}/ruby/vm.h
${RUBY_ARCHINC}/rb_mjit_min_header-${RUBY_VERSION}.h
${RUBY_ARCHINC}/rb_mjit_min_header-3.0.3.h
${RUBY_ARCHINC}/ruby/config.h
lib/libruby${RUBY_STATICLIB}
lib/libruby${RUBY_SUFFIX}.${RUBY_SLEXT}
@ -253,6 +253,7 @@ ${RUBY_LIB}/bundler/dep_proxy.rb
${RUBY_LIB}/bundler/dependency.rb
${RUBY_LIB}/bundler/deployment.rb
${RUBY_LIB}/bundler/deprecate.rb
${RUBY_LIB}/bundler/digest.rb
${RUBY_LIB}/bundler/dsl.rb
${RUBY_LIB}/bundler/endpoint_specification.rb
${RUBY_LIB}/bundler/env.rb
@ -403,6 +404,7 @@ ${RUBY_LIB}/bundler/templates/newgem/rspec.tt
${RUBY_LIB}/bundler/templates/newgem/rubocop.yml.tt
${RUBY_LIB}/bundler/templates/newgem/spec/newgem_spec.rb.tt
${RUBY_LIB}/bundler/templates/newgem/spec/spec_helper.rb.tt
${RUBY_LIB}/bundler/templates/newgem/standard.yml.tt
${RUBY_LIB}/bundler/templates/newgem/test/minitest/newgem_test.rb.tt
${RUBY_LIB}/bundler/templates/newgem/test/minitest/test_helper.rb.tt
${RUBY_LIB}/bundler/templates/newgem/test/test-unit/newgem_test.rb.tt
@ -414,9 +416,9 @@ ${RUBY_LIB}/bundler/ui/shell.rb
${RUBY_LIB}/bundler/ui/silent.rb
${RUBY_LIB}/bundler/uri_credentials_filter.rb
${RUBY_LIB}/bundler/vendor/connection_pool/lib/connection_pool.rb
${RUBY_LIB}/bundler/vendor/connection_pool/lib/connection_pool/monotonic_time.rb
${RUBY_LIB}/bundler/vendor/connection_pool/lib/connection_pool/timed_stack.rb
${RUBY_LIB}/bundler/vendor/connection_pool/lib/connection_pool/version.rb
${RUBY_LIB}/bundler/vendor/connection_pool/lib/connection_pool/wrapper.rb
${RUBY_LIB}/bundler/vendor/fileutils/lib/fileutils.rb
${RUBY_LIB}/bundler/vendor/molinillo/lib/molinillo.rb
${RUBY_LIB}/bundler/vendor/molinillo/lib/molinillo/delegates/resolution_state.rb
@ -474,6 +476,7 @@ ${RUBY_LIB}/bundler/vendor/thor/lib/thor/shell/html.rb
${RUBY_LIB}/bundler/vendor/thor/lib/thor/util.rb
${RUBY_LIB}/bundler/vendor/thor/lib/thor/version.rb
${RUBY_LIB}/bundler/vendor/tmpdir/lib/tmpdir.rb
${RUBY_LIB}/bundler/vendor/tsort/lib/tsort.rb
${RUBY_LIB}/bundler/vendor/uri/lib/uri.rb
${RUBY_LIB}/bundler/vendor/uri/lib/uri/common.rb
${RUBY_LIB}/bundler/vendor/uri/lib/uri/file.rb
@ -492,6 +495,7 @@ ${RUBY_LIB}/bundler/vendored_molinillo.rb
${RUBY_LIB}/bundler/vendored_persistent.rb
${RUBY_LIB}/bundler/vendored_thor.rb
${RUBY_LIB}/bundler/vendored_tmpdir.rb
${RUBY_LIB}/bundler/vendored_tsort.rb
${RUBY_LIB}/bundler/vendored_uri.rb
${RUBY_LIB}/bundler/version.rb
${RUBY_LIB}/bundler/version_ranges.rb
@ -1015,12 +1019,21 @@ ${RUBY_LIB}/rubygems/install_default_message.rb
${RUBY_LIB}/rubygems/install_message.rb
${RUBY_LIB}/rubygems/install_update_options.rb
${RUBY_LIB}/rubygems/installer.rb
${RUBY_LIB}/rubygems/installer_test_case.rb
${RUBY_LIB}/rubygems/installer_uninstaller_utils.rb
${RUBY_LIB}/rubygems/local_remote_options.rb
${RUBY_LIB}/rubygems/mock_gem_ui.rb
${RUBY_LIB}/rubygems/name_tuple.rb
${RUBY_LIB}/rubygems/openssl.rb
${RUBY_LIB}/rubygems/optparse.rb
${RUBY_LIB}/rubygems/optparse/lib/optionparser.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/ac.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/date.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/kwargs.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/shellwords.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/time.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/uri.rb
${RUBY_LIB}/rubygems/optparse/lib/optparse/version.rb
${RUBY_LIB}/rubygems/package.rb
${RUBY_LIB}/rubygems/package/digest_io.rb
${RUBY_LIB}/rubygems/package/file_source.rb
@ -1030,7 +1043,6 @@ ${RUBY_LIB}/rubygems/package/source.rb
${RUBY_LIB}/rubygems/package/tar_header.rb
${RUBY_LIB}/rubygems/package/tar_reader.rb
${RUBY_LIB}/rubygems/package/tar_reader/entry.rb
${RUBY_LIB}/rubygems/package/tar_test_case.rb
${RUBY_LIB}/rubygems/package/tar_writer.rb
${RUBY_LIB}/rubygems/package_task.rb
${RUBY_LIB}/rubygems/path_support.rb
@ -1121,14 +1133,12 @@ ${RUBY_LIB}/rubygems/specification_policy.rb
${RUBY_LIB}/rubygems/ssl_certs/rubygems.org/GlobalSignRootCA.pem
${RUBY_LIB}/rubygems/ssl_certs/rubygems.org/GlobalSignRootCA_R3.pem
${RUBY_LIB}/rubygems/stub_specification.rb
${RUBY_LIB}/rubygems/syck_hack.rb
${RUBY_LIB}/rubygems/test_case.rb
${RUBY_LIB}/rubygems/test_utilities.rb
${RUBY_LIB}/rubygems/text.rb
${RUBY_LIB}/rubygems/tsort.rb
${RUBY_LIB}/rubygems/tsort/lib/tsort.rb
${RUBY_LIB}/rubygems/uninstaller.rb
${RUBY_LIB}/rubygems/uri.rb
${RUBY_LIB}/rubygems/uri_formatter.rb
${RUBY_LIB}/rubygems/uri_parser.rb
${RUBY_LIB}/rubygems/uri_parsing.rb
${RUBY_LIB}/rubygems/user_interaction.rb
${RUBY_LIB}/rubygems/util.rb
${RUBY_LIB}/rubygems/util/licenses.rb
@ -1410,15 +1420,6 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/Gemfile
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/README.md
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/Rakefile
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/Steepfile
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/annotate-with-rdoc
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/console
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/query-rdoc
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/rbs-prof
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/run_in_md.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/setup
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/sort
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/steep
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/bin/test_runner.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/array.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/basic_object.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/binding.rbs
@ -1442,6 +1443,7 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/file.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/file_test.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/float.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/gc.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/global_variables.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/hash.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/integer.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/io.rbs
@ -1476,6 +1478,7 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/true_class.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/unbound_method.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/core/warning.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/docs/CONTRIBUTING.md
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/docs/rbs_by_example.md
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/docs/repo.md
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/docs/sigs.md
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/docs/stdlib.md
@ -1483,12 +1486,14 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/docs/syntax.md
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/exe/rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/goodcheck.yml
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/ancestor_graph.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/ast/annotation.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/ast/comment.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/ast/declarations.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/ast/members.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/buffer.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/builtin_names.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/char_scanner.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/cli.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/constant.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/constant_table.rb
@ -1502,6 +1507,7 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/environment_walker.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/errors.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/factory.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/location.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/locator.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/method_type.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/namespace.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/parser.rb
@ -1520,6 +1526,7 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/test/setup_helper.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/test/spy.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/test/tester.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/test/type_check.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/type_alias_dependency.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/type_name.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/type_name_resolver.rb
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/lib/rbs/types.rb
@ -1538,9 +1545,11 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/schema/members.json
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/schema/methodType.json
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/schema/types.json
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/ancestor_builder.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/ancestor_graph.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/annotation.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/buffer.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/builtin_names.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/char_scanner.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/cli.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/comment.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/constant.rbs
@ -1550,8 +1559,10 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/definition.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/definition_builder.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/environment.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/environment_loader.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/environment_walker.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/errors.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/location.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/locator.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/members.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/method_builder.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/method_types.rbs
@ -1561,6 +1572,7 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/polyfill.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/rbs.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/repository.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/substitution.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/type_alias_dependency.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/type_name_resolver.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/typename.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/sig/types.rbs
@ -1575,6 +1587,7 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/base64/0/base64.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/benchmark/0/benchmark.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/bigdecimal-math/0/big_math.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/bigdecimal/0/big_decimal.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/cgi/0/core.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/coverage/0/coverage.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/csv/0/csv.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/date/0/date.rbs
@ -1594,16 +1607,46 @@ ${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/logger/0/period.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/logger/0/severity.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/monitor/0/monitor.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/mutex_m/0/mutex_m.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/net-http/0/net-http.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/openssl/0/openssl.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/optparse/0/optparse.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/pathname/0/pathname.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/prettyprint/0/prettyprint.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/prime/0/integer-extension.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/prime/0/prime.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/pstore/0/pstore.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/pty/0/pty.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/resolv/0/resolv.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/basic_specification.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/config_file.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/dependency_installer.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/installer.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/path_support.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/platform.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/request_set.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/requirement.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/rubygems.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/source_list.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/specification.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/stream_ui.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/uninstaller.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/rubygems/0/version.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/securerandom/0/securerandom.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/set/0/set.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/shellwords/0/shellwords.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/singleton/0/singleton.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/addrinfo.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/basic_socket.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/ip_socket.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/socket.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/tcp_server.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/tcp_socket.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/udp_socket.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/unix_server.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/socket/0/unix_socket.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/strscan/0/string_scanner.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/time/0/time.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/timeout/0/timeout.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/tmpdir/0/tmpdir.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/tsort/0/cyclic.rbs
${GEM_HOME}/gems/rbs-${RUBY_RBS_VERSION}/stdlib/tsort/0/interfaces.rbs
@ -1984,6 +2027,7 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/blown.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/break1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/break2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/break3.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/break4.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/case.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/case2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/case3.rb
@ -1991,6 +2035,7 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class-hierarchy.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class-hierarchy2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class-new.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class_eval.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class_instance_var.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class_method.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/class_method2.rb
@ -2010,6 +2055,7 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/define_method4.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/define_method4.rbs
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/define_method5.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/define_method6.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/define_method7.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/demo.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/demo1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/demo10.rb
@ -2031,10 +2077,12 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/enum_for2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/enumerator.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/expandarray1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/expandarray2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/extended.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/fib.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flip-flop.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flow1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flow10.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flow11.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flow2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flow3.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/flow4.rb
@ -2057,12 +2105,17 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/hash2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/hash3.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/hash4.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/hash5.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/huge_union.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/identifier_keywords.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/included.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/inheritance.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/inheritance2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/inherited.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/initialize.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/instance_eval.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/instance_eval2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/instance_eval3.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/instance_eval4.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/int_times.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/integer.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/ivar.rb
@ -2105,6 +2158,7 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/multiple-include.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/multiple-superclass.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/next1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/next2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/noname.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/object-send1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/object-send2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/object-send3.rb
@ -2112,6 +2166,7 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/once.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/optional1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/optional2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/optional3.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/or_raise.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/parameterizedd-self.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/parameterizedd-self2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/pathname1.rb
@ -2128,6 +2183,8 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/proc2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/proc3.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/proc4.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/proc5.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/proc6.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/proc7.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/public.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/range.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/rbs-alias.rb
@ -2170,6 +2227,8 @@ ${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/rbs-vars.rbs
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/redo1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/redo2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/req-keyword.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/require1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/require2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/rescue1.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/rescue2.rb
${GEM_HOME}/gems/typeprof-${RUBY_TYPEPROF_VERSION}/smoke/rescue3.rb
@ -2232,15 +2291,15 @@ ${GEM_HOME}/specifications/default/base64-0.1.0.gemspec
${GEM_HOME}/specifications/default/benchmark-0.1.1.gemspec
${GEM_HOME}/specifications/default/bigdecimal-${RUBY_BIGDECIMAL_VERSION}.gemspec
${GEM_HOME}/specifications/default/bundler-${RUBY_BUNDLER_VERSION}.gemspec
${GEM_HOME}/specifications/default/cgi-0.2.0.gemspec
${GEM_HOME}/specifications/default/cgi-0.2.1.gemspec
${GEM_HOME}/specifications/default/csv-${RUBY_CSV_VERSION}.gemspec
${GEM_HOME}/specifications/default/date-${RUBY_DATE_VERSION}.gemspec
${GEM_HOME}/specifications/default/dbm-${RUBY_DBM_VERSION}.gemspec
${GEM_HOME}/specifications/default/debug-0.1.0.gemspec
${GEM_HOME}/specifications/default/debug-0.2.1.gemspec
${GEM_HOME}/specifications/default/delegate-0.2.0.gemspec
${GEM_HOME}/specifications/default/did_you_mean-${RUBY_DID_YOU_MEAN_VERSION}.gemspec
${GEM_HOME}/specifications/default/digest-${RUBY_DIGEST_VERSION}.gemspec
${GEM_HOME}/specifications/default/drb-2.0.4.gemspec
${GEM_HOME}/specifications/default/drb-2.0.5.gemspec
${GEM_HOME}/specifications/default/english-0.7.1.gemspec
${GEM_HOME}/specifications/default/erb-2.2.0.gemspec
${GEM_HOME}/specifications/default/etc-${RUBY_ETC_VERSION}.gemspec
@ -2251,7 +2310,7 @@ ${GEM_HOME}/specifications/default/forwardable-${RUBY_FORWARDABLE_VERSION}.gemsp
${GEM_HOME}/specifications/default/getoptlong-${RUBY_GETOPTLONG_VERSION}.gemspec
${PLIST.io}${GEM_HOME}/specifications/default/io-console-${RUBY_IO_CONSOLE_VERSION}.gemspec
${GEM_HOME}/specifications/default/io-nonblock-0.1.0.gemspec
${GEM_HOME}/specifications/default/io-wait-0.1.0.gemspec
${GEM_HOME}/specifications/default/io-wait-0.2.0.gemspec
${GEM_HOME}/specifications/default/ipaddr-${RUBY_IPADDR_VERSION}.gemspec
${GEM_HOME}/specifications/default/irb-${RUBY_IRB_VERSION}.gemspec
${GEM_HOME}/specifications/default/json-${RUBY_JSON_VERSION}.gemspec
@ -2262,18 +2321,18 @@ ${GEM_HOME}/specifications/default/net-ftp-${RUBY_NET_FTP_VERSION}.gemspec
${GEM_HOME}/specifications/default/net-http-0.1.1.gemspec
${GEM_HOME}/specifications/default/net-imap-0.1.1.gemspec
${GEM_HOME}/specifications/default/net-pop-0.1.1.gemspec
${GEM_HOME}/specifications/default/net-protocol-0.1.0.gemspec
${GEM_HOME}/specifications/default/net-protocol-0.1.1.gemspec
${GEM_HOME}/specifications/default/net-smtp-0.2.1.gemspec
${GEM_HOME}/specifications/default/nkf-0.1.0.gemspec
${GEM_HOME}/specifications/default/observer-0.1.1.gemspec
${GEM_HOME}/specifications/default/open-uri-0.1.0.gemspec
${GEM_HOME}/specifications/default/open3-0.1.1.gemspec
${GEM_HOME}/specifications/default/openssl-${RUBY_OPENSSL_VERSION}.gemspec
${GEM_HOME}/specifications/default/optparse-0.1.0.gemspec
${GEM_HOME}/specifications/default/optparse-0.1.1.gemspec
${GEM_HOME}/specifications/default/ostruct-${RUBY_OSTRUCT_VERSION}.gemspec
${GEM_HOME}/specifications/default/pathname-0.1.0.gemspec
${GEM_HOME}/specifications/default/pp-0.1.0.gemspec
${GEM_HOME}/specifications/default/prettyprint-0.1.0.gemspec
${GEM_HOME}/specifications/default/pp-0.2.1.gemspec
${GEM_HOME}/specifications/default/prettyprint-0.1.1.gemspec
${GEM_HOME}/specifications/default/prime-${RUBY_PRIME_VERSION}.gemspec
${GEM_HOME}/specifications/default/pstore-0.1.1.gemspec
${GEM_HOME}/specifications/default/psych-${RUBY_PSYCH_VERSION}.gemspec
@ -2281,9 +2340,9 @@ ${GEM_HOME}/specifications/default/racc-${RUBY_RACC_VERSION}.gemspec
${GEM_HOME}/specifications/default/rdoc-${RUBY_RDOC_VERSION}.gemspec
${GEM_HOME}/specifications/default/readline-0.0.2.gemspec
${GEM_HOME}/specifications/default/reline-0.2.5.gemspec
${GEM_HOME}/specifications/default/resolv-0.2.0.gemspec
${GEM_HOME}/specifications/default/resolv-0.2.1.gemspec
${GEM_HOME}/specifications/default/resolv-replace-0.1.0.gemspec
${GEM_HOME}/specifications/default/rinda-0.1.0.gemspec
${GEM_HOME}/specifications/default/rinda-0.1.1.gemspec
${GEM_HOME}/specifications/default/securerandom-0.1.0.gemspec
${GEM_HOME}/specifications/default/set-1.0.1.gemspec
${GEM_HOME}/specifications/default/shellwords-0.1.0.gemspec

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.6 2021/11/09 12:14:52 jperkin Exp $
$NetBSD: distinfo,v 1.7 2021/11/25 16:35:52 taca Exp $
BLAKE2s (ruby-3.0.2.tar.xz) = a475450d0808f13669ce156dfa1c49c8a48d6f2c3a51bcd016eca00263ea1df9
SHA512 (ruby-3.0.2.tar.xz) = 0f702e2d8ca1342a9d4284dbdd234a3588e057b92566353aa7c21835cf09a3932864b2acf459a976960a1704e9befa562155d36b98b7cda8bd99526e10a374c4
Size (ruby-3.0.2.tar.xz) = 14746080 bytes
BLAKE2s (ruby-3.0.3.tar.xz) = 4c2e9044c837710b2378059e65b43e1124d6d142be065de6d87df179391f4442
SHA512 (ruby-3.0.3.tar.xz) = bb9ea426278d5a7ac46595296f03b82d43df8b7db41045cdf85611e05e26c703c53f700494cd7cf5d4c27fa953bdc5c144317d7720812db0a6e3b6f4bc4d2e00
Size (ruby-3.0.3.tar.xz) = 14991880 bytes
SHA1 (patch-common.mk) = c23eed58427b2fd4ba8fdb3692f609701a666c6d
SHA1 (patch-configure) = a56184876caac5c24b2c2925f364d88c3ebc5662
SHA1 (patch-ext_dbm_extconf.rb) = c998f8735db54b1ae2bc8b6caa359ce88bc7a45b
@ -16,7 +16,7 @@ SHA1 (patch-lib_rubygems_commands_setup__command.rb) = 181bb7554d760182588b0e1b0
SHA1 (patch-lib_rubygems_defaults.rb) = 48b71108ec3d2202ac2b31fbcfa4af30db2bc817
SHA1 (patch-lib_rubygems_dependency__installer.rb) = 1776508907f17547ffe93f637d6f18d335061d76
SHA1 (patch-lib_rubygems_install__update__options.rb) = 1e953b5a517a805fd7184e359fbc06e67a5ff9b3
SHA1 (patch-lib_rubygems_installer.rb) = 4bcbed17d7db171986167afa10df873e4bc1b7d3
SHA1 (patch-lib_rubygems_installer.rb) = 03fcd57d4e7ea03cf2ffc3d219fd489e30361014
SHA1 (patch-lib_rubygems_platform.rb) = dc4c1073ffe331c06c477ee4b281db7aeb76fa92
SHA1 (patch-test_rubygems_test__gem.rb) = e624da5b9c49f9409160a7b0fdd2efad17986cab
SHA1 (patch-thread__pthread.c) = 7c1231933a2d6ce9d56891ab512371841697fbca

View file

@ -1,11 +1,11 @@
$NetBSD: patch-lib_rubygems_installer.rb,v 1.1 2021/02/14 14:32:41 taca Exp $
$NetBSD: patch-lib_rubygems_installer.rb,v 1.2 2021/11/25 16:35:52 taca Exp $
* Add install_root option for pkgsrc's rubygems support.
* Tweak build_info directory with destdir to store build_args.
--- lib/rubygems/installer.rb.orig 2020-12-25 03:33:01.000000000 +0000
--- lib/rubygems/installer.rb.orig 2021-11-24 11:12:15.000000000 +0000
+++ lib/rubygems/installer.rb
@@ -158,6 +158,9 @@ class Gem::Installer
@@ -166,6 +166,9 @@ class Gem::Installer
# foo_exec18.
# :ignore_dependencies:: Don't raise if a dependency is missing.
# :install_dir:: The directory to install the gem into.
@ -15,7 +15,7 @@ $NetBSD: patch-lib_rubygems_installer.rb,v 1.1 2021/02/14 14:32:41 taca Exp $
# :security_policy:: Use the specified security policy. See Gem::Security
# :user_install:: Indicate that the gem should be unpacked into the users
# personal gem directory.
@@ -669,7 +672,13 @@ class Gem::Installer
@@ -680,7 +683,13 @@ class Gem::Installer
# If the user has asked for the gem to be installed in a directory that is
# the system gem directory, then use the system bin directory, else create
# (or use) a new bin dir under the gem_home.
@ -30,8 +30,8 @@ $NetBSD: patch-lib_rubygems_installer.rb,v 1.1 2021/02/14 14:32:41 taca Exp $
@development = options[:development]
@build_root = options[:build_root]
@@ -906,6 +915,9 @@ TEXT
return if @build_args.empty?
@@ -930,6 +939,9 @@ TEXT
return if build_args.empty?
build_info_dir = File.join gem_home, 'build_info'
+ unless @install_root.nil? or @install_root.empty?