Fix build on SunOS.

This commit is contained in:
fhajny 2012-03-12 11:22:15 +00:00
parent 0b60b24404
commit 0fac662afa
3 changed files with 24 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.21 2012/03/06 17:38:59 ryoon Exp $
# $NetBSD: Makefile,v 1.22 2012/03/12 11:22:15 fhajny Exp $
#
DISTNAME= gpac-0.4.5
@ -21,7 +21,13 @@ USE_LANGUAGES= c c++
# not really GNU configure, but close enough
GNU_CONFIGURE= yes
.include "../../mk/bsd.prefs.mk"
CONFIGURE_ARGS+= --disable-wx
CONFIGURE_ARGS+= --X11-path=${X11BASE}
.if ${OPSYS} == "SunOS"
CONFIGURE_ARGS+= --enable-pic
.endif
.include "../../audio/faad2/buildlink3.mk"
.include "../../audio/liba52/buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2011/02/06 15:50:04 wiz Exp $
$NetBSD: distinfo,v 1.4 2012/03/12 11:22:15 fhajny Exp $
SHA1 (gpac-0.4.5.tar.gz) = 2ec03c1d7dc3f4d10c0f7b47696cc1e753a56fc8
RMD160 (gpac-0.4.5.tar.gz) = 21249249a412efa5d1237907cb6b8cfe6282e86f
@ -7,3 +7,4 @@ SHA1 (patch-aa) = bd4a1314fa80ced3cc4aaa632e4a522f877207a9
SHA1 (patch-ab) = 19bb0746ced98fbb438673a406a570cad7aaabb4
SHA1 (patch-ac) = 25f8b92a308b6a70fb160980fe86e7d3e3f3f0ac
SHA1 (patch-ad) = 32eac449b1b108937f9a723d7c4ba622182cf9ed
SHA1 (patch-extra_lib__include__ffmpeg__avio.h) = dff4609d59ec5da3788e2b613b73075eda0e7af0

View file

@ -0,0 +1,15 @@
$NetBSD: patch-extra_lib__include__ffmpeg__avio.h,v 1.1 2012/03/12 11:22:15 fhajny Exp $
SunOS already has offset_t defined.
--- extra_lib/include/ffmpeg/avio.h.orig 2007-05-30 15:54:08.000000000 +0000
+++ extra_lib/include/ffmpeg/avio.h
@@ -23,7 +23,9 @@
/* output byte stream handling */
+#if !defined(__sun)
typedef int64_t offset_t;
+#endif
/* unbuffered I/O */