stella: Update to 6.2.1
6.2 to 6.2.1: (June 20, 2020) * Fixed Pitfall II ROM not working correctly. * Fixed crashes when using some combinations of bankswitching schemes on incorrect ROMs, or when using invalid ROM file sizes, etc. * Fixed RIOT timer behaviour on reading/writing at the wraparound cycle. * Fixed incorrectly setting D6 bit on TIA reads in some cases. Related to this, improve 'tiadriven' option to randomize only D5..D0 bits. * Fixed custom palette and TV effects adjustable slider rounding issue. * Fixed some bugs in 3E+ scheme when using non-standard ROM sizes. * Fixed crash in Audio & Video dialog when opened from debugger, and the debugger window sometimes being resized when using the Options dialog. * Make NTSC custom phase shift not affect Yellow anymore. * Fixed '1x' snapshot mode; TV effects are now disabled. This mode now generates a clean, pixel-exact image. * Fixed mappings sometimes not being saved in the Retron77 port. * A ROM properties file may now be placed next to the ROM (with the same name as the ROM, except ending in .pro), and Stella will automatically apply the properties to the ROM. [NOTE: this was present in 6.2, but was mistakenly left out of the changelog] * Added button to Game Info dialog to save properties of the currently loaded ROM to a separate properties file (in the default save directory). This is useful in conjunction with the previous item. * Allow changing custom palette and TV effects adjustables in 1% steps again. * Updated documentation for changes in ROM properties key names. * The codebase now compiles under gcc6 again. Future versions will require gcc7, though. -Have fun!
This commit is contained in:
parent
681a9269cc
commit
0facecfddd
3 changed files with 8 additions and 29 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.5 2020/06/09 11:59:58 nia Exp $
|
||||
# $NetBSD: Makefile.common,v 1.6 2020/06/29 14:48:49 nia Exp $
|
||||
# used by emulators/stella/Makefile
|
||||
# used by emulators/libretro-stella/Makefile
|
||||
|
||||
DISTNAME= stella-6.2-src
|
||||
DISTNAME= stella-6.2.1-src
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=stella-emu/}
|
||||
GITHUB_RELEASE= ${PKGVERSION_NOREV}
|
||||
|
@ -18,6 +18,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//1}
|
|||
USE_LANGUAGES= c c++
|
||||
|
||||
# c++14
|
||||
GCC_REQD+= 5
|
||||
GCC_REQD+= 6
|
||||
|
||||
UNLIMIT_RESOURCES= datasize
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.28 2020/06/09 11:59:58 nia Exp $
|
||||
$NetBSD: distinfo,v 1.29 2020/06/29 14:48:49 nia Exp $
|
||||
|
||||
SHA1 (stella-6.2-src.tar.xz) = 3936d5ffbb870ae92cbfd27732632fdc543ccfce
|
||||
RMD160 (stella-6.2-src.tar.xz) = 5332be51144ae538b3a461e21b59df3cb860e23f
|
||||
SHA512 (stella-6.2-src.tar.xz) = 710b7980c1490c53e6a13ae99e56a089fb6d54b491332d8e7a81be182d06d6c5511cb2ff93791b3b94943266a52c2b0cc80080a64212e22ed1b6cf311c4277b4
|
||||
Size (stella-6.2-src.tar.xz) = 4239900 bytes
|
||||
SHA1 (patch-configure) = 4818245fe59c6c73e6d7647e7d3aed1f3c938c90
|
||||
SHA1 (stella-6.2.1-src.tar.xz) = 03508fdef44c003d15bbcd5fe8df4c7992e13d91
|
||||
RMD160 (stella-6.2.1-src.tar.xz) = a5ba66e6fa9cc672c314d1676d0270689da09123
|
||||
SHA512 (stella-6.2.1-src.tar.xz) = f6a8318db81da463cc10944228ac65f43d03823f50d9b2b37657e1c0161ee4d260226142acc9cbbf2fe4541b79a75856601bd44ac44e1f9f909ae11785f704ec
|
||||
Size (stella-6.2.1-src.tar.xz) = 4238636 bytes
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-configure,v 1.6 2019/09/08 20:04:54 dbj Exp $
|
||||
|
||||
pkgsrc cwrappers add -stdc=c++14 which causes an error
|
||||
when using clang -x c, so instead use -x c++ which works.
|
||||
|
||||
--- configure.orig 2019-06-02 16:25:55.000000000 +0000
|
||||
+++ configure
|
||||
@@ -385,9 +385,9 @@ cc_check_define __GNUC__ && have_gcc=yes
|
||||
|
||||
if test "$have_clang" = yes; then
|
||||
|
||||
- clang_minor=$( $CXX -dM -E -x c /dev/null | grep __clang_minor__ | sed -E 's/.* ([0-9]+).*/\1/' )
|
||||
- clang_patch=$( $CXX -dM -E -x c /dev/null | grep __clang_patchlevel__ | sed -E 's/.* ([0-9]+).*/\1/' )
|
||||
- clang_major=$( $CXX -dM -E -x c /dev/null | grep __clang_major__ | sed -E 's/.* ([0-9]+).*/\1/' )
|
||||
+ clang_minor=$( $CXX -dM -E -x c++ /dev/null | grep __clang_minor__ | sed -E 's/.* ([0-9]+).*/\1/' )
|
||||
+ clang_patch=$( $CXX -dM -E -x c++ /dev/null | grep __clang_patchlevel__ | sed -E 's/.* ([0-9]+).*/\1/' )
|
||||
+ clang_major=$( $CXX -dM -E -x c++ /dev/null | grep __clang_major__ | sed -E 's/.* ([0-9]+).*/\1/' )
|
||||
|
||||
cxx_version="$clang_major.$clang_minor.$clang_patch"
|
||||
|
Loading…
Reference in a new issue